View Full Version : [ubuntu] Can use wired router, can't log into admin section (D-Link DIR-628)

November 16th, 2009, 06:06 AM
I got this router, it's a D-Link DIR-628, I just bought it today. I can plug into it wired with my Ubuntu 9.1 laptop but I can't access the admin area. I'm supposed to go to either:
and it'll ask me for a password. That's what it says on the bottom of the router but there were warnings all over this thing to run the CD prior to plugging in the router. I ignored the warnings because the CD was Windows only and I obviously can't use it. Whenever I put in those addresses it just sits there searching for minutes and eventually fails. But I'm plugged into it wired right now and posting this.

November 16th, 2009, 07:47 PM
Well the router looks like it had been returned by someone that already accessed the admin area and changed the access IP. I held the RESET button on the back, tried it again and it worked fine.

But now I can connect to the wireless, I just can't load any webpages. Any ideas?