PDA

View Full Version : [ubuntu] samba asking for password



froggger
November 15th, 2009, 10:04 PM
I have a windows 7 machine that I have set up to share without requiring a password.
My other windows machines can access the shares fine, and so could my ubuntu rig too. Until just out of the blue i noticed the drives weren't connecting automatically like before. When I tried to do it manually, they asked me for a password.
There is nothing on my network that is passworded. Everything is open access. I don't even have a password on my windows 7 machine.

I have to assume that some update caused this, but i have no idea exactly when it started otherwise i'd hunt through the logs.
I updated to karmic after this started to see if that would fix it, but it didn't.

I'm considering a reinstall, but i'd prefer to avoid that if possible.

Any help?

froggger
November 18th, 2009, 01:40 AM
bump

dmizer
November 18th, 2009, 03:37 AM
Please see the 6th link in my sig.

froggger
November 21st, 2009, 12:04 AM
I tried all of those steps, none fixed it...

froggger
November 21st, 2009, 05:29 PM
bump

dmizer
November 21st, 2009, 07:12 PM
In Win7, please post the following. Go to:

start orb > control panel > network and sharing center > click on "Change advanced sharing settings"

What options are selected here?

froggger
November 21st, 2009, 10:04 PM
home(public is the same, minus the homegroup stuff of course)
network discovery-on
file printer sharing-on
public folder sharing-on
media streaming-on
file sharing connections-enable file sharing for devices that use 40- or 56-bin encryption(just in case that happened to be the problem, needless to say, it wasn't)
password protected sharing-off
homegroup- use user accounts and passwords to connect

dmizer
November 22nd, 2009, 01:23 AM
Please try changing "homegroup- use user accounts and passwords to connect" to "Allow Windows users to manage homegroup connections"

froggger
November 22nd, 2009, 06:07 PM
Just tried that, no dice.

dmizer
November 23rd, 2009, 02:23 AM
Just tried that, no dice.
Ok, I'll do some more testing when I get home from work.

froggger
November 25th, 2009, 02:34 AM
thanks, i may just reinstall, i guess i shouldn't have messed with what worked.

froggger
November 28th, 2009, 04:58 PM
I fixed it by using your other guide, thanks for the help
http://ubuntuforums.org/showthread.php?t=288534