View Full Version : [ubuntu] 9.10 - gtk ????

November 15th, 2009, 08:33 PM
I have 2 programs I wrote which I had last compiled in 9.04 that use libusb and GTK. With 9.10, it says it can't execute the binaries. I then tried to recompile them but found I hadn't installed the development lib for libusb. I double-checked and *thought* I had what I needed of GTK to be able to compile using it. So, I installed the libusb dev lib and the compiles still fail - it looks like it doesn't know anything about GTK.

So, obviously something has changed from 9.04 to 9.10, and as such I have the following questions I hope someone can answer:

(1) why wouldn't a binary compiled in 9.04 that uses libusb but not GTK not be able to run in 9.10?

(2) why wouldn't a binary compiled in 9.04 that uses libusb and GTK not be able to run in 9.10?

(3) did something change with GTK such that I have to change my includes or the change the paths for the compile?

(4) since these programs reference "special" USB devices, they have required special rules in udev. It seems with each new release something changes in udev, is not noted in the release notes, and I have to hunt all over to try to find what to do. So, have the udev rules syntax or structure changed again with 9.10?

ANY help would be GREATLY appreciated!

Thanks in advance!
Dave :)

November 15th, 2009, 08:43 PM
If it fails, let us know the output. I don't think that this is a general support question .. more likely the fact that the repos for 9.10 contain a newer version of C/C++ compilers.

November 15th, 2009, 09:07 PM
Okay, now this is strange. The "include" path for libraries on the gcc statement has libusb and libglade (I have it there so that if I decide to move to glade for screen development I won't have to change anything). Well, I didn't have libglade for development installed. The expansion of the "include" (I'm probably saying this wrong) didn't find libglade and as a result I don't think it made anything for the lib string, so the GTK stuff was never found. Being dumb that I am I would have thought that the expansion would have just not put in a lib path for a lib that didn't exist, or else give a warning.

As for the binaries, SOMETHING must have changed in 9.10 - just recompiling the source did the trick. Libglade still seems at the same level, the development lib for GTK seems at the same level, so all I can assume is that something changed in the internals of libusb? I would be curious to know.

As for error messages, all I did was ./xxxxxx to execute, as always, and it just said "unable to execute binary" - that was it. Just compiling in 9.10 let them run. Seems strange - did others have to recompile their programs, even with no changes, just to get them to run in 9.10?

Dave :)