PDA

View Full Version : [SOLVED] 9.10 - problem logging off, trying to start kde session



anewguy
November 15th, 2009, 09:21 AM
After *many* hours of downloads by Synaptic on my dialup connection, I finally think I have everything in 9.10 that I had in 9.04, including KDE. So, I decide to try a KDE session. First I select log out from my Gnome session, which it does and returns me to the log on screen. Only one problem - the system is now "unreachable" - the mouse does nothing, keystrokes do nothing. So, I press the old system reset button and let it boot up. At the log on screen I select my userid, enter my password, select KDE as the session type and away I go - to problems. KDE starts up, shows the initialization box and only the disk drive symbol is there. It keeps blinking my USB ports and eventually comes up with this error:

Configuration file "/home/dave/kde/share/config/ksmserverrc" not writable. Please contact your sysadmin. Click ok and back to a reboot, try again, same thing. Eventually I just gave up and logged back in with a Gnome session. All of the directories down to and including config are owned by me, but ALL of the files within config are owned by root - which explains not being able to write the error file. But why isn't this even working to begin with?

My first big "gotcha" with 9.10. It was a fresh install on a repartitioned drive that used to have 9.04 (wanted the new file system, so didn't do the "upgrade" but a full new install).

Any help would be greatly appreciated!

Dave :)

BTW - I like KDE, but couldn't download anything for an install CD (if one exists for 9.10 Kubuntu) because I'm on dial up and we're talking over a day to download! I received a 32-bit 9.10 desktop CD from Canonical in the mail late last week and used it to install. if it makes any difference, I'm running an old MSI Neo board with an AMD 64.

It should be noted this worked in 9.04, so I don't know what I may have missed or whatever for 9.10.

anewguy
November 15th, 2009, 08:22 PM
bump

anewguy
November 16th, 2009, 01:25 AM
I changed ownership and group of all the files in the mentioned config directory to me, then when I try to start a KDE session, it just goes blank for a second and back to the log on screen. I haven't seen any messages in dmesg regarding this, nor have I found any log file in /var/log for it. Is there another directory that may contain a log file for this that I could look at and try to figure out *why* it allows me to select KDE as my session but *doesn't* start a KDE session?

Thanks in advance!

Dave :)

anewguy
November 17th, 2009, 01:12 AM
I have removed via Synaptic kubuntu-desktop and all of the kde things I had installed, and I removed the .kde directory in my home directory, so I should be back to a clean place to try again.

Can *anyone* please tell me what might be going on *before* I try to install KDE again, so I don't go in a circle??


Dave

dzon65
November 17th, 2009, 08:34 AM
AMD by any chance?I tried installing KDE once,came up with several issues.(yours was one of them)Turned out AMD didn't support KDE.(but that was the 8.10 version,not sure with the 9.10)

anewguy
November 17th, 2009, 11:38 PM
Yes, it's an AMD 64, but I did have KDE 4 working in 9.04 64-bit. Perhaps there is some sort of problem with 32-bit, KDE and the AMD 64? Would seem odd, but I guess you never know.

I'm going to close this post (mark solved even though it isn't) and open a post with a different title and see if that draws any more help.

Thanks for the reply!

Dave :)

anewguy
November 24th, 2009, 10:38 AM
The problem was compiz - I didn't install the compiz settings manager and as a result the option to allow kde compatibility wasn't turned on. Installed compiz settings manager and turned on the compatibility and everything works fine.

Dave :)