View Full Version : [ubuntu] I can't find boot record for other distro's on my hard drive

November 14th, 2009, 11:47 PM
I tried to upgrade my Jaunty distro to Karmic recently, but I could never get the sound to work. I tried most of the things that people were saying and decided to opt for a clean install. I deleted the partition which contained Jaunty and then tried to install Karmic onto that section.

Problem was it couldn't boot at all. I managed to use super grub disk to find and boot xp (on hd0,0) and hardy (on hd0,1) but all my other distro's that I had on an extended partition where lost as well. I didn't mind too much about the others (fedora and debian) as i didn't really use them. I was a bit narked about losing linux mint, which I use quite a bit. I also can't boot into Karmic Koala.

Can anybody help?

November 15th, 2009, 04:04 PM
That's a bit of a horror story. You can see why it's advised to back up before doing anything major to your system though.

So when you installed Karmic, are you saying that it booted into the LiveCD, ran ok, installed, but then wouldn't reboot?

November 15th, 2009, 05:19 PM
I can access the files on my linux mint through my hardy installation. I don't think I've lost any files. But I would like to get back into those other distributions.

To recap. I installed ubuntu koala from livecd. Then when it had finished I got the option to carry on testing or reboot. I rebooted and that's when it failed to load.

It's not the end of the world, but I would like to get back into these other distro's. And find out why I've been locked out.


November 16th, 2009, 10:12 AM
Quickest solution might be to reinstall Jaunty, since you know it works for you. I'd check the integrity of your Karmic disk, search for any possible show-stopping bugs on your hardware, and if all that seemed ok, take another crack at installing Karmic.

November 16th, 2009, 12:29 PM
It could be the disk.

I've got Hardy working, so there's no real advantage in putting on Jaunty. What I would really like to do is get a bit of help so that I can boot up linux mint.

I think its something to do with my MBR

But I've fiddled with it and need a bit of help fixing it.