View Full Version : [all variants] 9.10 network buffering or?? (ipv6 disable tested already)

November 14th, 2009, 10:40 AM
My network speed is fine but i am suffering from horrible network pausing, when i download something or even copy on lan then network stream completely pauses some 7-12 seconds and then continues, it happens on random times. Is there some simple solution, i already tested ipv6 disabling in different ways but i need some simple solution or i just switch to XP until 10.04 arrives ??? internet usage is out of mind because of this.

November 14th, 2009, 12:37 PM
Well, have you tried consulting the logs to see if they report what is happening? You might get lucky and pick something up running dmesg on terminal, but more likely you'll have to consult /var/log/syslog, which is pretty long as it gets rather detailed information.

If you don't want to dig through the whole syslog file, then you might do a tail -n 100 /var/log/syslog immediately after one of your hiccups. You'll see from the time stamp which messages are relevant to anything happening during the time frame of the pause, if you need more or less info change the number after the n option to a larger or smaller amount of lines displayed.

November 15th, 2009, 01:09 AM

syslog shows this from log viewer, these CTRL-EVENT-SCAN-RESULTS messages appears if traffic pause starts.

November 15th, 2009, 02:06 PM
I have exactly the same problem here and probably a solution: The whole network stops immediately, I cannot even ping local machines and comes back after some time (10 to 60 seconds). Looking in my syslog I notice that these logmessages come from wpa_supplicant, a helper application for the wireless system. Switching off the wireless seems to solve the problem here as the network comes back immediately and I have a feeling that DNS queries take much less time.
I wonder if there is a bug in network manager or wpa_supplicant that changes the routing policy when wireless is on, even when it is not connected to any access point.

Nov 15 12:53:58 aurora wpa_supplicant[1121]: CTRL-EVENT-SCAN-RESULTS
Nov 15 12:54:18 aurora wpa_supplicant[1121]: CTRL-EVENT-SCAN-RESULTS
Nov 15 12:54:32 aurora NetworkManager: <info> Wireless now disabled by radio killswitch
Nov 15 12:54:32 aurora NetworkManager: <info> (wlan0): device state change: 3 -> 2 (reason 0)
Nov 15 12:54:32 aurora NetworkManager: <info> (wlan0): deactivating device (reason: 0).
Nov 15 12:54:32 aurora kernel: [15439.988101] iwl3945 0000:0c:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x040003DD
Nov 15 12:54:32 aurora NetworkManager: <info> Policy set 'Auto eth0' (eth0) as default for routing and DNS.

November 15th, 2009, 02:18 PM
Ah yes, those are caused by the periodic scans for wireless AP's. I ran into another problem where they were the catalyst earlier too and it's possible to turn them off, which fixed the problem the other person was having. Don't have time to search for the solution now, but I'll do some digging tonight, if you're still having trouble with it.

November 16th, 2009, 12:09 AM
Ok, can't find the bug report that I read about it in the first place. Should learn to bookmark pages that offer interesting solutions. Anyhow, test if disabling the wireless helps, so we can pinpoint the root of the problem first before starting to try elaborate fixes.

November 17th, 2009, 06:08 PM
i even tested backport modules but nothing, i cannot disable wifi because it is main connection link so i need alternate way?

November 17th, 2009, 09:00 PM
Ah sorry, for some reason I thought you were on wired. Well then, what chip & driver are you using (can check with lshw -C network)?

November 18th, 2009, 12:55 AM
AR928X Wireless Network Adapter (PCI-Express)

what that adapter gives, i just need disable somehow that pauser?

November 18th, 2009, 05:20 AM
Ok, then you're probably using the ath9k driver with it, right?

See these two bug reports that are somewhat related (talk about the performance issues): #1 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/414560) & #2 (http://bugzilla.kernel.org/show_bug.cgi?id=13807) and try this patch (https://launchpad.net/~frank-dekervel/+archive/ppa), which is listed as solving a lot of issues in both, it has the power saving and polling turned off.

EDIT: Reading it a bit further, this comment (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/414560/comments/61) seems to apply directly to your situation.

So, try it out without network manager (http://ubuntuforums.org/showthread.php?t=571188) at first and if that works better, you can switch to another GUI, if you don't like the CLI, by installing WICD or Wifi Radar.

November 20th, 2009, 02:30 AM
i found another solution, i just pause (stop) NetworkManager service itself and if i need to use another wifi access point i resume service.

t0mppa thanks to you i know how to fight with that bug.