View Full Version : [ubuntu] Error 15 after upgrade -

von Stalhein
November 13th, 2009, 11:15 PM
I saved my entire semi-borked 9.10 installation to an external hdd and prepared to do a clean install of Karmic.

I used the alternate cd to do the install, as any system boot with the desktop version resulted in a "cannot read this video mode" situation.

The OS installed OK (AFAIK), but on reboot I got the dreaded "Error 15".

I still can't use the karmic CD as a live CD, but I can get into it via good old 9.04.

My fstab:

# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdc1 during installation
UUID=57209f0d-0612-47d3-8415-05c2d5181db2 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdc5 during installation
UUID=27179ee5-e990-4dcb-9fc8-a5857a0f1b37 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

My /boot/grub/grub.cfg

# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
set default="0"
if [ ${prev_saved_entry} ]; then
save_env saved_entry
save_env prev_saved_entry
insmod ext2
set root=(hd2,1)
search --no-floppy --fs-uuid --set 57209f0d-0612-47d3-8415-05c2d5181db2
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else

Output of blkid is

/dev/loop0: TYPE="squashfs"
/dev/sda5: UUID="A83CB1173CB0E18C" LABEL="Disk 2" TYPE="ntfs"
/dev/sdb1: UUID="01C3D871F965AC80" LABEL="DSK1_VOL1" TYPE="ntfs"
/dev/sdc1: UUID="57209f0d-0612-47d3-8415-05c2d5181db2" TYPE="ext4"
/dev/sdc5: TYPE="swap" UUID="27179ee5-e990-4dcb-9fc8-a5857a0f1b37"

As you can see, the system has 3 HDDs, sdb1 and sda5 are XP OS and data respectively, and used to dual boot with Jaunty.

Where to from here??? :frown:

November 14th, 2009, 01:45 AM
hey drama comrade.
Didn't read much,but i suggest should reinstall Grub as it says here
Go to reinstall chapter.
It worked for me few hours ago.

von Stalhein
November 15th, 2009, 05:43 AM

November 18th, 2009, 08:42 PM
I have gotten a similar result. I have a Ubuntu-only server with the boot sector on /dev/sdc1. I get the dreaded Error 15 after a clean install and am ready to go back to Jaunty. I've tried the "rescue a broken system" to make sure that the boot sector is on sdc1. When I look at the grub.cfg file, I get a UUID which corresponds to the UUID of sdc1 reported by blkid. Does anybody have an idea what is going on? Is Karmic totally broken?

von Stalhein
November 18th, 2009, 09:14 PM
Mine was the same until the re-install of GRUB 2, and it then started to behave.

My only issue now is that I can't get it to dual -boot XP.