PDA

View Full Version : [SOLVED] Ubuntu 9.10 Grub menu missing unbuntu after a few reboots



Ghoulchaser
November 11th, 2009, 11:01 PM
Anyone else run into the following problem.?

Upgraded to Ubuntu 9.10 from 9.04.
Wireless work for 3 hours then vanished. all wireless settings were gone.

Networkmanger only showed wired
iwconfig wanl0 was gone
ndiswrapper still had the driver installed .
rebooted to see if wireless would return

Then after rebooting grub only had the memory test . strange
generic and safe were gone. Also Vista was still on the list .

reinstalled 9.10 clean and wireless worked for a few hours and again vanished .
Grub was only showing the memory test option and Vista after rebooting a 4th time.

Seems grub 2 is unstable.

Not sure why this is occurring.

System has two drives one for Windows and the other for Ubuntu

Always worked in the past up until 9.10

Perhaps I should just return to 9.04 for a while.

After all I am new to Linux so I don't know if grub can be repair via live cd

Wireless is another problem as well.


The wireless usb adapter was an Airlink 101 AWLL6070 (used it fine with 9.04 after failing to get my dlink dwa130 working). Tried just about everything for the wireless on forums. Why grub changed is very odd . It worked a few times than bamm on boot only Vista and the ubuntu mem test shows . I was thinking grub 2 may be the problem . After two rebuilds and the same problems I tested OPENSUSE 11.1 which worked fine . The weekend I will just reinstall 9.04 for now. Upgrading is always fun . Just was really checking if anyone else had the same problems. Thanks