View Full Version : [ubuntu] MySQL installation Problem

November 10th, 2009, 08:50 PM
After successfully installing APACHE & PHP when tried to install MySQL by giving this command " $sudo apt-get install mysql-server " I got this type of message.....

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

So, Please kindly any one tell me how to rid out from this problem.

November 10th, 2009, 08:57 PM
It could seem like you have some package manager running. But I am not sure.

November 11th, 2009, 04:56 AM
Friend, I'm absolutely new to this world of Ubuntu. So, really don't know much about it. Please, can u tell me what i need to do exactly to solve this problem.

November 11th, 2009, 05:06 AM
Rather than go through hoops checking for a running package manager (which would probably just be synaptic open), reboot and try the command.

November 11th, 2009, 06:16 AM
@blueridgedog (http://ubuntuforums.org/member.php?u=459469)
Same error message is coming always even if rebooting and entering the command. Can't understand what's d wrong going at where.......

November 11th, 2009, 07:01 AM
Hey Guys, I've solved my problem.But, I technically don't know what was going wrong. What i just did is..... rather than giving the command " $sudo apt-get install mysql-server "
I entered it as " sudo apt-get install mysql-server " (remove that $ symbol from start of the command). That's all & my MySQL started installing & now running perfectly.

By d way, Guys thx u all to responding my query so quickly.

November 11th, 2009, 01:59 PM
Ah...yes, the $ is not part of the command and represents the command prompt, if you see it or # in commands at the start, they are representative of the command prompt and not part of the command.

November 11th, 2009, 05:03 PM
Oop's this is d thing. Any way thx man for this information.......