PDA

View Full Version : [SOLVED] Ugly/unreadable korean fonts in Karmic



bakaeigo
November 7th, 2009, 05:45 AM
Hey all,

I'm running a fresh install of 9.10, and pretty much every application displays Korean text in an ugly and often unreadable font (see attached image.) I have a wide range of Korean fonts installed, and Openoffice displays Korean well, according to the font I choose.

How can I fix the display problem for the rest of my applications?

bakaeigo
November 7th, 2009, 11:16 PM
bump

carlos08
November 8th, 2009, 02:03 AM
I suggest you uninstall ttf-wqy-zenhei from your system. It worked for me on
a fresh install of Ubuntu 9.10 64-bit. Amazing how a single new default font can
cause such a regression. I guess the developers should have tested the font
more thoroughly before setting it to override the Un fonts as the default for Hangul.
I've seen this issue in recent Debian and PcLinuxOS releases, as well.

If you need more specific instructions, just do the following:
Open Synaptic via System > Administration > Synaptic Package Manager
[Enter your password for administrative privileges]
Search for ttf-wqy-* in the search box
You will see that ttf-wqy-zenhei is installed
Click on the green check box next to the package,
and select Mark for Complete Removal
Click Apply

That should solve the problem.
If you really need Chinese or Japanese fonts, I think there are workarounds
that don't require uninstalling the font package(s), but I haven't tried them myself.

For reference:
https://bugs.launchpad.net/ubuntu/+source/ttf-wqy-zenhei/+bug/475240
http://www.ubuntu.or.kr/viewtopic.php?f=10&t=8232 (in Korean)

Good luck!

bakaeigo
November 8th, 2009, 03:09 AM
Carlos08, thank you so much. Your instructions worked :D

sulgorae
November 13th, 2009, 03:27 AM
thanks so much guys. that works perfectly

ubun_two
December 8th, 2009, 04:31 AM
This also fixed the ugly Japanese font that I was seeing on my system.

jrrader
December 16th, 2009, 07:32 AM
This fixed it for my wife's computer too. I hope this font is removed in the future.

G2k
January 26th, 2010, 05:32 AM
Fixed!

Wow they should really get rid of that horrible font..

AncientPC
February 23rd, 2010, 07:27 AM
I suggest you uninstall ttf-wqy-zenhei from your system. It worked for me on
a fresh install of Ubuntu 9.10 64-bit. Amazing how a single new default font can
cause such a regression. I guess the developers should have tested the font
more thoroughly before setting it to override the Un fonts as the default for Hangul.
I've seen this issue in recent Debian and PcLinuxOS releases, as well.

If you need more specific instructions, just do the following:
Open Synaptic via System > Administration > Synaptic Package Manager
[Enter your password for administrative privileges]
Search for ttf-wqy-* in the search box
You will see that ttf-wqy-zenhei is installed
Click on the green check box next to the package,
and select Mark for Complete Removal
Click Apply

That should solve the problem.
If you really need Chinese or Japanese fonts, I think there are workarounds
that don't require uninstalling the font package(s), but I haven't tried them myself.

For reference:
https://bugs.launchpad.net/ubuntu/+source/ttf-wqy-zenhei/+bug/475240
http://www.ubuntu.or.kr/viewtopic.php?f=10&t=8232 (in Korean)

Good luck!
This fixed my issue as well. I agree with everyone else that this font needs to be removed.

Decimatio
March 3rd, 2010, 07:28 AM
Thank you very much.

감사합니다 :)

tora201
March 20th, 2010, 04:41 AM
Yeah! Works here too. Japanese fonts all looking *much* better!