View Full Version : [SOLVED] 9.10 Upgrade Samba issiues

November 6th, 2009, 09:10 PM
Was running 8.04 Mythbuntu until last weekend when I decided to upgrade. Let the update manager take me to 9.04 then to 9.10. After upgrade to 9.10, tried to connect to my XP laptop to the server shares to no avail. Mind you nothing changed. smb.conf was the same, computer name, workgroup, netbios name, IP, nothing changed. WHen I try logging into the new 9.10 system I get:

System error 234 has occurred

More data is available

I've even simplieified my smb.conf to

encrypt passwords=no
netbios name=server

ufw is disabled
send unencrypted passwords in XP is enabled.

Samba version 3.4.0

Please Help!!!!

Roland of Gilead
November 6th, 2009, 10:01 PM
I just completed the upgrade to KK on my system, and am now experiencing exactly the same problem.

My XPSP3 machine will no longer connect to the mapped Samba shares...throws "System Error 234: More data is available."

Testing shows me that machines are now connecting to my Samba server via IPv6 instead of IPv4...this is causing host name mismatching and resulting in authentication errors for non-public share access.

I'll post again when I've figured out the best resolution.

EDIT #2:
The solution is easy. You'll need to modify your /etc/hosts file to allow Samba to successfully map incoming host traffic using IPV6-style name resolution.

For example, my WinXP machine is named leo, so I changed my Ubuntu /etc/hosts file like this:

OLD: leo

::ffff: leo

November 8th, 2009, 01:49 AM
I didn't have any entries for my network in my hosts file. All I had was this: localhost honestabe

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

I added a line for my Windows XP SP3 laptop in the style you suggested but it still gave me the same error. I tried adding the IPv6 driver to my Windows connection but that didn't work either. I'm still having the issue.

November 8th, 2009, 02:30 AM
I never changed the host file at all. I am a little leery of this solution because I bring a lot of computers in and out of my house connecting to various shares. I don't want to have to edit my hosts file every time I try and connect a new computer.

November 12th, 2009, 03:53 PM
i've also encounter similar problem, i checked my old smb.conf with new smb.conf, they changed the defaut value of "encrypt passwords" to no. For windows higher than 2000, this should be yes

November 12th, 2009, 04:06 PM
I haven't read this thread exhaustively, so sorry if I'm repeating anything.
I had trouble with my samba shares, and got it fixed.

Go and look here. Pay particular attention to what dmizer has to say, and go through the links in his signature.



November 12th, 2009, 10:57 PM
Thanks for the link, audiomick. I've posted my question in that thread.

November 13th, 2009, 03:44 AM
I got my issues solved like this (http://ubuntuforums.org/showpost.php?p=8305376&postcount=226).

November 25th, 2009, 03:48 PM
Here's my newest quandry...

Some background...I have 2 file servers in my house, both installed from ubuntu mini's 64-bit karmic. The first server I installed ssh server, samba, myth backend and nfs installed in setup. My smb.conf was pulled in from 8.04 where it was working flawlessly. When I fired Samba up after a clean 9.10 install, I started getting the "More Data is Available" error. Playing around with it last weekend I got 1 of my shares to work. I though problem solved, so I checked the other 2 shares and nothing..."more data is available". So out of 3 shares, 1 works, 2 don't. I've checked everything I can think of, permissions, order of shares in smb.conf, suggestions on this board and others, etc.

So I set up another server to see if it is something I did at install. For server #2 I installed nothing at setup and then installed all apps from the command line. Fired up samba and nothing..."more data is available..."

FRUSTRATING!!! Please help....

Share issue was with the batch program I wrote to mount with shares. Also, in smb.conf I had to set security = share