PDA

View Full Version : [ubuntu] 9.10: harddisk detected "sometimes"



d.s.thor
November 5th, 2009, 09:35 PM
Hi!

I have got a serious problem with two of my harddisks. I installed the 9.10 amd64 final release on an ASUS M2N-VM DVI board with the latest bios.

The computer runs 3 disks, the first one to boot the system from, the others to store data on an software raid 1. This configuration worked well on the previous versions of ubuntu. All 3 disks are connected to the SATA controller (part of the onboard GeForce 7050 / nForce630A chipset) which is configurated to run the disks in AHCI mode. The bios reads the information of the disks, it detects all of them!

When I am running the system now, it always detects the first disk and boots from it. The others are detected sometimes, sometimes one, seldom both, in an random way. I have never reinstalled the raid in 9.10, it is just two independent disks for now.

I already tried to change the harddisk mode to SATA and RAID; with the same results.

It seems the kernel switches off the SATA links to the hard disks for some reason. See the attached dmesg output. It switches on the ata1 link at 1.84 and ata2 and ata3 off at 1.66. ata4 should always be off, because there is no disk attached.

Do you have any idea how to solve this problem?

thanks

M

noskoski
November 5th, 2009, 10:49 PM
friend

try to disable dmraid in grub configuration

adding "nodmraid" in your grub (grub.cfg or menu.lst)


i had the same problem

and it solve.

d.s.thor
November 6th, 2009, 08:51 AM
Hello noskoski,

Thank you for answering.

But that doesn't solve it, same behaviour like before :-(
Except of the disk numbering, is the classic way now (of course).


Does anybody knows a way to reset or restart the SATA links manually? Probably this could cause some kind of hotplug effect to the disks. Funny thing, I can't find the kernel module, which one is resposable for SATA in the 2.6.31?

Regards,
M




UPDATE:

solved the problem by installing a second SATA controller card. It seems to be a bug in the kernel...