View Full Version : [ubuntu] Need help installing graphics drivers - Ubuntu 9.04 (on laptop)

November 5th, 2009, 04:02 AM
I have Ubuntu 9.04 installed on my laptop. Everything seems to be working fine, but the system does not recognize my graphics card!! It is very frustrating, especially because when I watch livestreaming clips, it can be very choppy and jumpy.

If someone would be able to help me out (I am relatively new to Linux), I would so much appreciate that.

First, here are my computer specs:

Model: Aspire 5735-4774

Processor: Intel Pentium dual-core T3200 (2.0 GHz, 667 MHz FSB, 1 MB L2 Cache)

Screen: 15.6" HD Acer CineCrystal LCD

Graphics: Up to 732 MB Mobile Intel Graphics Media Accelerator 4500M
(In terminal when I used the command 'lspci' the 'VGA Compatible Controler was: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller)

The Problem:

I tried to install my graphics card manually (because apparently Ubuntu didn't install it by itself) by Sytem --> Administration --> Hardware Drivers.

And in the Hardware Drivers window, there are no drivers to enable, and on top, in big black font it says:

No proprietary drivers are in use in this system.

Solutions I have tried:

First off, I searched all over Google for some kind of solution.
But it seems that everyone has either Nvidia or ATI graphics drivers.

Also, there was a lot of technical jargon that I had no clue what it means (like 'X Servers' Etc, I am a technical newbie).

If someone could please assist me with this problem (in simple language), I would be very appreciative.

Thank you! :)

November 5th, 2009, 04:18 AM
ok, I would like to help

my laptop which is an HP Pavilion Entertainment PC is running on an intel GMA 950

-First I don't have problems like you, after I installed ubuntu 9.04 on my laptop. All (networking, graphics, sounds) works fine.

So here you can try,

go to

www.gmabooster.com/download.htm (http://ubuntuforums.org/www.gmabooster.com/download.htm)

then download for intel GMA 4500

then choose for linux

after downloading extract files to a folder and then

run the application

(if you need help reply to this thread again)

November 5th, 2009, 06:40 AM
When I clicked on it, it brought me to a message (http://www.gmabooster.com/message.htm), but no download link. What should I do?