View Full Version : [ubuntu] 9.10 - suspend breaks touchpad

November 5th, 2009, 01:50 AM
Just installed Karmic, but once i resume from suspend, the touch pad is 'frozen' ie it does not respond to any input.

This problem was still present in Gusty, however, i am not sure of the steps i would need to take in order to provide evidence.

Any help will be greatly appreciated.

November 5th, 2009, 02:40 AM
Check if your notebook has an i8042 controller:

ls /sys/devices/platform/ | grep i8042

If this returns i8042 then you do have it. In that case you need to unbind the controller on suspend/hibernate and bind it on resume/thaw. This bug was fixed in Jaunty - at least for me but it appears to be live and kicking in Karmic again.

This is a script for pm-utils which will do the job stated above:

Install as stated in the script.

Come back with feedback - if it works for you as well I can write a general HOWTO page for this problem.

November 5th, 2009, 11:01 AM
Thanks very much, I will update this post with feedback asap

November 5th, 2009, 01:03 PM
Just tested the above script, and unfortunately it has not worked. If anything it just wipes out my touchpad settings.

okay.. so where would be the best direction to go from here?

November 5th, 2009, 03:45 PM
Did you test if you have an i8042 controller prior to applying the script?
If you do not have one, then this script is rather useless to you since it targets a problem specific to that controller.

Please state here if you have i8042 or not since I consider your input as feedback for my script. Check my post above to see how to check that.

If you don't have an i8042, then you could try unloading and loading the module:

on suspend.

To do that follow these steps:

1. Open a terminal an go to:


2. Edit the following file with your favourite text editor (you need to be root):


3. Inside that file, after all lines, on a new line insert this:


That will make Pm-utils unload your touchpad module on suspend and load it back on resume. It may or may not help - give it a try and if it does nto help revert the changes back to normal and shout back here.

November 5th, 2009, 06:16 PM
I can confirm that I do indeed have the i8042 module.
- Still no luck i'm afraid

November 5th, 2009, 08:11 PM
Well I guess then the problem is not related to i8042 in your case. At this point I have no further information to help with. :(

November 6th, 2009, 11:39 AM
No problem, its probably still worth publishing your fix, because im sure it will work with most users out there.

Does anyone else have any other suggestions?

November 7th, 2009, 04:29 PM
Thanks. The fix worked for my Toshiba NB 200.

November 10th, 2009, 01:41 AM
For anyone with Intel based laptop + i8042 controller who experiences keyboard and/or touchpad freeze on resume/thaw after suspend/hibernate you can look here for more detailed HOWTO about my workaround:

HOWTO: Fix touchpad, keyboard freeze on resume/thaw for laptops with i8042 controller (http://ubuntuforums.org/showthread.php?t=1321032)

November 28th, 2009, 08:45 AM
I had the same problem. Touchpad doesn't respond after suspending. Output from

ls /sys/devices/platform | grep i8042
sais that I have i8042 controller.
I fixed this issue by adding following line



Thanks lightrush for the suggestions!

November 29th, 2009, 03:57 PM
Thanks for the suggestion, unfortunately this fix did not work for me :(

December 7th, 2009, 02:51 PM
Does the same solution apply in theory for



I mean , is there a different file for the modules to load & unload for hibernation ?

January 12th, 2010, 04:24 AM
I just installed 9.1 and I have this same problem. I have i8042 and neither the script fix suggested earlier in this post (nor other similar scripts) nor the 00sleep_module fix worked for me. I do, however have some additional information to add that might shed some light on the problem.

I installed System>Preferences>Touchpad gui application (gsynaptics) and it works fine when my touchpad is working, however, after i suspend my computer, not only does my touchpad stop working, but when i try to open this application i get the error message:

"GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics"

I know that setting the SHMConfig option to "on" in the touchpad section of xorg.conf was able fix this problem in past versions, but now in 9.1 our xorg.conf file is gone. Surely, SHMConfig is properly set somehow when my computer boots because my touchpad works flawlessly. There must be some way then to have it set properly when my computer returns from a suspend. (preferably without resorting back to a xorg.conf file) I however, don't know how do this as I am a mere n00b. Any insight would be appreciated and if you think making an xorg.conf file is the only solution please direct me toward instructions on how to build one from scratch.

Further information:

This problem does NOT occur if I hibernate, although i have only tested this once.

My computer is a Gateway CX200X tablet.

January 12th, 2010, 06:56 PM

February 7th, 2010, 07:18 PM
Funny here ...

For me it survives after suspend, but not after hibernation ...