View Full Version : [SOLVED] cannot connect to xrdp

November 4th, 2009, 06:02 PM
I have an Xubuntu 9.10 Karmic Koala VM set up within VMware ESX to test out xrdp.

xrdp appears to appropriately start up when Xubuntu is booted.

When I try to RDP to the VM (it has a DHCP address), I get the following messages:

connecting to sesman ip port 3350
sesman connect ok
sending login info to sesman
login successful for display 10
started connecting
connecting to 5910
error - problem connecting

What can I do to fix this??

I really don't want to deploy other VNC servers/clients etc., I would really like people to be able to use Windows RDP...

I opened 5910 in the Xubuntu VM's firewall for both TCP/UDP via gufw.

I could also use xdmcp but I cannot find anything on how to enable this in Xubuntu 9.10.

Thank you, Tom

November 4th, 2009, 08:21 PM
got this solved.

I had to remove xrdp, vnc4server, tightvnc, which were all installed in the wrong order.

I had to install tightvncserver, then install xrdp.

Please see:

It's important to do tightvnc before xrdp.

Doing things in this manner will cause xrdp to use tightvncserver instead of vnc4server, which will not work.

I'm not a Linux expert.

Thank you, Tom