PDA

View Full Version : [ubuntu] 9.10 compiz eating cpu



carolinason
November 3rd, 2009, 04:46 PM
Running Ubuntu 9.10 with an ATI Radeon 9000 Pro video card and I can't run compiz without bringing my system to it's knees, because it's consuming the CPU. Sounds like the driver, no?

Ubuntu 9.04 did not have this issue and compiz ran fine no problems.

Anyone else have this issue? I know there is a bug with running full screen video and compiz. Work around is disable compiz. Why is it every time a new kernel comes out getting an open source driver card working is a crap shoot?

spacecheck
November 3rd, 2009, 05:46 PM
Running Ubuntu 9.10 with an ATI Radeon 9000 Pro video card and I can't run compiz without bringing my system to it's knees, because it's consuming the CPU. Sounds like the driver, no?

Ubuntu 9.04 did not have this issue and compiz ran fine no problems.

Anyone else have this issue? I know there is a bug with running full screen video and compiz. Work around is disable compiz. Why is it every time a new kernel comes out getting an open source driver card working is a crap shoot?

Hey Tarheel, try turning off 'Visual Effects' (but then you will not be able to see notices or System Monitor):
http://ubuntuforums.org/showthread.php?t=1305279&highlight=system+monitor+notices&page=2
Ciao

carolinason
November 3rd, 2009, 09:32 PM
i did that, but i would prefer them to be on like it was in 9.04. i'm trying to find this in ubuntu bugs to see what's up, frustrating!

carolinason
November 3rd, 2009, 09:52 PM
yeah i posted to the link you gave, thanks.

like i said there you know this isn't going to get fixed. bugs like this don't get fixed!

i can go back to 9.04 and deal with old software or run debian and do the same

after some investigation this has to be compiz. i'm getting excellent performance on my ati 9000 pro

svanechel
November 4th, 2009, 08:47 AM
I'm experiencing similar problems. I just did a clean install of 9.10 and all of a sudden compiz is unbelievably slow. Windows take ages to pop up, the same for menus, clicks are unresponsive. The cpu is continuously hovering around 20-25% utilization, even when doing nothing else. Switching of compiz restores performance;

I have a Dell Studio 17 with an ATI card:


01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650
0

I did a clean install over 8.04, which I liked very much as it was stable. I skipped 8.10 because of sound card issues, but I wanted to have some newer versions of the software I use, so I decided to finally upgrade to the latest Ubuntu. I may have to go back now.

spacecheck
November 4th, 2009, 12:35 PM
I'm experiencing similar problems. I just did a clean install of 9.10 and all of a sudden compiz is unbelievably slow. Windows take ages to pop up, the same for menus, clicks are unresponsive. The cpu is continuously hovering around 20-25% utilization, even when doing nothing else. Switching of compiz restores performance;

I have a Dell Studio 17 with an ATI card:


01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650
0

I did a clean install over 8.04, which I liked very much as it was stable. I skipped 8.10 because of sound card issues, but I wanted to have some newer versions of the software I use, so I decided to finally upgrade to the latest Ubuntu. I may have to go back now.

Ati Radeon Mobility 7500 w/ 128 MB worked fine for me under 9.04, but the upgrade to 9.10 changed that, so system notices & system monitor windows were corrupted unless using "normal" visual effects, instead of "none".
After reviewing bugs & forums, I edited xorg.conf as suggested here:
https://bugs.launchpad.net/ubuntu/+s...01/comments/13
by adding
Option "AccelMethod" "EXA"
and restarting.
I thought having added the "EXA" entry had worked, but then realized I was testing without "visual effects". When I tried to turn them on, to "normal" (which turns on compiz) it crashed my system. I restarted and edited xorg.conf and changed the entry to
Option "AccelMethod" "XAA"
instead, but this brought back the problem of corrupt system notices & system monitor when "visual effects" are set to "none".

Ciao

svanechel
November 6th, 2009, 07:14 PM
Ati Radeon Mobility 7500 w/ 128 MB worked fine for me under 9.04, but the upgrade to 9.10 changed that, so system notices & system monitor windows were corrupted unless using "normal" visual effects, instead of "none".
After reviewing bugs & forums, I edited xorg.conf as suggested here:
https://bugs.launchpad.net/ubuntu/+s...01/comments/13
by adding
Option "AccelMethod" "EXA"
and restarting.
I thought having added the "EXA" entry had worked, but then realized I was testing without "visual effects". When I tried to turn them on, to "normal" (which turns on compiz) it crashed my system. I restarted and edited xorg.conf and changed the entry to
Option "AccelMethod" "XAA"
instead, but this brought back the problem of corrupt system notices & system monitor when "visual effects" are set to "none".

Ciao

Unfortunately neither works for me. When add the AccelMethod option, I reboot into a terminal. I'm guessing that X just cannot initialize. I must say that my xorg.conf is rather flimsy, as I have seen other peoples' with much more options. Can it be this tiers?

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "fglrx"
EndSection

Any ideas?

Thanks,

Sven

spacecheck
November 8th, 2009, 03:36 PM
Unfortunately neither works for me. When add the AccelMethod option, I reboot into a terminal. I'm guessing that X just cannot initialize. I must say that my xorg.conf is rather flimsy, as I have seen other peoples' with much more options. Can it be this tiers?

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "fglrx"
EndSection

Any ideas?

Thanks,

Sven

Hi Sven,
I'm not using glx or fglrx. Just the standard opensource radeon driver.
Apparently there are quite a number of default settings, which seem to reduce a need for specific settings in the xorg.conf, if the card & chip are correctly detected.
I tried modifying the EXA & virtual resolution options suggested by Tormod here:
http://ubuntuforums.org/showpost.php...72&postcount=6

Among an amazing number of other possible options (check the manpages and the "see also", for example:
man radeon
man xorg.conf
man ati
), you also have the option to reduce color depth from 24 to 16 bits, set the AGPGart aperture, etc.
I only specified EXA & changed the virtual res. from 2304x down to 1980x, so my xorg.conf now looks like this:
Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Virtual 1980 1024 EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "AccelMethod" "EXA"
EndSection

Hope this helps.
Ciao

carolinason
December 3rd, 2009, 02:45 PM
Well, I reached around my problem. First by downgrading to 9.04. Then I tried an ATI 9500 Pro and the fan stopped working and I could fry eggs on the card. Then I found an ATI Radeon 9600 in a machine in the closet and it works fine with 9.10. This does not fix the problem with the 9000 (laptop owners have to be totally frustrated), which to me should have worked, since the 9000 was fine in 9.04. I thought the 9600 that I found was an nVidia(it doesn't say ATI on the card and has a nice silver fan), imagine my horror and disappointment when I found it was just another Radeon.

I tried the legacy fglrx driver from AMD/ATI for the 9000 and the system was unusable. What a nightmare. I loaded Windows XP and took Unreal Tournament for a spin and it rocked. Why can't Linux do this? I mean Linux was the OS for older hardware at one point. You would think that AMD/ATI would open the drivers for them, since they are so old. The ATI site said that the open 2d drivers should handle compositing. Obviously Ubuntu 9.10 with the Radeon 9000 won't.