PDA

View Full Version : [ubuntu] 9.10 XKB settings disregarded



trekkie3k
November 3rd, 2009, 01:15 PM
Hi everyone,

I've just installed 9.10 on my Macbook. Previously i was using 9.04 (before my hard disk died last sunday).

The XKB settings I use to be able to type Characters needing Mod-key (at-sign etc.) don't work properly.

Here are my current settings (Set up using System>Preferences>Keyboard GUI):


k3t@misaki:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "macbook79", "de,de", "mac,", "eurosign:e,lv3:rwin_switch"
_XKB_RULES_NAMES(STRING) = "evdev", "macbook79", "de", "mac", "eurosign:e,terminate:ctrl_alt_bksp,lv3:rwin_switch"

Theses settings are ignored (as far as I've encountered until now) by nearly any application except gnome-terminal and xterm.

On Virtual Consoles (No X) everything works as expected.

Now I'm stuck, because I have no idea what could cause that. Especially considering the difference between gnome-terminal, xterm and other gnome/gtk/X apps when it comes to keyboard input.