PDA

View Full Version : How To: Install Xgl/compiz with Dapper, ATI, Gnome



Pages : 1 [2] 3

Fedup
February 20th, 2006, 11:49 PM
Arrrrgh!
I reboot after playing with Compiz for a few hours, and now get


paul@flight4:~$ compiz.real: GLX_EXT_texture_from_pixmap is missing
compiz.real: Failed to manage screen: 0
compiz.real: No managable screens found on display :0.0

again. I thought things where going too easily (for a change) :rolleyes:

...Excuse me for a while whilst I kick my computer down the stairs :mad: :mad:

concept10
February 20th, 2006, 11:51 PM
Its a real shame that we haven't cracked this yet :( So many people seem to be stuck on this one.

I don't know how relevant this could be to this issue, but here's something I found while debugging my problems a couple of days ago.

First off, some history: I attempted to install the proprietary "fglrx" ATI drivers from Seveas' repository to replace the original "ati" binary drivers that are installed by default. The driver worked, but video was not normal at all, I traced the problem to DRI (Direct Rendering).

My laptop has this graphics chipset (from lspci): 0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

I could not find any information anywhere stating that this chipset was supported by the "fglrx" drivers.

Using this page http://dri.freedesktop.org/wiki/DriTroubleshooting#head-fd0412cece2b6aa5b7c6ee47f228c402787a8a57

I was able to put my system back together again, getting off the Mesa software rendering stuff and back on DRI. I basically made a symlink to fix my system.

That page takes paitence, but pay attention to the Userspace section.

Here it is if you don't want to go there:

Userspace setup

Next, look at a GL program. Set the environment variable LIBGL_DEBUG to verbose, i.e. setenv LIBGL_DEBUG verbose for csh-based shells or export LIBGL_DEBUG=verbose for bash-based shells. Run glxinfo, which should be included with X.Org. At the top it should show libGL trying to load the driver-specific hardware rendering library, like:

libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/radeon_dri.so.

If it isn't doing that, you have replaced your X.Org-provided libGL with some other libGL, or it's finding an old libGL from somewhere. Run ldd /usr/X11R6/bin/glxinfo and see which libGL it's finding. Make sure it's the one in /usr/X11R6/lib/libGL, or a link in /usr/lib to the one in /usr/X11R6/lib. You shouldn't have any libMesaGL* on your system.

If the driver complains about unresolved symbols:

libGL error: dlopen /usr/X11R6/lib/modules/dri/radeon_dri.so failed
(/usr/X11R6/lib/modules/dri/radeon_dri.so: undefined symbol: _glapi_noop_enable_warnings)

then your libGL is out of sync with your DRI drivers. Because APIs change, you typically need a libGL from the latest X.Org release to run DRI drivers, and sometimes you need a libGL from X.Org CVS for the latest drivers. Reinstall both your drivers and your libGL from sources from the same date.

If you get:

libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering

then you are trying to run as a user that doesn't have permission to use the DRI (root is the default allowed user). To let all users access the DRI, add the following section to your xorg.conf:

Section "DRI"
Mode 0666
EndSection

If you get (the driver name may vary):

libGL error: dlopen /usr/X11R6/lib/modules/dri/r200_dri.so failed \
(libexpat.so.1 : cannot open shared object file: No such file or directory)
libGL error: unable to find driver: r200_dri.so

then make sure that you have libexpat.so.1 installed. Binary snapshots now come with a statically linked libexpat, so this should no longer be a problem.

If you get (the driver name may vary):

libGL error: dlopen /usr/X11R6/lib/modules/dri/r200_dri.so failed \
(r200_dri.so : cannot open shared object file: No such file or directory)

then make sure you have compiled the appropriate dri module for your card. It it could be either in a separate file (r200_dri.so in this case), or bundled in libGL.so. Edit xc/config/cf/host.def and make sure you list at least your driver (if not all available) in a line:\ \

#define BuildXF86DRI YES
/* 2D accel drivers are: ati mga glint s3virge sis savage nv tga rendition tdfx vga i810 sunffb sunleo suncg6 suncg3 suncg14 suntcx */
#define XF86CardDrivers ati
/* the next line DriDrivers defines dri modules. Valid choices: gamma i810 i915 mach64 mga r128 radeon r200 tdfx savage sis ffb
ati is not a valid DriDriver name. For new Radeon cards use r200 instead. */
#define DriDrivers radeon r200

If you have a 3dfx card and it's complaining about libglide3, or there are glide errors, you need to install the correct glide for your card as provided by your distribution.

If you are using a radeon and it complains about the module versions and maybe fails on an assertion, you need to update your DRM as in the instructions above.

If you've made it this far, glxinfo should be printing direct rendering: Yes and direct rendering for native GL programs should be working. Make sure that you are running at reasonable settings for your card, and maybe adjust your expectations of speed.

If you are experiencing trouble using GL with any program, maybe setting more [WWW]environment variables may help you.

KOnsumer
February 20th, 2006, 11:55 PM
~$ DISPLAY=:1 glxinfo
name of display: :1.0
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 0 0 0 24 8 0 0 0 0 1 0 None
0x2d 24 tc 0 32 0 r . . 8 8 0 0 0 0 0 0 0 0 0 1 0 None
0x2e 32 tc 0 32 0 r y . 8 8 0 0 0 24 8 0 0 0 0 1 0 None
0x2f 32 tc 0 32 0 r . . 8 8 0 0 0 0 0 0 0 0 0 1 0 None
~$

What is wrong? What can i do?

fluxin
February 21st, 2006, 12:17 AM
JWolf: it's slow when you login, but what happens when you start
gnome-window-decorator & compiz --replace gconf?
It should be slow until you start those.

Tea
February 21st, 2006, 12:23 AM
Hi,

Im using a ATI 7500. Will it be possible to get this to workm on this old a video card? The rest of my system is decent (1.6Pm, 512mb).

Thanks.

Fedup
February 21st, 2006, 12:28 AM
*oops*.

Fedup
February 21st, 2006, 12:29 AM
*double post*

Fedup
February 21st, 2006, 12:30 AM
It gets stranger and stranger... after threatening the PC with a clean format and reinstall of Windows I backtracked my steps somewhat, uninstall KDM and went back to GDM... and compiz is working again :eek:

Not sure if its a path issue or if KDM is broken (I noticed a while back that using KDM to log in makes all the fonts too small in KDE using the NVidia drivers), but at least things are working again for me.

Now, all I need to figure out it how to get compiz working correctly with KDE and I'm happy.. wish me luck - I feel I may need it.

Lars A E
February 21st, 2006, 12:34 AM
I do also experienced the same with my X600, but it seems that the problem just happened lately after some updates as when I first configured XGL on it, I was able to play for almost about 5 hrs without any problem before I shut down my machine.

I did tried disabling compiz and then used metacity but still I encountered the same problem, I don't believe that there were any recent upgrades to the fglrx driver. Could it be caused by XGL? or fglrx? or both? :-k

I'll try a fresh install of Flight 4 tomorrow morning and will see how things will get by.
I also have the probblem with hard lock ups. A few small gnome applications will open, but once I start evolution, nautilus or other larger apps, the system freezes.
Hopefully someone will figure this one out too :)

guyhersh
February 21st, 2006, 01:23 AM
fangorious

I'm having the exact same problem as you know. I had Xgl working with the fglrx from the ubuntu repository, but it froze often. So I updated to the latest fglrx drivers from ati, and I get these Diagonal distortions, and no Xgl effects.

At first the desktop wouldn't fully load, and then I did that libGL.so thing like you did, and the desktop loaded, but theres no windows around the programs, and no Xgl effects.

Sooo until we get a fix for the lastest ati drivers, try reverting to the ubuntu fglrx drivers in the meantime for Xgl to work.

Also, with the old drivers with working Xgl AND new drivers where Xgl doesnt work, when I ran fglrxinfo on display1, it said it was using Mesa drivers, so I don't think that is really a problem.

Hit me up on AIM if anyone has any ideas or wants to troubleshoot @ GuyHersh.


Guy

EstevaoSoares
February 21st, 2006, 01:46 AM
Hi Folks...


I'm in a terrible disaster here with xgl.

The install was ok, no major problems, no errors, gconf-editor reconize compiz perfect.

I`ve instaled all required debs plus gnome-compiz , all from repo.
I'm using fglrx driver from the Repo, not ATI.

I did this on a fresh Flight 4 install...

After install, I reboot, GDM starts fine, when I enter with login/pass the system halts... freezes.
I have no clue what to do?

Someone could please, helpe on that?

Thanks a lot !

guyhersh
February 21st, 2006, 02:04 AM
Hi Folks...


I'm in a terrible disaster here with xgl.

The install was ok, no major problems, no errors, gconf-editor reconize compiz perfect.

I`ve instaled all required debs plus gnome-compiz , all from repo.
I'm using fglrx driver from the Repo, not ATI.

I did this on a fresh Flight 4 install...

After install, I reboot, GDM starts fine, when I enter with login/pass the system halts... freezes.
I have no clue what to do?

Someone could please, helpe on that?

Thanks a lot !

Mine froze during login often too, probably 2/5 times I get passed login without it freezing. This was when I used the ATi drivers from repo. Now I have drivers from ATi, and it doesn't freeze as often, but Xgl doesn't work worth crap.

Xgl is alpha, Dapper is alpha, there is gonna be problems, got to accept it.

Guy

Vinterstum
February 21st, 2006, 02:34 AM
Hi Folks...


I'm in a terrible disaster here with xgl.

The install was ok, no major problems, no errors, gconf-editor reconize compiz perfect.

I`ve instaled all required debs plus gnome-compiz , all from repo.
I'm using fglrx driver from the Repo, not ATI.

I did this on a fresh Flight 4 install...

After install, I reboot, GDM starts fine, when I enter with login/pass the system halts... freezes.
I have no clue what to do?

Someone could please, helpe on that?

Thanks a lot !


That was the exact same problem I had. Which I solved using the method I posted about three pages back.

DanVarga
February 21st, 2006, 03:02 AM
I am having problems with getting gconf-editor to recognize compiz. Anyone know of a fix?

jwolf
February 21st, 2006, 04:16 AM
JWolf: it's slow when you login, but what happens when you start
gnome-window-decorator & compiz --replace gconf?
It should be slow until you start those.

Actually, I have narrowed my problem down to compiz itself. I can start X+Xgl now and have it run (albeit without a window manager), but as soon as I try to start compiz, the entire screen becomes garbled.

This is solved by switching to a console and executing a sudo killall compiz.real, which restores my desktop.

Any ideas why compiz is freaking out? I'm so close to figuring this out, it's frustrating the heck out of me!

jwolf
February 21st, 2006, 04:17 AM
I am having problems with getting gconf-editor to recognize compiz. Anyone know of a fix?

I am pretty sure compiz needs to run successfully at least once before it appears in the menu (at least that was the case for me).

xavatar
February 21st, 2006, 04:39 AM
Yeahie i got mine working in less than an hour...
However after half an hour I crashed down, and it seems to have some troubles with my version of fglrx (kernel 2.6.15-14). So where to report bugs ??

BTW if you don't want to mess with gdm, you can create xserverrc and run xserver from a tty as root

$echo "/usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo" > .xserverrc

It's nice, the exposÚ-like features are so cool! but i couldn't find what they call the "super" key ... as i am using a french keyboard... Any clues on this ?

Hobbes
February 21st, 2006, 04:41 AM
Well I am in the same boat as a few people seem to be. When I run Xgl by adding the lines to my gdm.conf and gdm.conf-custom, I will login and everything crawwwls along. but if I get out and get back into to a normal xserver, everything is fine. I looked back a few pages and couldn't find any reason for this, it could be somewhere in the middle of the 27 pages and I missed it, if so a link or even page # would be great.

BTW I'm using 9800 pro, fglrx driver (from repo), and my roomate has a stupid 6600 gt and is spinning his cube in my face :)

Regards.

P.S. xavatar, the super key is the "windows" key at least on english keyboards, otherwise u can change the shortcut.

Rob2687
February 21st, 2006, 04:42 AM
The Super key is the Windows Start button.

EstevaoSoares
February 21st, 2006, 04:57 AM
That was the exact same problem I had. Which I solved using the method I posted about three pages back.



Sorry about my dumbness but I did everything you wrote and even this way I couldn't realize what to do.

After all that steps I suppose to get xgl working after my next boot (or restarting gdm) ?



Many thanks !

guyhersh
February 21st, 2006, 05:09 AM
Hiya guys,

A couple of things to try if you're having problems:

If 3D acceleration doesn't work but there's no error messages (and fglrxinfo displays ATI), try doing:

export LIBGL_DEBUG=verbose
glxgears

And see if there are any error messages printed out. In my case (Breezy-updated Dapper, with messed up fglrx), I had to copy fglrx_dri.o from something like /usr/share/dri to /usr/X11R6/lib/dri. I don't remember the exact paths, but if there is a complaining error message, you'll figure it out :)


Secondly:
The recipe in the first post didn't work for me (X300 Mobility).
What did work:

*Create an init file somewhere. Say, /usr/bin/startxgl.sh. The init file should be executable, and contain something like:


#!/bin/bash

Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo & sleep 2 && DISPLAY=:1 gnome-session



*Create a file called /usr/share/xsessions/xgl.desktop, containing:

[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/path/to/init/file/here
Icon=
Type=Application


You still need to start compiz and gnome-window-decorator yourself at some point (for example using the method in the original post).

Oh, the above will basically make Xgl appear as a Session option on the login screen (where you select between GNOME, KDE, etc).

EDIT: Updated info after a bit more testing.


THIS GUIDE WORKS GREAT!!!

Xgl worked okay with the fglrx from the Ubuntu repo, then I upgraded to the latest ATi drivers to see if it helped at all, and Xgl was all screwed up, so I decided to follow this guide.

Not only did it get rid of *some* of my freezing problems, windows not displaying, display corruption, and many other problems, I can CHOOSE whether I want my session to be default Gnome OR Xgl.

ANYONE having problems, undo the edits that you made to gdm.conf and gdm.conf-custom and try this guide. (Make sure you do everything else listed on the front page)

Also, to make the startxgl.sh executable, use this after you create the file :


chmod 755 /usr/bin/startxgl.sh


But yah, works great. Thanks!

Guy

xavatar
February 21st, 2006, 06:13 AM
I've got a trouble with that way of launching xgl
It should be run as root but launched from gdm it runs as normal user

I can put a nopasswd sudo but that does not really satisfy me

Any idea ?

Vinterstum
February 21st, 2006, 06:23 AM
Sorry about my dumbness but I did everything you wrote and even this way I couldn't realize what to do.

After all that steps I suppose to get xgl working after my next boot (or restarting gdm) ?



Many thanks !

After you've done this, you should be able to go to the Login screen (gdm), click Options down in the left corner, click Choose Session and then select 'Xgl' :)


But yah, works great. Thanks!

Guy

No problem :)



I've got a trouble with that way of launching xgl
It should be run as root but launched from gdm it runs as normal user

I can put a nopasswd sudo but that does not really satisfy me

Any idea ?

Uhm Xgl doesn't have to be run by root, just by your normal user.

danmagicman7
February 21st, 2006, 07:26 AM
Alright, here is my...story.

Basically, the past 3 days I have spent trying to get a consistent pattern of getting fglrx drivers to work. I found a good guide, reinstalled xorg, and everything would work.

Once I started to do any xgl stuff, upon reboot, fglrxinfo would bring up nothing errors that it couldn't find the current view, and I would have no hardware accelleration. So, Cntrl+Alt+F1 I go, and I learned that the sudo dpkg-reconfigure xserver-xorg command then a startx would bring everything happily running in 3D acceleration. Problem is, whenever I did a startx, I wasn't in XGL, I was just in plain ol' Xwindows.

So, I was pulling my hair out thinking I was in xgl after I did the xorg reconfigure and startx, when I was in fact not in it after all. No wonder the compiz stuff wouldn't work!

Anyone else having the same dillema?

Entity
February 21st, 2006, 01:16 PM
ok...I hate to do this...
BUT
in the gconf-editor, i don't have the compiz in apps. I ran the app as mentioned on page 16, but to no avail. The services did start up though in the current session I am assuming since it's now listed there.

When Compiz with all options is run, I get compiz.real: No composite extension and then nothing happens.

I get the same problem here on a Powerbook G4 17" with ATI 9600 Pro using the radeon driver (compiz.real: No composite extension).

I also don't have compiz in gconf neither.

Vinterstum
February 21st, 2006, 03:48 PM
I get the same problem here on a Powerbook G4 17" with ATI 9600 Pro using the radeon driver (compiz.real: No composite extension).

I also don't have compiz in gconf neither.

Compiz needs to run successfully to add them, it seems.
That error message, from what I've been able to gather, just means that Xgl isn't currently running.

danmagicman7
February 21st, 2006, 04:56 PM
There's a fix for the no composite extension in the Nvidia guide.

Hobbes
February 21st, 2006, 06:03 PM
Wow, doing the method above:



*Create an init file somewhere. Say, /usr/bin/startxgl.sh. The init file should be executable, and contain something like:


#!/bin/bash Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo & sleep 2 && DISPLAY=:1 gnome-session


*Create a file called /usr/share/xsessions/xgl.desktop, containing:


[Desktop Entry] Encoding=UTF-8 Name=XGl Exec=/path/to/init/file/here Icon= Type=Application


You still need to start compiz and gnome-window-decorator yourself at some point (for example using the method in the original post).

Oh, the above will basically make Xgl appear as a Session option on the login screen (where you select between GNOME, KDE, etc).


Fixed my problems. By the way the infamous No composite extension found error, at least for me, was caused when I was trying to run compiz when I wasn't actually in Xgl. You do not need to add the composite section listed elsewhere to your X.org. That will make the error message go away but doesn't actually fix the problem.

And like people have been saying, running compiz successfully once (try just compiz --replace first) will add the setting to your gconf, access it and add plugins listed in order at beginning of this thread, and that is how I at least got it all to run.

Also a bug mentioned somewhere else is that the wobbly effect glitches if you are not a refresh rate of 60 Hz, either switch to that refresh rate or add a system monitor to your gnome panel and change its settings to an update interval of 50 ms. (this will have the added bonus of you being able to see how xgl doesn't tax you're cpu!)

Thanks everyone!

P.S. can somebody remind me what the actual code and quote tags are so I can edit this post and fix them :)

guyhersh
February 21st, 2006, 06:40 PM
they are "[Quote]" and "[code]"

Theres little buttons on the top when you create the message

DrSturgeon
February 21st, 2006, 08:05 PM
Success! At least partly...

I highly recommend the above method of creating a seperate session (selectable from gdm login) to run XGL--it makes debugging a lot less of a headache.

If compiz won't start (for me it was the error about two non-something textures), make absolutely sure the versions of the xorg fglrx driver and the fglrx kernel module match. Today my system automatically got the new xorg driver, but didn't upgrade to kernel 2.6.15-16, and they mismatched, and then fglrx stopped working. Once that was corrected...success!

Except that every time I open an application, there's about a 50% chance that the system will hard freeze. So it's still pretty much unusable, but it's pretty cool when it does work.

I'm assuming this is just a bug proving the unstability of an alpha release, but if not, anyone know how to fix it?

Thinkpad t43
Mobility Radeon x300

Thanks to everyone on this thread who's sharing advice and experiences. This is why open source is so much fun :-)

rjtd
February 21st, 2006, 08:07 PM
I cannot get this to work with ATI9200.
Any luck with this? I just get a black screen after running compiz :(

jecos
February 21st, 2006, 08:53 PM
If you don't mind trying it out, could you do as I suggested anyway then? I'm curious about trying to get the proper gconf settings in there. On my primary PC I started with battlehorse debs and then switched to Universe as packages became available and I had no trouble... but on my lower end PC I went straight from the repositories and there are no compiz options listed at all under gconf. I will test this myself later on today after work when I'm home but that will be quite a while.

I can confirm that repository Compiz doesn't add anything to gconf, but weirdly enough it worked on my other pc fine

Odice
February 21st, 2006, 09:03 PM
Yep, its doesn't add it. In the howto, says that i must install the "battlehorse debs" but, what are those?

DrSturgeon
February 21st, 2006, 09:13 PM
I can confirm that repository Compiz doesn't add anything to gconf, but weirdly enough it worked on my other pc fine


This is the way it seemed to work for me: You have to start compiz once with gconf and all other plugins:


compiz --replace gconf and all the other plugins

When that works successfully, it will add the stuff to gconf for all those plugins.

DrSturgeon
February 21st, 2006, 09:17 PM
And my guess (but it's only a guess) about all the warnings about switching from the battlehorse debs to the normal ones is that compiz will only create the gconf keys if they don't already exist. So if battlehorse compiz created them once, normal compiz won't create them, except then the plugins are listed in a different order, so the battlehorse keys won't work with the normal compiz.

jwolf
February 21st, 2006, 09:18 PM
Yep, its doesn't add it. In the howto, says that i must install the "battlehorse debs" but, what are those?

http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl

EstevaoSoares
February 21st, 2006, 09:36 PM
After you've done this, you should be able to go to the Login screen (gdm), click Options down in the left corner, click Choose Session and then select 'Xgl' :)


Hi again...

What I must do if I can't choose on Session? Nothing different appears there after all that steps... could point me something?

Thanks a lot!

zachtib
February 21st, 2006, 10:42 PM
this is exciting
after upgrading to fglrx 8.22.5 from the repos., and a 686 kernel
fglrxinfo now properly reports that it is accelerated with the fglrx driver, instead of mesa FROMWITHIN XGL

zachtib
February 21st, 2006, 11:13 PM
however, i still cannot start compiz, radeon mobility 9000
im getting the corrupted display bug

Portanoo
February 21st, 2006, 11:50 PM
argh **** ATI....

sorry for my English i'm poor frenchie

after upgrade of Dapper maybe 2hours ago, and install of Ati driver 8.22 Xgl and compiz are boken.

pb with the driver ATI 8.22 don't have "non power of two texture" now for me it's DON'T Buy ATI Card they are to bad with them drivers for linux.


Now i'll try a install manual of driver 6.xxx

Odice
February 22nd, 2006, 12:36 AM
Ok i did the fix founded on the battlehorse page (start xgl first and a xterm, and then start compiz) and now compiz is in the gconf, but everytime i start to login into de system, the system freeze, so i follow the alternative guida given here in the page 23 and it works, now y can enter to gnome with xgl enabled (bi the trick of using startglx.sh, and run compiz by hand), the problem is that my pc freeze when i open firefox, or dillo :( I don't know what is it (it happens even with just XGL loaded no compiz)

My Card is a Ati Radeon x700pro, and im using the fgrlx drive from the repos.

danios
February 22nd, 2006, 12:55 AM
Hallo!
I've a ati x700. i instalt all schown on the first page and after problems with compiz in gconf editor, it suddenly was listed there. and WOW it woked. But then i updated my fresh installed flight 4 with synaptic and after reboot. Nothing worked anymore :cry: I checkt the configs and i coudn't find changes. Now i tried the whole day fixing it but it don't work!!! i can't remember which driver i had bevore which worked!? but if it will run again (and i know it must) i never update my system again.... cause i felt in love with this eyecandy...\\:D/

Roybotnik
February 22nd, 2006, 01:01 AM
Add me to the list of people having trouble with XGL and compiz with the new ATI drivers that just went on the repos today. Go ATI.

9600 Mobility

macmasterxiv
February 22nd, 2006, 01:22 AM
Add me to the list of people having trouble with XGL and compiz with the new ATI drivers that just went on the repos today. Go ATI.

9600 Mobility

I think everyone is gonna have problems because the linux-restricted package hasn't been updated so the kernel module is still at 8.21.7

sephiroth_4
February 22nd, 2006, 01:29 AM
I get the same problem here on a Powerbook G4 17" with ATI 9600 Pro using the radeon driver (compiz.real: No composite extension).

I also don't have compiz in gconf neither.


Sorry cheif...I've moved to the dark side with nvidia. For testing, it just works, and for gaming the 7800 GTX is still a beast. I would love to run my 12" pb with this stuff, but ati...pffffft, poor ati. Tiger reigns on the pb...maybe xagl will come sooner rather than later.
Thanks for the guide again PHG!!!!!!!! This stuff is like a extra men code in contra, once you know it, you know it (for those who don't know, up up down down left right left right b a start) ;);) :-D
Good luck! THANKS!!!!!!! UBUNTU FORUMS AND SUPPORT ARE THE BEST!!!!!!!!!!!!!!

Odice
February 22nd, 2006, 01:43 AM
Ive fix the problems, no i justo have random freezes.

-Download from repos the files you need.
-Do the tick on the page 23 (the one who uses xsession to launch xgl, justo have to add that you need to chmod 755 the startxgl.sh)
-Add to sessions the gnome-window-decorator, and the compiz --replace decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher
-Start GDM and in option init the session with Xgl in the menu.

And tada there it is, just remember not to do the gmd.conf and stuf edition, they are not needed.

Ok, greets to all and thanks to all

nhwk64
February 22nd, 2006, 02:26 AM
I've been having problems with Xorg going to a black screen and completely locking X, if I use the fglrx driver, and I ctrl+alt+backspace to quit X (This seems to be just a problem with the ati driver and xorg, not related to xgl etc). I searched around and other people had this problem, and it seems that something to do with the kernel agp driver is causing the issue.

Anyone else had this problem?

Portanoo
February 22nd, 2006, 02:54 AM
I will stay on breez because compiz + Xgl works fine and no surprise with a simple dist-upgrade.

Xgl is not very dependent of Xorg 7

macmasterxiv
February 22nd, 2006, 03:58 AM
Just to let people know, I've got this running on a Radeon 7500 with the open source radeon driver. Pretty much all you have to do is follow this guide except replace all instances where the screen is changed to 1, keeping the default 0 since it doesn't have the fglrx problems. The performance is surprisingly good and the only real issue is a transparency bug. Also, make sure you are running in 24 bit color if your login screen colors are inverted/messed up.

anno
February 22nd, 2006, 04:08 AM
Just to let people know, I've got this running on a Radeon 7500 with the open source radeon driver. Pretty much all you have to do is follow this guide except replace all instances where the screen is changed to 1, keeping the default 0 since it doesn't have the fglrx problems. The performance is surprisingly good and the only real issue is a transparency bug. Also, make sure you are running in 24 bit color if your login screen colors are inverted/messed up.

That is good news. Not sure if it would work on my IGP 340M card though. Had a try yesterday, but the background kept covering the windows. If you would be kind enough to elaborate for the poor "radeon" dependent ones, i would be happy. What kind of transparency problem/bug did you have? Which howto did u use?

Thankful and hopeful.

coder_cotton
February 22nd, 2006, 06:56 AM
Wow, doing the method above:



Fixed my problems. By the way the infamous No composite extension found error, at least for me, was caused when I was trying to run compiz when I wasn't actually in Xgl. You do not need to add the composite section listed elsewhere to your X.org. That will make the error message go away but doesn't actually fix the problem.

And like people have been saying, running compiz successfully once (try just compiz --replace first) will add the setting to your gconf, access it and add plugins listed in order at beginning of this thread, and that is how I at least got it all to run.

Also a bug mentioned somewhere else is that the wobbly effect glitches if you are not a refresh rate of 60 Hz, either switch to that refresh rate or add a system monitor to your gnome panel and change its settings to an update interval of 50 ms. (this will have the added bonus of you being able to see how xgl doesn't tax you're cpu!)

Thanks everyone!

P.S. can somebody remind me what the actual code and quote tags are so I can edit this post and fix them :)
i'm still unable to run even "compiz --replace" without the no composite extension error.

Xylene
February 22nd, 2006, 07:42 AM
I personally can't get it going. No matter what debs I install for compiz the entries in gconf-editor don't show up. Then, someone, I don't know what I did, even after reediting the files back to their original state, XGL kept trying to run and slowed my X server down to a halt. I believe I got it back to the original state, though.

Using the fglxr ATi driver on a 9800 XT.

coder_cotton
February 22nd, 2006, 07:51 AM
I personally can't get it going. No matter what debs I install for compiz the entries in gconf-editor don't show up. Then, someone, I don't know what I did, even after reediting the files back to their original state, XGL kept trying to run and slowed my X server down to a halt. I believe I got it back to the original state, though.

Using the fglxr ATi driver on a 9800 XT.
i'm having the same problem regarding compiz entries not showing up in gconf-editor.

to my credit, the nvidia 6800 amd64 box right next to me is up and running xgl nicely, i just can't get past this no composite extension error. i'm on a amd64 compaq laptop w/ the ati m200 chipset, ati drivers are accelerated fine in regular gnome session. here's some console output...

jason@jason:~$ ps aux | grep Xgl
root 21349 0.0 0.5 8800 2600 ? S 21:23 0:00 /usr/X11R6/bin/ Xgl
root 21350 0.0 2.4 14080 11092 ? S 21:23 0:04 /usr/bin/Xorg - auth /tmp/.Xgl-auth-3qRdXt -nolisten tcp -dpms -v -s 0 :93 -terminate
jason 23688 0.0 0.1 3064 764 pts/1 S+ 22:52 0:00 grep Xgl
jason@jason:~$ ps aux | grep Xgl
root 21349 0.0 0.5 8800 2600 ? S 21:23 0:00 /usr/X11R6/bin/Xgl
root 21350 0.0 2.4 14080 11092 ? S 21:23 0:04 /usr/bin/Xorg -auth /tmp/.Xgl-auth-3qRdXt -nolisten tcp -dpms -v -s 0 :93 -terminate
jason 23694 0.0 0.1 2932 744 pts/1 R+ 22:52 0:00 grep Xgl
jason@jason:~$ compiz
compiz: No composite extension
jason@jason:~$ compiz --replace
compiz: No composite extension
jason@jason:~$ thefuture
compiz: No composite extension
jason@jason:~$ gnome-window-decorator, Failed to load shadow images

jason@jason:~$

Xylene
February 22nd, 2006, 07:53 AM
Hrm, apparently compiz isn't even installed!


root@athlon:/home/anthony/Desktop# dpkg -i compiz_0.0.3-1_i386.deb (Reading database ... 61770 files and directories currently installed.)
Preparing to replace compiz 0.0.3-1 (using compiz_0.0.3-1_i386.deb) ...
Unpacking replacement compiz ...
Setting up compiz (0.0.3-1) ...
root@athlon:/home/anthony/Desktop#



root@athlon:/home/anthony/Desktop# compiz gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher --replace
bash: compiz: command not found
root@athlon:/home/anthony/Desktop#


When using the battlehorse debs I found compiz in /opt/fdo/bin/compiz but I get the error about composite then. I removed that compiz install and installed the one from the Dapper repos but it still doesn't add the entries to gconf-editor.

I also apparently don't have gnome-window-decorator nor can I install it.

nhwk64
February 22nd, 2006, 07:58 AM
ii'm on a amd64 compaq laptop w/ the ati m200 chipset, ati drivers are accelerated fine in regular gnome session.

Have you updated your ati fglrx today, and does acceleration still work? I believe I was getting Xorg to run accelerated yesterday, but today after (I think) an updated xorg-driver-fglrx, my Xorg.0.log complains of kernel module version mismatches. (I'm using an ati card too, and the amd64-generic kernel)

Xylene
February 22nd, 2006, 10:44 AM
Does compiz not work with 8.22.5 or something?

Laterix
February 22nd, 2006, 12:33 PM
I managed to get this work on my laptop with Radeon 9600 mobility.... but then I broke it. :( I tried to change different window decoration, because I'm not too happy with this default semi-transparent theme. Is it even possible to use other themes with XGL+compiz? Are the window shadows part of the window-decorator?

I just reinstalled my dapper... hopefully I manage to get it back... can't live without anymore. :)

EDIT: Well, of course I doesn't work as well as before :( Everything else is fine, but there is no window decorations. Actually the command "gnome-window-decorator" doesn't even exists. What I'm missing here?

Here is what I get when I execute compiz


late@bumba:~$ compiz gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher --replace
compiz.real: Couldn't load plugin 'libgconf.so'
compiz.real: Couldn't load plugin 'libmenu.so'


Ok, I was missing gnome-compiz -package. Now I have window decarations as well. Everything seems to be working now... but dare I boot this computer ever again....

Someone asked about this Box effect when executing a program from panel launcher. For me it really lags and that's why I disabled it. You can disable this effect with gconf-editor. Go /apps/panel/global and remove tick from enable_animations box.

Tapir
February 22nd, 2006, 01:45 PM
I symlinked from /etc/X11/X to the Xgl, but when i reboot i can only see a black screen and a cursor showing a clock, which remains there (probably forever). The KDM login screen won't show.

When run Xgl in a Window from KDE it starts properly and also compiz.

Anyone else with the same Problem? I'm using all the debs from the universe on an ATI X600 with fglrx.

Regards,

Tapir

JeRa
February 22nd, 2006, 01:49 PM
Success! At least partly...
...
Except that every time I open an application, there's about a 50% chance that the system will hard freeze. So it's still pretty much unusable, but it's pretty cool when it does work.

I'm assuming this is just a bug proving the unstability of an alpha release, but if not, anyone know how to fix it?

Thinkpad t43
Mobility Radeon x300

I have the same problem, NEC Versa P550 with Mobility X300...everything works fine, but I don't even get the chance to run compiz as opening the KDE menu crashes Xgl :( I use the method described on page 23, but no luck as to this moment.

EstevaoSoares
February 22nd, 2006, 03:35 PM
Have you updated your ati fglrx today, and does acceleration still work? I believe I was getting Xorg to run accelerated yesterday, but today after (I think) an updated xorg-driver-fglrx, my Xorg.0.log complains of kernel module version mismatches. (I'm using an ati card too, and the amd64-generic kernel)


Same for me... but it worked after a sudo apt-get dist-upgrade and a second reboot.

Dist-upgrade on Dapper Flight4 right now will upgrade its kernel.


See ya!

Vinterstum
February 22nd, 2006, 04:38 PM
i'm having the same problem regarding compiz entries not showing up in gconf-editor.

to my credit, the nvidia 6800 amd64 box right next to me is up and running xgl nicely, i just can't get past this no composite extension error. i'm on a amd64 compaq laptop w/ the ati m200 chipset, ati drivers are accelerated fine in regular gnome session. here's some console output...
...


Xgl shouldn't be running as root, but as your regular user ('jason' in your case).

Vinterstum
February 22nd, 2006, 04:39 PM
I symlinked from /etc/X11/X to the Xgl, but when i reboot i can only see a black screen and a cursor showing a clock, which remains there (probably forever). The KDM login screen won't show.

When run Xgl in a Window from KDE it starts properly and also compiz.

Anyone else with the same Problem? I'm using all the debs from the universe on an ATI X600 with fglrx.

Regards,

Tapir

Xgl isn't a replacement for the regular X server, it's -supposed- to run on top of it.

Roybotnik
February 22nd, 2006, 05:01 PM
Xgl isn't a replacement for the regular X server, it's -supposed- to run on top of it.

He's referring to the guide located on the Ubuntu wiki. It says to symlink /usr/bin/Xgl to /etc/X11/X. It doesn't work with radeons because of the fglrx problems.

JeRa
February 22nd, 2006, 05:26 PM
Xgl shouldn't be running as root, but as your regular user ('jason' in your case).
Vinterstum, you seem to have the exact same videocard as I have (ATI Radeon Mobility X300), did you experience any freeze problems? I have followed your instructions which lead to the same problem: my system freezes whenever I open a new window or menu.

seanodonnell
February 22nd, 2006, 06:03 PM
Anyone had any luck with an ATI MOBILITY FireGL V3200 ?

I cant get xgl to start, unless I remove dri from my xorg.conf.
If I do and then I attempt to start compiz, etc

I get the non_power bug, and no manageable screens found.

Anyone have any suggestions?

thanks

Sean

William the Conquerer
February 22nd, 2006, 07:01 PM
I've got that same card in my Thinkpad T43p (the firegl v3200) and I think I got the oss ati fglrx driver working at one time, but I just went through the steps here: http://ubuntuforums.org/showpost.php?p=423584 to install fglrx drivers... it works, BUT I do not get hardware acceleration and sudo fglrxinfo just gives me stuff about mesa... I have not been able to get Xgl and compiz to work (I'm using kde btw and I had to apt-get install gdm and just use that to boot into Xgl) so I could boot to Xgl, but not use compiz and it was the same no manageable screens stuff... SO, I don't know what to tell you, but I'm definitely searching for the same problem, have you found anything different? btw, I have Load "dri" enabled in xorg.conf and it seems to work...

Xylene
February 22nd, 2006, 07:24 PM
I finally got it working on my 9800 XT. I have to run that script, thefuture for window decorations to show up, but besides that, works great.

twisted_steel
February 22nd, 2006, 08:22 PM
I got it working with my 9600 XT using the XGl session. It couldn't get the fglrx acceleration working properly until today when a kernel update fixed it.

This is on my desktop which is running Dapper.

frozdsolid
February 22nd, 2006, 09:01 PM
Vinterstum, you seem to have the exact same videocard as I have (ATI Radeon Mobility X300), did you experience any freeze problems? I have followed your instructions which lead to the same problem: my system freezes whenever I open a new window or menu.


I have a thinkpad T43 with the mobility radeon x300, and i encountered the same freeze problems when i was using self compiled packages. Mind you, I tried this with all the day compiz was released. Have you tried it with the latest packages from the repository since dapper flight 4 was released? I'm wondering if the freezing issues have been resolved.

William the Conquerer
February 22nd, 2006, 09:21 PM
It couldn't get the fglrx acceleration working properly until today when a kernel update fixed it.

are you using the open source fglrx from: http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html, were you able to just apt-get it and use the restricted modules or (and I'm not sure if this even exists) did you use the official ati fglrx driver... was it just the kernel update or was it also a restricted modules update (that has the fglrx module).

zachtib
February 22nd, 2006, 10:21 PM
can someone tell me what this means:


zach@notapowerbook:~$ export LIBGL_DEBUG=verbose
zach@notapowerbook:~$ glxgears
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/atiogl_a_dri.so
fglrx: libGL version does not match - OpenGL module is using glapi fallback
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
drmOpenByBusid: busid is PCI:1:0:0
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:1:0:0

zach@notapowerbook:~$ fglrxinfo
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/atiogl_a_dri.so
fglrx: libGL version does not match - OpenGL module is using glapi fallback
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
drmOpenByBusid: busid is PCI:1:0:0
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: FireMV 2400 PCI DDR Generic
OpenGL version string: 1.3.1050 (X4.3.0-8.22.5)

zach@notapowerbook:~$


I copied the dri drivers as iunstructed in this post: http://ubuntuforums.org/showthread.php?p=753120&highlight=mobility#post753120
did i put them in the wrong place? where should i have copied them to?

ATI Mobility Radeon 9000, btw

EstevaoSoares
February 22nd, 2006, 11:37 PM
Hi folks!

That's more good news!

I've got it working and.. man, it's so beautiful :D

But I've got a big halt on system on I try to access xterm from gnome bar. If I try from gnome-menu it goes fine.


Someone knows how to get my Terminal Transparent?

I'm so glad folks :D


My system.

Notebook compat V2000
Turion64 1.6
ATI Radeon Xpress 200M 128 Shared

Good luck for everyone... I just need to learn how to manage this right now!

nhwk64
February 22nd, 2006, 11:58 PM
Got Xgl and dri acceleration working back today with the dist-upgrade, but back to the problem I was having before:

fglrxinfo -display :1 shows
Error: couldn't find RGB GLX visual!

glxgears shows
Error: couldn't get an RGB, Double-buffered visual

grep -i glx /var/log/Xorg.1.log shows
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
(II) Loading extension GLX

Anyone have any idea? There is a bit of screen corruption happening when Xgl is running, also.


Edit: found this in my xorg log:

(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
dlopen: /usr/lib/xorg/modules/extensions/libGLcore.so: undefined symbol: __glXLastContext
(EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
(II) UnloadModule: "GLcore"
(EE) Failed to load module "GLcore" (loader failed, 7)

EstevaoSoares
February 23rd, 2006, 12:15 AM
Something I could see now is that when I minimize some window It can't be find on the bar anymore and I can't maximize it... Any Ideias?

eeclark
February 23rd, 2006, 01:14 AM
7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:

gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher
It MUST be in this order as there are dependencies between them. If you've already been playing with this from earlier debs - maybe from battlehorse, or maybe you rolled your own - this is an important step because it's very likely in the wrong order. Most people that are missing certain plugins or are missing things like "alt-switch" will find they need to correct this and restart.


On this item you might want to clarify by stating it is actually "right click on the active_plugins key and select Edit Key..." instead of just stating "adjust 'plugins'".

EstevaoSoares
February 23rd, 2006, 01:31 AM
Guys,


Something I realize is that with the new compiz / gnome-compiz the gconf-editor (with no compiz) problem was solved.

In my first try with an old compiz it didn't appear on gconf-edtir even after typing compiz --replace on terminal.
Now, with the new from repo everything was there.

That's it.

Good luck u folks

seanodonnell
February 23rd, 2006, 02:39 AM
I've got that same card in my Thinkpad T43p (the firegl v3200) and I think I got the oss ati fglrx driver working at one time, but I just went through the steps here: http://ubuntuforums.org/showpost.php?p=423584 to install fglrx drivers... it works, BUT I do not get hardware acceleration and sudo fglrxinfo just gives me stuff about mesa... I have not been able to get Xgl and compiz to work (I'm using kde btw and I had to apt-get install gdm and just use that to boot into Xgl) so I could boot to Xgl, but not use compiz and it was the same no manageable screens stuff... SO, I don't know what to tell you, but I'm definitely searching for the same problem, have you found anything different? btw, I have Load "dri" enabled in xorg.conf and it seems to work...

I have had mixed results on the dri/no dri thing. Depends which days updates i am on. I have gotten Xgl to start, but never gotten past the no manageable screens stuff. Im going to keep trying every few days, If I have any success I will let you know

Sean

twisted_steel
February 23rd, 2006, 05:16 AM
are you using the open source fglrx from: http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html, were you able to just apt-get it and use the restricted modules or (and I'm not sure if this even exists) did you use the official ati fglrx driver... was it just the kernel update or was it also a restricted modules update (that has the fglrx module).

I am using the fglrx driver from the Dapper repositories. I imagine it may have been the restricted modules update that fixed it (both the kernel and restricted modules were updated when I last ran Synaptic).

eeclark
February 23rd, 2006, 06:08 AM
edward@smallville:~$ glxinfo |grep rendering
direct rendering: No

is that normal for Xgl?

Using ATI "fglrx" driver.
Seems fast enough, though.

Vinterstum
February 23rd, 2006, 10:12 AM
Vinterstum, you seem to have the exact same videocard as I have (ATI Radeon Mobility X300), did you experience any freeze problems? I have followed your instructions which lead to the same problem: my system freezes whenever I open a new window or menu.

Yeah, I get freezes once in a while. Not as often as you do, though, no idea why :(. But often enough that I don't use Xgl normally. I chalked it down to issues with fglrx itself, so we might just have to wait it out.

JeRa
February 23rd, 2006, 11:50 AM
Yeah, I get freezes once in a while. Not as often as you do, though, no idea why :(. But often enough that I don't use Xgl normally. I chalked it down to issues with fglrx itself, so we might just have to wait it out.
I noticed that the fglrx driver tends to crash even when using the normal Xorg server instead of Xgl when switching between screens or logging out; hopefully ATI will release a new driver soon with bigger changes than 'fglrx is now able to read more than 22 lines from the config!!'. Quite annoying since I receive no error or warning at all; maybe AGP related?

Zek
February 23rd, 2006, 01:12 PM
edward@smallville:~$ glxinfo |grep rendering
direct rendering: No

is that normal for Xgl?

Using ATI "fglrx" driver.
Seems fast enough, though.

Same here :



nicolas@Tux:~$ fglrxinfo -display :1
display: :1.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.2 (2.0.5642 (8.22.5))


nicolas@Tux:~$ glxinfo
name of display: :1.0
display: :1 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.2 (2.0.5642 (8.22.5))
OpenGL extensions:
GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1 0 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1 0 Ncon
nicolas@Tux:~$

No direct rendering but opengl works fine.

rawler
February 23rd, 2006, 01:46 PM
Jera, frozdsolid: I'm also on a T43 with an ATI X300 running FGLRX. For me it crashes to the extent of being unusable. A bit sad, since each time I turn on Xgl gives me a little smile on my face. :) (Until the laptop dies on me, of course ;) )

husher
February 23rd, 2006, 09:57 PM
I just wanted to confirm that this works exceedingly well on my notebook which has an ATI Mobility Radeon 9700 graphics chip. If anyone knows of a database or list I should add this setup to, let me know.

Thanks for all the info and the hard work!

christophsky
February 23rd, 2006, 11:37 PM
Has anyone been able to get XGL+compiz to work with Mobility Radeon 9000? I can get Xglserver to run (it's very slow) but when I issue the compiz command (with options of course) my screen becomes heavily corrupted. I know others with this card have reported similar experiences. So, does anyone know of a workaround? Thanks!

BTW, I have XGL working flawlessly on another machine with a geforce 6800. The effects are simply stunning...

didit
February 23rd, 2006, 11:52 PM
For ati 9000, you should use 'radeon' driver. For detail:
http://www.ubuntuforums.org/showthread.php?t=129505&page=19

christophsky
February 24th, 2006, 12:08 AM
Thanks didit. Somehow I missed that while searching.

macmasterxiv
February 24th, 2006, 01:48 AM
That is good news. Not sure if it would work on my IGP 340M card though. Had a try yesterday, but the background kept covering the windows. If you would be kind enough to elaborate for the poor "radeon" dependent ones, i would be happy. What kind of transparency problem/bug did you have? Which howto did u use?

Thankful and hopeful.

Getting radeon driver to work:

1. make sure you have direct rendering enabled in glxinfo.

2. edit the xorg.conf and make sure that GLcore is commented out, but leave dri and glx enabled in the modules section. Also make sure the color is set for 24 bit to avoid inverted colors/corruption.

3. edit the gdm.conf-custom file like so:
[servers]
# Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX).
0=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo
flexible=true

** Make sure to leave the regular gdm.conf alone, default settings are fine.

Now it's the same as the fglrx howto.

4. Modify your session ("Menu System" -> "Preferences" -> "Sessions") by adding in the following two items:

gnome-window-decorator (must be on top, start first)
compiz --replace gconf

5. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:


gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher

The transparency bug is when the background sometimes shows thorough the windows at points.

oceanelement
February 24th, 2006, 04:23 AM
I just wanted to confirm that this works exceedingly well on my notebook which has an ATI Mobility Radeon 9700 graphics chip. If anyone knows of a database or list I should add this setup to, let me know.

Thanks for all the info and the hard work!

If you could write up something on how you did it that would be greatly appreciated. I have a 9700 as well. The main problem at the for my computer is that in gconf-editor compiz is not showing up :(

oceanelement

guyhersh
February 24th, 2006, 04:33 AM
If you could write up something on how you did it that would be greatly appreciated. I have a 9700 as well. The main problem at the for my computer is that in gconf-editor compiz is not showing up :(

oceanelement

To get it to show up, be running IN Xgl (you'll probably be windowless) and run the command "compiz --replace somethin something" that is on Pg 16 of this thread.

It ONLY went into gconf-editor AFTER i ran that command WHILE i was running Xgl, then restarted.

hope that helps.

Guy

joflow
February 24th, 2006, 10:05 AM
Trying to install...r9500

I'm having the no compriz in gconf-editor problem but the command on page 16 doesn't fix it. It starts compiz (and I get to see all the sweet effect with no borders) but it doesn't add compiz to my gconf-editor. Any ideas?

joflow
February 24th, 2006, 10:13 AM
Trying to install...r9500

I'm having the no compriz in gconf-editor problem but the command on page 16 doesn't fix it. It starts compiz (and I get to see all the sweet effect with no borders) but it doesn't add compiz to my gconf-editor. Any ideas?

When I run compiz from the terminal I also get this error:

compiz.real: Couldn't load plugin 'libmenu.so'

but as I've said...all the effects work (cube, wobbly,expose)

joflow
February 24th, 2006, 10:25 AM
gnome-compiz fixed the problem.

oceanelement
February 24th, 2006, 10:53 AM
Ok, I think I know where the problem begins. When I try to do a manual compiz command,


$ compiz -- blah blah etc.

the output is the following


$ compiz.real couldn't open display

I have the latest ATI driver and I glx is working. When I first tried to get compiz working the gconf-editor never showed compiz under apps. This problem still persists. Any suggestions?

Oceanelement

joflow
February 24th, 2006, 02:14 PM
Ok, I think I know where the problem begins. When I try to do a manual compiz command,



the output is the following



I have the latest ATI driver and I glx is working. When I first tried to get compiz working the gconf-editor never showed compiz under apps. This problem still persists. Any suggestions?

Oceanelement


install gnome-compiz. Its in the repos.

xavatar
February 24th, 2006, 02:28 PM
For those that still have problems, here are my config files


* /usr/share/xsessions/xgl.desktop:


[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl.sh 1
Icon=
Type=Application


* /usr/bin/startxgl.sh


#!/bin/bash

echo ">Starting XGL at Display: $1"
echo "========= XGL ============"
Xgl -fullscreen :$1 -ac -accel xv -accel glx:pbuffer &
sleep 5

echo "======= COMPIZ ==========="
DISPLAY=:$1 LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ compiz --replace decoration wobbly fade switcher minimize cube rotate zoom scale move resize place &
sleep 3

echo "====== DECORATIONS ======="
DISPLAY=:$1 gnome-window-decorator &
sleep 3

echo "======= GNOME ============"
DISPLAY=:$1 setxkbmap -model pc105 -layout fr -variant basic
DISPLAY=:$1 gnome-session

#echo "======= LOGOUT ============"
#killall Xgl
# Adding the line above,if you can't logout Gnome correctly.


*/etc/X11/xorg.conf


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "extmod"

# This loads the DBE extension module.

# Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# SubSection "extmod"
# Option "omit xfree86-dga" # don't initialise the DGA extension
# EndSubSection

EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Driver "fglrx"

# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver$# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "(null)"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "yes"
Option "ForceGenericCPU" "no"
BusID "PCI:1:0:0" # vendor=1002, device=4150
Screen 0
EndSection

Section "Monitor"
Identifier "LS902U"
Option "DPMS"
HorizSync 30-96
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Monitor "LS902U"
DefaultDepth 24
#Option "backingstore"

SubSection "Display"
Depth 1
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection


Everything work great for me and i can log using GDM...
Though be sure to delete /tmp/.X1-lock before running and don't forget to
chmod a+x /usr/bin/startxgl.sh

Good luck

aboe
February 24th, 2006, 09:49 PM
For those that still have problems, here are my config files


* /usr/share/xsessions/xgl.desktop:


[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl.sh 1
Icon=
Type=Application

* /usr/bin/startxgl.sh


#!/bin/bash

echo ">Starting XGL at Display: $1"
echo "========= XGL ============"
Xgl -fullscreen :$1 -ac -accel xv -accel glx:pbuffer &
sleep 5

echo "======= COMPIZ ==========="
DISPLAY=:$1 LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ compiz --replace decoration wobbly fade switcher minimize cube rotate zoom scale move resize place &
sleep 3

echo "====== DECORATIONS ======="
DISPLAY=:$1 gnome-window-decorator &
sleep 3

echo "======= GNOME ============"
DISPLAY=:$1 setxkbmap -model pc105 -layout fr -variant basic
DISPLAY=:$1 gnome-session

#echo "======= LOGOUT ============"
#killall Xgl
# Adding the line above,if you can't logout Gnome correctly.


Everything work great for me and i can log using GDM...
Though be sure to delete /tmp/.X1-lock before running and don't forget to
chmod a+x /usr/bin/startxgl.sh

Good luck

I tried it your way, because it seems easy and a good idea to have a choice .
But I can't get it working...
I get kicked back at gdm-login...

been fiddling around and I can't seem to get it working correctly..

If I start from the command line with this code:


#!/bin/bash
sudo killall gdm
sudo killall Xgl &
sudo killall Xorg &
wait
sleep 2
sudo /usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
DISPLAY=:1 gnome-window-decorator &
DISPLAY=:1 compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
sleep 4
DISPLAY=:1 gnome-settings-daemon &
DISPLAY=:1 gnome-panel &
DISPLAY=:1 nautilus &
sleep 8


It works.. but not from gdm with your files..

fangorious
February 24th, 2006, 10:34 PM
I tried the startxgl.sh/xgl.desktop route with the Ati binary fglrx driver manually built. That crashed on login while drawing the desktop background. The gnome splash screen came and went, and I got a popup about a disk being 95% full, then the background started to display, and was immediately deformed as though a window was being dragged around and the screen was being redrawn quickly enough. Then everything froze. Mouse pointer was unresponsive, ctrl-alt-del didn't reboot, ctl-alt-backspace didn't kill X. Using the gdm.conf[-custom] route I could get gnome and gnome-window-decorator running but compiz wouldn't start, the message about not finding a manageable screen/display (yes I tried starting it with both --display and with DISPLAY=:1, no effect from either).

So I tried going with the build of the binary driver in the repos (since it's up to 8.22.5 now). The drivers work for plain old X with dri. But Xgl hangs right away using them. And I can't seem to go back to using manually built drivers. The final step of 'module-assistant a-i fglrx) to get the kernel module fails. One thing that catches my eye with the repo drivers is the version numbers seem to indicate being built against xorg 6.9.0.



[justin@justinxp ~]
$ dpkg -l xorg-driver-fglrx
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xorg-driver-fg 6.9.0-8.22.5+2 Video driver for ATI graphics accelerator

fungi
February 25th, 2006, 07:12 AM
compiz and glx are running quite nicley on 9550

but..

- theme selector crashes whenevr i change wigits or icons ( but the new settins are applied )
-frozen-bubble is transparent (unless you put a black terminal behind it )
-vlc has no window borders ( alt click any where to move the window )

thanks for the how-to.

peace

xavatar
February 25th, 2006, 08:20 AM
I tried it your way, because it seems easy and a good idea to have a choice .
But I can't get it working...
I get kicked back at gdm-login...

been fiddling around and I can't seem to get it working correctly..

If I start from the command line with this code:


#!/bin/bash
sudo killall gdm
sudo killall Xgl &
sudo killall Xorg &
wait
sleep 2
sudo /usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
DISPLAY=:1 gnome-window-decorator &
DISPLAY=:1 compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
sleep 4
DISPLAY=:1 gnome-settings-daemon &
DISPLAY=:1 gnome-panel &
DISPLAY=:1 nautilus &
sleep 8


It works.. but not from gdm with your files..

Well that's strange, i've no extra repo except PLF, nothing compiled from source and it work as a charm with my radeon 9600.

Do you get an error message complaining about the session that was too short ?

xavatar

aboe
February 25th, 2006, 09:27 AM
yes it complaines about it.

zasf
February 25th, 2006, 09:40 AM
[justin@justinxp ~]
$ dpkg -l xorg-driver-fglrx
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xorg-driver-fg 6.9.0-8.22.5+2 Video driver for ATI graphics accelerator


Is newest ATI driver (8.22.5) reported to work with xgl?

xavatar
February 25th, 2006, 01:15 PM
yes it complaines about it.

Have you tried setting a longer sleep after Xgl start ?

aboe
February 25th, 2006, 01:54 PM
Have you tried setting a longer sleep after Xgl start ?
that helped a lot...

I have renamed it a bit: startxgl-gnome

my new code looks like:

#!/bin/bash

echo ">Starting XGL at Display: $1"
echo "========= XGL ============"
Xgl -fullscreen :$1 -ac -accel xv:pbuffer -accel glx:pbuffer &
sleep 6

echo "======= COMPIZ ==========="
DISPLAY=:$1 LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ compiz --replace gconf decoration wobbly fade switcher minimize cube rotate zoom scale move resize place &
sleep 3

echo "====== DECORATIONS ======="
DISPLAY=:$1 gnome-window-decorator &
sleep 3

echo "======= GNOME ============"
DISPLAY=:$1 setxkbmap -model pc105 -layout us -variant basic
DISPLAY=:$1 gnome-session

#echo "======= LOGOUT ============"
#killall Xgl
# Adding the line above,if you can't logout Gnome correctly.

and for XFCE4 : startxgl-xfce4

#!/bin/bash

echo ">Starting XGL at Display: $1"
echo "========= XGL ============"
Xgl -fullscreen :$1 -ac -accel xv -accel glx:pbuffer &
sleep 6

echo "======= COMPIZ ==========="
DISPLAY=:$1 LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ compiz --replace gconf decoration wobbly fade switcher minimize cube rotate zoom scale move resize place &
sleep 4

echo "====== DECORATIONS ======="
DISPLAY=:$1 gnome-window-decorator &
sleep 4

echo "======= XFCE4 ============"
DISPLAY=:$1 xfce4-session

#echo "======= LOGOUT ============"
#killall Xgl
# Adding the line above,if you can't logout Gnome correctly.


All is working now.

giosquad
February 25th, 2006, 02:58 PM
Hi folks,
thanks to all you I have tried Xgl and compiz after spend long time with fglrx, I tried with radeon open source driver and works for a while, seems that for my radeon 9000pro and 9000 series there is a problem with fglrx that I have and that must be corrected:
http://gentoo-wiki.com/XGL#Whole_distortion

Have someone of you the same problem with fglrx?

Moreover there is an other strange thing with latest fglrx installed from dapper repository with restricted modules package, direct rendering is ok, but:



gio@kubalien:~$ export LIBGL_DEBUG=verbose
gio@kubalien:~$ fglrxinfo
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/atiogl_a_dri.so
fglrx: libGL version does not match - OpenGL module is using glapi fallback
libGL: XF86DRIGetClientDriverName: 8.22.5 atiogl_a (screen 0)
drmOpenByBusid: busid is PCI:2:0:0
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:2:0:0
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9000 PRO DDR Generic
OpenGL version string: 1.3.1050 (X4.3.0-8.22.5)



What could I do to correct glapi fallback?

Thanks,
Giordano

fangorious
February 25th, 2006, 08:40 PM
Is newest ATI driver (8.22.5) reported to work with xgl?


A bunch of people in this thread have said they have it working with the drivers in the repos, which are at v 8.22.5.

aboe
February 25th, 2006, 08:49 PM
I got Xgl and compiz working with everything from the repos.
so yes.

the repo version is: 6.90-8.22.5+2.6.15.6-1(dapper)

hentaidan
February 26th, 2006, 12:33 AM
Working on:

ATI Radeon 9550 128mb, with all the latest from the repos.

Had no apps/compiz in gconf so tried with battlehorse instructions (using repo), but was no go, so retried with tutorial here, and compiz had appeared in gconf, but no plugins. Removed any entries from gnome-session-properties as it seems to be having problems with me atm, freezing, messing up orders. Aside from a short wait before login screen at an oldstyle black and white grid wallpaper, nothing changed so have to run:
gnome-window-decorator and
sudo compiz gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher --replace after login.

Zero crashes or freezes. Lags a bit when moving windows. (No transparency). Zoom, cube, all working BEAUTIFULLY!!!

Thank-you!!! \\:D/

poyner
February 26th, 2006, 10:40 AM
Hi all,
I've had XGL+compiz working for a while now but I still haven't managed to get any transparency love. Are others also having problems with this? If you've managed to get it working what did you do? Any assistance appreciated.

Poyner

Edit: OK I've done a bit of playing. I have transset installed using apt-get. I can go to a terminal and type in transset .7 (for example) and then click on a window and it will set the transperancy of that window to 70%.... This is pretty cool.... but how do I get a dropdown list when right clicking on the titlebar? Or isn't this implemented properly yet?

oceanelement
February 26th, 2006, 11:59 AM
ATI AIW9600 Pro / PIV 2.8Ghz / 1Go
Dapper, Xgl from repo, fglrx driver
Xgl is running with a modified gdm.conf & -custom
I would have said quite stable, but my post was just deleted with a crash : )

To start Compiz, I had to remove "gconf" from the command line.



If I add gconf anywhere in the command, it's failing. I don't know why. All the other plugins are working fine, be careful with the order, you can't change it the way you want, there are some dependencies (some plugins must be loaded before others).

No need of any sudo, you can forget about my previous advise.

So far, it's very smooth, I will talk about the stability after some tests.


You're move on taking out gconf worked for me as well. This maybe a good tip for others. My main symptom in the beginning with compiz was that it did not want to show up in my gconf-editor. I did two fresh installs to get compiz working. After taking the gconf out it worked like a charm. Now it boots up with my system \\:D/

oceanelement

lawngn0mex
February 26th, 2006, 08:29 PM
I followed the steps in the fist post....


Direct Rendering is off.. can't figure out how to enable it.
fglxr I'm using from the repos.. along with xgl and compiz.

I'm just getting an insane amount of hardlocking... any suggestions on where I can look to it's souirce.. or something that people have had luck with?

Kernel 2.6.15-16-k7


everything installed from the repos.

x800xl pci-e

running compiz off of startup programs in gnome, along with the gnome-window-decorator

compiz decoration move resize place switcher wobbly fade minimize cube rotate zoom scale --replace

Athauglas
February 27th, 2006, 12:45 AM
Hey all.

Has anyone tried installing this on a thinkpad? I'm using a T43, and so far I've got nothing.

I had noticed a few things before going back to Breezy, though:

- fglrx works well. fglrxinfo normally reports the correct driver's in use, and the right GPU. But, as soon as I install xgl (and make the appropriate changes to gdm.conf and .conf-custom) I get the following: "Error: unable to open display :0" Shortly after the system will lock up, and once that happens, I cant start normally at all.

-after being installed, compiz doesn't have an entry in the gconf editor, so I cant follow the instructions to change the effects, etc. I have no idea if this is even a problem since everything is pretty well hosed before then, and I've only gotten that far once out of half a dozen tries.

-when the system did start with xgl, there was a long pause on the old style black/white background before the login screen appeared. When it fails, it does so the same way each time - the login screen will flash, and then a blank white screen will appear with just the cursor, and "..." where the text box would be. At that point the system is unresponsive and has to be powered off.


So, while this is really beyond my ability, it looks like I have at least one big issue, and that is xgl isn't happy with some of the hardware hardware present. It'd be nice to find a solution but none of the threads (including this one) cover anything like what's happening here. I'll include some details in case someone has an idea:

IBM Thinkpad T43, 2687-DDU
512mb system memory
Mobility X300 with 64mb dedicated mem
Pentium M 750

Everything was done on a clean install using Dapper flight 4 disc, made current using software update, switched to the 686 kernel... um.. swap partition is about 1GB.. i dunno what else might be relevant.

Thanks :)

eeclark
February 27th, 2006, 04:14 AM
my best success was to install from Flight 4 and use the method on this thread that shows you how to create an XGl session rather than modding the gdm files.

palomar
February 27th, 2006, 03:44 PM
-when the system did start with xgl, there was a long pause on the old style black/white background before the login screen appeared. When it fails, it does so the same way each time - the login screen will flash, and then a blank white screen will appear with just the cursor, and "..." where the text box would be. At that point the system is unresponsive and has to be powered off.

I have the same problems with that long spause on the login screen. Also when I try command like 'fglrxinfo -display :1', 'glxinfo' or 'glxgears' there is a long pause before the command will be executed.
Another little annoyance is when I start an application from a panel it starts slow. I don't know how to describe exactly, but I can see the window being build up from increasing black rectangles. It's only when I click icons in the panel. When I start an app. from the Gnome menu it does start quickly.

My specs:
Athlon64 2800
Radeon 9800SE
Installed Dapper and XGL/ati drivers from repository this morning, so everything is up to date.

fglrxinfo -display :1 displays that I'm using ATI drivers. Besides the problems I mentioned above, all graphical effects are running very smoothly.

DOes anyone have a sollution for this?

strawman
February 27th, 2006, 04:46 PM
Same on my system. From the panel i also have those expanding lines, not from the menu. It also appears that DRI is off but it was functioning before, maybe Xgl can't use dri.

Using Hp nc8000 laptop with mobility radeon 9600.

everything runs pretty smooth but it does use a lot more of the cpu

mcduck
February 27th, 2006, 05:15 PM
Another little annoyance is when I start an application from a panel it starts slow. I don't know how to describe exactly, but I can see the window being build up from increasing black rectangles. It's only when I click icons in the panel. When I start an app. from the Gnome menu it does start quickly.
Open configuration editor, browse to apps/panel/global and unmark 'enable_animations'..

aamukahvi
February 27th, 2006, 05:19 PM
palomar & strawman:

Start gconf. Navigate to /apps/panel/global. Turn off enable_animations.

ed: seems I'm too slow.

palomar
February 27th, 2006, 08:06 PM
Thanks, that worked :)

But I have another problem: when I try an 'OpenGL'-related command like 'fglrxinfo -display :1', 'glxinfo' or 'glxgears' there is a long pause before the command will be executed. What can I try tol solve it?

Their is also still a hige delay when starting X-server. For about 30 seconds I see the ' classic' X black-white raster with a mouse cursor in it.

MaZiNgA
February 27th, 2006, 08:49 PM
Hi I'm using XGL with an ATI IGP 345M but the desktop is veeeeery slow and has many glitches too! Can ayone help? I'm using the "radeon" driver and 3D is enabled.

MeijUbuntu
February 27th, 2006, 09:04 PM
Well, after lot's of frustration with my ATI X600 card, i decide to buy me a Nvidia 6600GT.

Froms scratch all works well !

It's a bad thing that ATi doesn't support and maintain there Linux drivers well.

Thnx

P.S. Who wan;t to buy a ATI X600 ??? :D :D :D

strawman
February 28th, 2006, 03:34 AM
Hey, thanks that did the trick

bugmenot
February 28th, 2006, 10:05 PM
Well, finally got it working with my Mobility Radeon 9700 :)
How can i take screenshots of the 3d cube? When using the std. screenshot prog i only see the active desktop...

DeeZiD
February 28th, 2006, 10:10 PM
You can do that with gimp or ksnapshot :)


regards Dennis

jsgaarde
February 28th, 2006, 10:48 PM
Hi.
I have installed everything alright, and everything seems to work alright, almost :-k
The only problem seems to be that the wobling windows don't seem to wobble finished.
How so you ask?
Well, if i start dragging a window the window wobbles smoothly around while moving the mouse around continiously. If I suddenly hold the mouse cursor still the wobling also freezes. That doesn't look very cool at all.
Does anybody else experience the same?

Best regards
Jakob Simon-Gaarde

Athropos
March 1st, 2006, 08:07 AM
Well, if i start dragging a window the window wobbles smoothly around while moving the mouse around continiously. If I suddenly hold the mouse cursor still the wobling also freezes. That doesn't look very cool at all.
Does anybody else experience the same?


I experience this also. Some windows seem more subject to this, especially terminal windows. I don't have this problem with mplayer windows for example.

oceanelement
March 1st, 2006, 08:55 AM
I experience this also. Some windows seem more subject to this, especially terminal windows. I don't have this problem with mplayer windows for example.

Im not experiencing that problem at all. It could be because I have my compiz setup slightly different than what this thread.

Using ATI radeon 9700 mobility with compiz-gnome from repository.

I did everything this thread has suggested for the ati setup except one thing: using the hack from poofyhairyguy "thefuture" in his thread.

hentaidan
March 1st, 2006, 09:36 PM
Hi.
Well, if i start dragging a window the window wobbles smoothly around while moving the mouse around continiously. If I suddenly hold the mouse cursor still the wobling also freezes. That doesn't look very cool at all.

Quoting Hobbes from earlier in the thread...:


Also a bug mentioned somewhere else is that the wobbly effect glitches if you are not a refresh rate of 60 Hz, either switch to that refresh rate or add a system monitor to your gnome panel and change its settings to an update interval of 50 ms. (this will have the added bonus of you being able to see how xgl doesn't tax you're cpu!)

Dan

GazaM
March 2nd, 2006, 12:04 AM
Unfortunately my ATI equipped machine suffers from complete lockup/freezing with Xgl, so it's unusable for me there. I'm writing this from a PC with an old GeForce2 MX and Xgl/compiz is running rock solid. Pretty disappointing not to be able to run this on my main machine though, anybody know what's causing these lockups? I know others here have mentioned it as well. Hoping a fix is available, as I'm blown away by the effects, as are my friends and family... some of them really are good for usability, such as the window minimising effect and the zoom effect.

oceanelement
March 2nd, 2006, 03:55 AM
I just did an update and some errors came up with the error. Now the x server keeps trying to boot up with no luck. i suspect is has to do something with the way xgl is put into the system. Anyone else experiencing the same problem?

Lux Perpetua
March 2nd, 2006, 11:31 AM
Hey all.

Has anyone tried installing this on a thinkpad? I'm using a T43, and so far I've got nothing.
I actually installed Xgl and Compiz on my Thinkpad T43p, and it "worked." By "worked" here I mean there were about 30 minutes of bliss and drooling at the translucency and jello-like windows, but apparently I just got lucky that one time. Every other time, X locked hard before I could even log into GDM. I had to go back to X.org/Metacity to be able to use my system again.


-after being installed, compiz doesn't have an entry in the gconf editor, so I cant follow the instructions to change the effects, etc. I have no idea if this is even a problem since everything is pretty well hosed before then, and I've only gotten that far once out of half a dozen tries.
I had that problem, but there is a way to fix this. I think you need to run compiz once to add the gconf entry. I followed this: http://battlehorse.homelinux.net/w/Wiki.jsp?page=HowToXglATI


-when the system did start with xgl, there was a long pause on the old style black/white background before the login screen appeared. When it fails, it does so the same way each time - the login screen will flash, and then a blank white screen will appear with just the cursor, and "..." where the text box would be. At that point the system is unresponsive and has to be powered off.

I too am acquainted with the flash and the beautiful snowy screen of icy Xgl death :-) It happened almost every time, but once it actually let me log in and mess around for a few minutes before cutting me off.

tukster
March 2nd, 2006, 08:54 PM
I too am acquainted with the flash and the beautiful snowy screen of icy Xgl death :-) It happened almost every time, but once it actually let me log in and mess around for a few minutes before cutting me off.


same here, random lockups, even before loading windowdecorator and compiz.
can anyone help.


heres some info:



$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 XT Generic
OpenGL version string: 2.0.5642 (8.22.5)




$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2





# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "hr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. R423 5F57 [Radeon X800XT (PCIE)]"
Driver "fglrx"
BusID "PCI:5:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-65
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. R423 5F57 [Radeon X800XT (PCIE)]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

fusionfd
March 2nd, 2006, 11:56 PM
w00t!!! I finally got it. Dell 6000 with ATI X300 (128MB PCIe). Works great, not so stable (launched Gnomebaker and it locked up hard). I have a terminal (with a true transparent title bar) and a browser open now and its rocking. I just ran the compiz command without the sudo or the gconf reference as stated in an earlier post.

let me know if you have question. I'm gonna try and stablize it over the weekend and run this way full time.

wobbly windows rock. ;-)

d3x7r0
March 3rd, 2006, 12:03 AM
I just want to know why I can't have 3D accelerated graphics in my radeon 9600PRO :'(

I did everything right and I keep getting mesa... dsmeg keeps saying something about the agp module failing and still no acceleration... Tried loading different agp kernel modules, tried a couple of clean installs and still no go...

Damn my asus p4v800D-x motherboard I suppose :'(

nhwk64
March 3rd, 2006, 12:36 AM
Unfortunately my ATI equipped machine suffers from complete lockup/freezing with Xgl, so it's unusable for me there. I'm writing this from a PC with an old GeForce2 MX and Xgl/compiz is running rock solid. Pretty disappointing not to be able to run this on my main machine though, anybody know what's causing these lockups? I know others here have mentioned it as well. Hoping a fix is available, as I'm blown away by the effects, as are my friends and family... some of them really are good for usability, such as the window minimising effect and the zoom effect.

It seems like an ATI specific bug in either xgl or fglrx, so I guess we'll just have to wait for newer versions of either to come out and see if it fixes it. I haven't heard anyone mention ways to debug it, since nothing shows up in the logs it seems.

danmagicman7
March 3rd, 2006, 06:07 PM
I think it would be great if someone made a new, sticky thread when this happens.

Most ATI users are at a standstill until XGL is updated.

Melvil
March 3rd, 2006, 11:51 PM
Xgl runs great on my ATI Radeon Mobility 9600 using fglrx and the 686 kernel.

Just had a lockup a few minutes ago while an OpenGL screensaver was running, it was the first freeze in the last two days I've been using Xgl.

Entity
March 4th, 2006, 12:01 AM
...

lipido
March 4th, 2006, 01:18 PM
My experiences in several PCs (all ATI) with Drake XGL/Compiz are:

I used the same procedure to install the 3D desktop:
- Ubuntu install CD daily compiled 2006/03/01
- Install fglrx (apt-get install xorg-driver-fglrx).
- Install xgl/compiz with the procedure at the top of this thread and the one in the page 23.


1. Laptop Acer Ferrari 3000: ATI Mobility Radeon 9200. (OpenGL detected: ATI 9000 DDR Generic)
- Fglrx: OK
- Xgl/Compiz: Impossible to get it working. When compiz starts I get a whole distortion in the screen. I think that is a jam of pieces of images in the card's memory because I see different things and I can recognize some content.

2. Laptop Acer Travelmate 4100: ATI Mobility Radeon X700 128Mb.
- Fglx: OK
- Xgl/Compiz: It works some secs, but then it freezes hard.

3. Desktop PC with ATI Radeon 9550 128Mb
- Fglx: OK
- Xgl/Compiz: It works! (no freezes! eye-candy! :cool: ). However, I can observe that when I move a window with wobbly, after release it, if I leave the mouse, the wobbly effect becames slow, (0.5 fps! aprox), I have to keep moving the mouse. To solve it I have to maintain an app with movement in the screen (video, xmms, etc), (in other side of the cube it works too). :-k

4. Desktop PC with ATI Radeon 9800Pro 128Mb
- Fglx: OK.
- XGl/Compiz: The same, same, same as in point 3 (including the wobbly bug!).

5. Desktop PC with ATI Radeon X300 128Mb
- Fglx: OK.
- Xgl/compiz: The same, same, same as in point 2.


Conclusions:
- ATI 9550 or better works fine (with the wobbly strange behaviour).
- ATI X series (X300, X700) freezes after several seconds. (When it works, before the freeze, I have observed that the strange wobbly behaviour is not present).
- ATI 9200 doesnt work (fglrx yes, Xgl starts, but compiz shows a whole distorted screen).

I have read many posts and that some people got the freezes in X series.

Any Ideas?

xkcdmagic8
March 4th, 2006, 11:28 PM
Ferrari 4000 (4005 lol) works:

fglrx: works fine (i guess - didnt have to do much)

Xgl: all works, freezes hard with GDM so i boot into console and run Xgl from there with terminal and then start gnome-session - works. Everything works, i can launch firefox BUT if i click on the taskbar (application bar) watever on the bottom it just stops - all dead need to reboot.

lipido
March 5th, 2006, 12:13 PM
Your graphics card is an ATI x series, right?

My hypothesis: ATI x series = freezes hard randomly.

lawngn0mex
March 6th, 2006, 07:31 PM
Your graphics card is an ATI x series, right?

My hypothesis: ATI x series = freezes hard randomly.


My x800xl locks hard with XGL. I just dist-upgraded.. and things seem pretty smooth though.. so here's to hoping that some driver issues are fixed.. It seems to be snappier.

LJunkie
March 6th, 2006, 08:38 PM
Your graphics card is an ATI x series, right?

My hypothesis: ATI x series = freezes hard randomly.

Has anyone of the poor ones with ATI x series tried the fglrx-builtin agp driver? Maybe I am wrong but it seems to me that the module provided in universe doesn't support the ati internal driver. Is that right?
I tried to compile the driver from source but didn't succeed.

tukster
March 6th, 2006, 10:44 PM
yes well for now, X series = random lockups.
i have tried everything to no avail.

mine is x800xt with fglrx.
anyone had any success with drivers from ati?

lipido
March 6th, 2006, 10:52 PM
My x800xl locks hard with XGL. I just dist-upgraded.. and things seem pretty smooth though.. so here's to hoping that some driver issues are fixed.. It seems to be snappier.

I'm gonna try this! :-k

tukster
March 6th, 2006, 11:13 PM
dist-upgrade,
well maybe its smoother cause we have a new fglrx driver in repo.
dunno if it helps with lockups

dragoncow2
March 7th, 2006, 12:06 AM
Wow, compiz/xgl is really cool! :o)

The only problems I run into is when running the xserver-xgl (with or without compiz), random crap doesn't display correctly. That's about the best I can describe it..firefox pages sometimes blend into highly-unreadable-slanty-font-land, and other random problems like that. Not too bad though, it gets worse when compiz is run, but not by much. It isn't quite usable, but it's damn cool! (cube and all). (nvidia go5700)

lipido
March 7th, 2006, 12:11 AM
I've just performed a dist-upgrade. After 5 minutes I get a hard freeze again with xgl/compiz. (ati x700). Remember: Ati x series = freeze.

Is there anybody with an ati x series who works with xgl/compiz with no problems? I only can work with my ATI 9550 and 9800pro. :confused:

jasay
March 7th, 2006, 12:23 AM
I've just performed a dist-upgrade. After 5 minutes I get a hard freeze again with xgl/compiz. (ati x700). Remember: Ati x series = freeze.

Is there anybody with an ati x series who works with xgl/compiz with no problems? I only can work with my ATI 9550 and 9800pro. :confused:
Sorry to say that my x300 has never made it more than 30 minutes--and usually more like 10--without a hard freeze.:(

PeArL PaNdA
March 7th, 2006, 11:03 AM
Sorry to say that my x300 has never made it more than 30 minutes--and usually more like 10--without a hard freeze.:(

I have a Radeon X300SE in my Dell GX280 and it mostly crashes in GDM already, so before Compiz is loaded.

And I have a X200 in my MSI S270 laptop, where I can login, but it crashes whenever I try to run "very heavy" software like minsweeper or mahjong ;)

Also there's a bug that when I lock my X session, while running Xgl and I start using it again, I don't have to type my password again, instead it just gives me all my open programs without window decoration. Not very good security I'd say.

Viriiguy
March 7th, 2006, 06:31 PM
Ok I am a bit of a dumb dumb I suppose. But I have skimmed thru this thread several times and found no mention of this "MAin" thread that tells how to set up my xorg.conf file for an ATI 9600.

I have been afraid to install anything out of fear I will break it before I can fix it :D

Could someone kindly point me to this thread with the directions for setting up my xorg.conf file? From then I just follow the directions on the first page right?

Thank you,
Randy

mega
March 8th, 2006, 02:42 AM
X300 here, prior to today it locked up randomly 1-5 minutes into a session


now gdm does not even start

julipanno
March 8th, 2006, 03:23 AM
Thanks for the Howto. I've got it running wonderfully on my Inspiron 9200 laptop with ATI Radeon Mobility 9800 (detected as 9700). I run dapper and use the proprietary fglrx-drivers from the repository.

My only problem is that the socalled 'super'-key doesn't work at all.

A possibly related thing is that gThumb crashes when I choose fullscreen-mode, but I'm not sure if compiz has anthing to do with this.


Stian

jasay
March 8th, 2006, 05:39 AM
Ok I am a bit of a dumb dumb I suppose. But I have skimmed thru this thread several times and found no mention of this "MAin" thread that tells how to set up my xorg.conf file for an ATI 9600.

I have been afraid to install anything out of fear I will break it before I can fix it :D

Could someone kindly point me to this thread with the directions for setting up my xorg.conf file? From then I just follow the directions on the first page right?

Thank you,
RandyThis one? http://www.ubuntuforums.org/showthread.php?t=132406

WhO_KnOwS
March 9th, 2006, 12:16 AM
Got a problem... I have everything installed (no errors), did everything according to the howto and I get no eye candy :cry:
I have 3d acceleration, and glxinfo reports that xgl is running. But for some reason compiz is not running it seems. And if I try to run it manually it doesn't start.
Also, I have no compiz entry in gconf.
I tried the packages from both apt-get and the ones from battlehorse. I even installed all the mesa debs...
What am I missing? (tell me if you need more info - I'll provide it gladly)

Jengu
March 9th, 2006, 01:26 AM
Well, I would really like to try with the new drivers, but I can't get gdm to load Xgl. No matter what settings I put in /etc/gdm/gdm.conf and /etc/gdm/gdm.conf-custom, ps aux | grep X always shows that /usr/bin/X is running instead of /usr/bin/Xgl.

Has anyone managed to get the new 8.23.7 ati drivers working with Xgl/compiz?

setenza
March 9th, 2006, 02:50 AM
Hi,

I have fully upgraded the new ATI drivers to version 2.23.7


dmartone@setenza-lnx:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 2.0.5695 (8.23.7)


dmartone@setenza-lnx:~$ glxgears -printfps
16568 frames in 5.0 seconds = 3313.412 FPS
21449 frames in 5.0 seconds = 4287.488 FPS
21204 frames in 5.0 seconds = 4240.779 FPS
21335 frames in 5.0 seconds = 4241.441 FPS


XGL/Compiz work fine a little more speed and rendering is a bit faster.

Sorry for my english i'm french

apoclypse
March 9th, 2006, 06:06 AM
It worked first try for me, however I seem to have trouble with gnome it taked forever to start and when it does it doesn't load the panel.

The little that I did get to use was incredible, I almost fell out of my chair. I didn't expect it to be this polished. Its still rough but its very usable.

getaceres
March 9th, 2006, 08:46 AM
It doesn't work for me, no matter what I try:

First I tried with the method posted in the first page, but there's no apps/compiz/general/all screens/options section in my gconf so it didn't work (XGL was working, I think but I cannot init compiz). Then, I tried with the tutorial at http://www.rage3d.com/board/showthread.php?t=33847510 but again, it didn't work. Everytime I start compiz I loose the window decoration (by the way, I'm vanyar in this post).
Then I tried with the method of xsession in page 23 of this post but when I run this session I get a black screen and nothing more, and I have to reset.
Is it really so difficult to make it work? I'm the only one who finds it impossible to make it work?

setenza
March 9th, 2006, 11:04 AM
It doesn't work for me, no matter what I try:

First I tried with the method posted in the first page, but there's no apps/compiz/general/all screens/options section in my gconf so it didn't work (XGL was working, I think but I cannot init compiz). Then, I tried with the tutorial at http://www.rage3d.com/board/showthread.php?t=33847510 but again, it didn't work. Everytime I start compiz I loose the window decoration (by the way, I'm vanyar in this post).
Then I tried with the method of xsession in page 23 of this post but when I run this session I get a black screen and nothing more, and I have to reset.
Is it really so difficult to make it work? I'm the only one who finds it impossible to make it work?

Hi,

Test with this method, to add compiz in gconf. Don't start an XGL sessions, start a xorg sessions.

Method point 4 start xgl rootless :

http://gentoo-wiki.com/HOWTO_XGL#Running_Xgl

After that you have the compiz in gconf.

WhO_KnOwS
March 9th, 2006, 11:27 AM
Hi,

Test with this method, to add compiz in gconf. Don't start an XGL sessions, start a xorg sessions.

Method point 4 start xgl rootless :

http://gentoo-wiki.com/HOWTO_XGL#Running_Xgl

After that you have the compiz in gconf.

Using this method I get:


root@Damage-Inc:/home/peter# Xgl :1 -ac -accel glx:pbuffer -accel xv:pbuffer
X Error of failed request: BadLength (poly request too large or internal Xlib l ength error)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 1 (X_GLXRender)
Serial number of failed request: 94
Current serial number in output stream: 95
root@Damage-Inc:/home/peter# LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ DISPL AY=:1 compiz gconf
root@Damage-Inc:/home/peter# DISPLAY=:1 gnome-window-decorator
compiz.real: Couldn't open display :1

(gnome-window-decorator:5309): Gtk-WARNING **: cannot open display:

setenza
March 9th, 2006, 12:02 PM
That's a problem with your drivers try a "fglrxinfo" what the result ??

Fudgie
March 9th, 2006, 12:08 PM
I've tried running Xgl with the new drivers on my X300 (Not from gdm, had to start Xorg manually and do everything from an xterm), and I was totally disappointed to get a hard-lockup within 2 minutes of use. The fglrx driver makes it extremely cumbersome to try different options as well, as after having started X once the machine will freeze on the next attempt.

Bleh, shame on you ATI.

Fudgie

WhO_KnOwS
March 9th, 2006, 12:18 PM
That's a problem with your drivers try a "fglrxinfo" what the result ??

That's the funny part. I have direct rendering... Proof:


root@Damage-Inc:/home/peter# fglrxinfo -display :1 ## had to specify :1 cause :0 is empty ;)
display: :1.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 XT Platinum Edition Generic
OpenGL version string: 2.0.5642 (8.22.5)

setenza
March 9th, 2006, 02:33 PM
Try with proprietary drivers from ATI 8.23.7 ....

WhO_KnOwS
March 9th, 2006, 03:32 PM
No juice... :cry:

Jengu
March 9th, 2006, 06:53 PM
I tried loading Xgl/Compiz with the session trick instead of editing gdm.conf, but only on display 1. That manages to get me into gnome, but compiz still refuses to take control of the windows. 8.23.7 drivers give me no luck with Xgl so far :/

skit
March 9th, 2006, 10:03 PM
Hello,

Sorry if my english is a little ... bad

I have a ATI Radeon 9200 and i have done exactly what the tutorial said, then because i was getting it soo slow and did not have flgrxinfo information i changed everything to display=0 and now everything is working just fine ... however i have problem ... I can find the /apps/compiz/... in gconfg-editor so I have everything working fine, but just whitout the effects zoom and everything on ...

Can you please please help me ?

[]'s

getaceres
March 9th, 2006, 10:48 PM
I made a fresh install of Ubuntu Dapper Flight 4 and followed the instructions on the page 23. Now I'm running XGL.

Ocxic
March 9th, 2006, 10:49 PM
I went throught the guide, and everyhting seemed to go well but when i try to run compiz i get this


admin@ubuntu-Bennett:~$ compiz
admin@ubuntu-Bennett:~$ compiz.real: No composite extension

whats up with that??? is there a way to fix it?
how can i tell if xgl is running?

setenza
March 9th, 2006, 10:53 PM
I went throught the guide, and everyhting seemed to go well but when i try to run compiz i get this


admin@ubuntu-Bennett:~$ compiz
admin@ubuntu-Bennett:~$ compiz.real: No composite extension

whats up with that??? is there a way to fix it?
how can i tell if xgl is running?


Xgl is not running if you have this error

lipido
March 9th, 2006, 11:58 PM
Hello,

Sorry if my english is a little ... bad

I have a ATI Radeon 9200 and i have done exactly what the tutorial said, then because i was getting it soo slow and did not have flgrxinfo information i changed everything to display=0 and now everything is working just fine ... however i have problem ... I can find the /apps/compiz/... in gconfg-editor so I have everything working fine, but just whitout the effects zoom and everything on ...

Can you please please help me ?

[]'s

I can't get Xgl work with display 0, it shows the mouse clock forever. When I read your post I hope I can definitively get my 9200 working, but I only get a whole distorted screen when I start compiz (with display 1, and with display 0, Xgl hangs with the mouse clock).:???:

skit
March 10th, 2006, 12:32 AM
I have just formatted my machine, just wanna know after i run the tutorial i get stuck because i cannot find (probably because it really doesn't exists ... in gconf-editor ... apps > compiz ... How can this happen ? It really isn't there ...

=/

[]'s

setenza
March 10th, 2006, 02:39 AM
I have just formatted my machine, just wanna know after i run the tutorial i get stuck because i cannot find (probably because it really doesn't exists ... in gconf-editor ... apps > compiz ... How can this happen ? It really isn't there ...

=/

[]'s

After you have successfully started XGL, execute in a terminal :

compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher

And they add compiz in gconf

JLTB
March 10th, 2006, 06:20 AM
Well I just got this stuff installed. No major problems. However, I wasn't expecting how crazy this compiz stuff really is!! I'm am completely speachless. I thought my ubuntu box was the ugly one in the corner (the nice mac mini I have at work is the 'real' GUI computer). I really don't know what to say ... have I been under a rock for a few months or something??

Good job suse, novell (and of course ubuntu packagers!)!!! I'll be able to convert many more friends to ubuntu with just a few minutes of seeing XGL and Compiz! :-D

skit
March 10th, 2006, 10:33 AM
Now i have the ati drivers problem ... they won't load correctly and fglrxinfo gives me MESA Driver ...

=/

Ocxic
March 10th, 2006, 03:18 PM
read back a few page or do a search i read in this thread it should say that if it's working, i think... it's in here somewhere

typoEDR
March 10th, 2006, 06:28 PM
I have a question regarding this wacky little software: Some functions (resize, opacity) do not appear to function. I've followed the guide quite closely (actually several guides, since I screwed up twice) and put the plugins in a certain order, but some of the functions aren't working at all.

Also, what is the 'super-key' or whatever it's called? I assumed it was the Windows key, but it isn't doing anything.

Thanks.

wousser
March 10th, 2006, 07:41 PM
does anybody know how to get it work again with the new 8.23.7 drivers? xgl works but compiz doesnt start.
ahh, and in X fglrxinfo gives correct info about ati, but in Xgl it gives the mesa stuff..

Melvil
March 11th, 2006, 02:22 AM
Now i have the ati drivers problem ... they won't load correctly and fglrxinfo gives me MESA Driver ...

=/

fglrx gives me NO driver.... "Error: unable to open display :0"

is there a way to revert to the old version?

apoclypse
March 11th, 2006, 05:18 AM
everything works great so far. I'm using the packages provided in one of the threads here it on the first page called new compiz or soemthing. So far everything works great. My only question is, is it normal for xgl to take 5 minutes to start? I also can't seem to logoff, the gnome panel just seems to freeze so I've been killing the x server to drop out. Is there a workaround or is this the way it works for the moment?

QUASAR_FREAK
March 11th, 2006, 05:33 AM
everything works great so far. I'm using the packages provided in one of the threads here it on the first page called new compiz or soemthing. So far everything works great. My only question is, is it normal for xgl to take 5 minutes to start? I also can't seem to logoff, the gnome panel just seems to freeze so I've been killing the x server to drop out. Is there a workaround or is this the way it works for the moment?

The 5 min delay never happen to me, the freeze on logoff yes but stop with the last update.

Aschi
March 11th, 2006, 02:21 PM
Does this whole XGL and Compiz stuff work on a mobility x300 128mb as well (smoothly)?

Jengu
March 11th, 2006, 08:10 PM
Does this whole XGL and Compiz stuff work on a mobility x300 128mb as well (smoothly)?

Assuminng the fglrx drivers support your card (I think they do but check) it should be more than capable of handling Xgl and Compiz.

eMuNiX
March 12th, 2006, 01:32 AM
Can't quite seem to get this running but I do have the latest drivers and 3D working:-

emunix@linux:~$ Xgl :1 -ac -accel glx:pbuffer -accel xv:pbuffer
Couldn't open RGB_DB '/usr/share/X11/rgb'
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/linux:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
Could not init font path element /usr/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/lib/X11/fonts/CID/, removing from list!
FreeFontPath: FPE "/usr/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.


emunix@linux:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.5695 (8.23.7)


My xorg.conf only shows 1 display device, it used to show 2:-



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "LS902U"
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Driver "fglrx"
Option "UseFBDev" "true"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. RV350 AP [Radeon 9600]"
Monitor "LS902U"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

apoclypse
March 12th, 2006, 02:52 AM
It seems when I updated the packahes the dalt went away. i can now restart my pc from gnome, but when I logout it still freezes and when I log back im after killing the xserver I get a panel alreay running type error. However these little things are to be expected, I'm just so surprised at how stable it is. It works really well. Now if inly they can fix video playback specifically the wmv files which have a weird doubling uninterlaced look to them, and my tv card has to be in capture mode as overlay doesn't work. Is there a fix for this or is this to be expected?

Fudgie
March 12th, 2006, 11:11 AM
I have a question regarding this wacky little software: Some functions (resize, opacity) do not appear to function. I've followed the guide quite closely (actually several guides, since I screwed up twice) and put the plugins in a certain order, but some of the functions aren't working at all.


Make sure the plugins are active in gconf as well, not just on the command line. If you add gconf on the command line, compiz will ignore all other plugins specified there, and ONLY read from gconf.


Also, what is the 'super-key' or whatever it's called? I assumed it was the Windows key, but it isn't doing anything.


It is the windows key, make sure you have a 105 key keyboard set up, not 101/102 keys.

wolfchri
March 12th, 2006, 06:28 PM
Hello folks,

my dumb question, not meant to provocate:

Did anybody ever get xgl up and running by just using the official XGLHowTo (https://wiki.ubuntu.com/XglHowto)? If not, why is there such a crap in the Wiki that makes you think xgl is a thing of a little apt-get install ???

I would very much like to simply delete this Howto (but do not dare...) because it is obviously far away from being a help - according to all the xgl threads here. I am still not even close to get xgl working, after following the HowTo step by step.

Or is there some magic between the lines in the HowTo article that I have not read?

Otherwise I would suggest to deactivate that page until xgl has in fact become a matter of an apt-get install xyz.

recover82
March 12th, 2006, 07:19 PM
Quick question about the "Shift+Backspace" bug.

I know that when you login you can issue
"xmodmap /usr/share/xmodmap/xmodmap.us" (us being my region) via terminal and fix the bug with "Shift+Backspace"..the fix works great actually..but I shouldn't have to enter it every time I log in.

Can I add that command to my "Sessions" along side gnome-window-decorator and compiz replace gconf commands? I would just try.. but I'm not at that box right now. I'm just trying to get a list of things to do when I do have access.

Thanks for any input.

::recover82::

Fudgie
March 12th, 2006, 09:05 PM
Did anybody ever get xgl up and running by just using the official XGLHowTo (https://wiki.ubuntu.com/XglHowto)? If not, why is there such a crap in the Wiki that makes you think xgl is a thing of a little apt-get install ???


If you have an nvidia card, it's pretty much just apt-get install. Otherwise, you need to fiddle quite a bit for limited results.

Fudgie
March 12th, 2006, 09:09 PM
Does this whole XGL and Compiz stuff work on a mobility x300 128mb as well (smoothly)?

Works on an ATI X300 SE for 1-10 minutes depending on luck and how much you try to do other than wobble windows. :-) ATI needs to fix their drivers, or someone needs to sit down and write around the hard-freeze that occurs on most highend ATI cards.

wolfchri
March 12th, 2006, 09:14 PM
Fudgie,

I have an NVidia 6600GT.... :-?

Still, the HowTo does not work, the only thing I get is that my Gnome task bar is vanishing. Sorry, but that is far away from being useful, at least for me.

Here is my hardware:

http://librarian.launchpad.net/1693217/lspci.txt

and it is not working although I am trying since Dapper Flight 4, and I am not considering myself a complete noob, coming from Gentoo :-)

Fudgie
March 12th, 2006, 09:42 PM
Ah. That howto. Sorry, I've never gotten that way of launching Xgl to work, I've always just replaced X with Xgl in /etc/gdm/gdm.conf in the [server-Standard] section, and disabled DRI, GLCore & Composite in xorg.conf. Never had any problems on any of my machines running the nvidia driver as long as I had working DRI up front.

(http://mr.fudgie.org/index.php/2006/02/16/tiny-ubuntu-dapper-nvidia-xgl-howto/ is how I always do it when setting it up for friends)

recover82
March 12th, 2006, 10:05 PM
I know that when you login you can issue
"xmodmap /usr/share/xmodmap/xmodmap.us" (us being my region) via terminal and fix the bug with "Shift+Backspace"..the fix works great actually..but I shouldn't have to enter it every time I log in.

Can I add that command to my "Sessions" along side gnome-window-decorator and compiz replace gconf commands? I would just try.. but I'm not at that box right now. I'm just trying to get a list of things to do when I do have access.


I finally got to my box and for anyone else curious about this it does work.

loftx
March 12th, 2006, 11:17 PM
Hi all, I've got Xgl/Compiz working but for some reason, all windows don't seem to remember their position and start in the top left corner - the only one which doesn't seems to be beep-media-player.

Is anyone experiancing this or have any solutions? I had a look through most of this thread but couldn't see anything.

Spec:
AMD 2200 Athalon
Radeon 9600 with fglrx driver from repos
Dapper flight 5
Xgl compiz and supporting packages from repos
Transparancy plugin for compiz.

Thanks,

Tom

Melvil
March 12th, 2006, 11:31 PM
Is anyone experiancing this or have any solutions? I had a look through most of this thread but couldn't see anything.

Sort of...this problem (http://ubuntuforums.org/showpost.php?p=817724&postcount=173) is bugging me

loftx
March 12th, 2006, 11:37 PM
Is there some (official) site where I can post bugs related to Xgl/compiz?

Right now all applications start at screen location (0, -30), so the titlebar and menubar are "above" the screen and I have to move the window down first to see the contents.

Originally that did happen to me, I think it was the first time I got compiz working, but somehow it moved it down to starting at (0,0) I think on the second time I tried running it. It also put a window decorations (with title) around my gnome panel which moved it down so I couldn't actually see the main panel, though this fixed itself too.

I assumed this was something i'd done wrong rather than a bug ;)

JLTB
March 13th, 2006, 05:47 AM
My windows also often started with their taskbars under the top gnome task bar. After the first few windows had opened it quit happening.

Keep in mind that <Alt> keyboard shortcut will let you grab windows anywhere to move them so this isn't too big of a deal.

So far I've gotten XGL + Compiz going on 3 computers: AMD 64 3500 w/ ATI 9600 XT, AMD 64 3500 w/ Nvidia 6600 GT, and my pokey old Duron 950 w/ GForce 4 MX (which owns by the way.. . the computer is literally faster and more responsive after installing XGL, makes sense when you think about it).

Apparently a lot of people are having hardware issues with this. So far everything has installed without a hitch for me (no offence intended anyone).

My advice, get DRI going on your card very smoothy first before trying this howto (obvious yes, but it burns me all the time too).

mbozo
March 13th, 2006, 09:22 AM
Hi,

I've tried to start Xgl with the "gdm-howto".
Xgl fires up, but I'm not able to run compiz - it only replies with:
"compiz.real: Support for non power of two textures missing"

But if I revert to the original gdm configuration, and then run Xgl with:
"sudo /usr/bin/Xgl :1 -ac -accel glx:pbuffer -accel xv:fbo &"

Then I'm able to run compiz with:
"DISPLAY=:1 compiz -display :1 --replace gconf"

See attached screenshot.

Any suggestions?

loftx
March 13th, 2006, 07:30 PM
Something else I've just noticed - gconf won't let me add "menu" to the active_plugins string list - after I can add it to the values list in the dialog box - but when I press ok it doesn't add it to the string. Anyone know why this is and what problems it might cause?

eeclark
March 13th, 2006, 10:04 PM
Something else I've just noticed - gconf won't let me add "menu" to the active_plugins string list - after I can add it to the values list in the dialog box - but when I press ok it doesn't add it to the string. Anyone know why this is and what problems it might cause?

I have the same problem...posted it but no one ever responded. GL.

Mr Frosti
March 14th, 2006, 05:42 AM
Throwin' in my two cents on the chance Google crawls this site:

I have an ATI X300 mobile, and can confirm several issues with Xgl at this point. Even without compiz running, Xgl consistantly hard locks when Nautilus is initiated from within Xgl. Without Nautilus running, I do not experience any other stability issues when running it inside of a regular Gnome session as outlined below. The gnome-theme-manager crashes when switching themes, but this is to be expected. If I start Xgl using the HOWTO from Mattisking, my system reliably hardlocks at anywhere between 2 seconds and 2 minutes after the login screen appears. If I create a new "Xsession" file as outlined by Guyhersh, I have the same results. That HOWTO is here: http://www.ubuntuforums.org/showthread.php?t=131253&page=28

For those who have installed the compiz package, but do not have the entries in gconf-editor, I have a work around. I have exported the "apps->compiz" branch, and uploaded it. Anyone who is missing these entries, extract this package in "~/.gconf/apps/".

Also, version "0.0.5-0ubuntu4" of compiz does not appear to support the "libcube" module (at least not for me), which fails other modules in the dependency tree. The other failed modules are "zoom" and "rotate". Also, I have not had any luck in adding the opacity module outlined in the Howto below. I would recommend taking these entries out of gconf-editor under the plugins section if you are experiencing issues: http://ubuntuforums.org/showthread.php?t=132063&highlight=compiz+opacity

Now, these are the steps that I follow to start Xgl with stability. Open up a terminal and type in:


Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo & sleep 2 && DISPLAY=:1 gnome-terminal

This will initiate Xgl in fullscreen mode, with hardware acceleration on display 1 (resolves ATI driver bug). It will also open a terminal for you once it is finished loading. In this terminal, type the following:


compiz --replace gconf

This will start the compiz composite manager. Watch for any error messages on loading the modules. Once this finishes, add the window decorations by typing in:


gnome-window-decorator

==TROUBLESHOOTING==


Check to make sure that you have 3D acceleration by typing in "fglrxinfo" into a terminal. You should see "OpenGL vendor string: ATI Technologies Inc.". If not, resolve that issue first.

The original HOWTO by Mattisking asks the user to edit their /etc/gdm/gdm.conf and /etc/gdm/gdm.conf-custom files. With the new method, these alterations should be taken out.

If Xgl is hard locking your system before you can start compiz, follow the logs for the system by entering in the command:


sudo tail -f /var/log/syslog

If you are running Xgl and/or compiz, but are not seeing the fancy results everyone is describing, then check to make sure you have the following packages installed:

compiz (0.0.5-0ubuntu4)
compiz-gnome (0.0.5-0ubuntu4)
xserver-xgl (7.0.0-0ubuntu3)


Good luck all, and I hope this helps shed some light!

Update: This information has migrated to a wiki here: http://wiki.ubuntu.com/xglati

wylie348
March 14th, 2006, 09:21 PM
Oddly enough I get a proper login screen, but a black screen (with white mouse_pointer) when I get in to gnome. Cannot see anything, but things appear to be running?!
Only way back in is to disable changes in cust-conf.
Anyone else having this trouble?
(Using ATI9200 radeon, with working flgrx)

nhwk64
March 15th, 2006, 12:11 AM
Throwin' in my two cents on the chance Google crawls this site:

I have an ATI X300 mobile, and can confirm several issues with Xgl at this point. Even without compiz running, Xgl consistantly hard locks when Nautilus is initiated from within Xgl. Without Nautilus running, I do not experience any other stability issues when running it inside of a regular Gnome session as outlined below. The gnome-theme-manager crashes when switching themes, but this is to be expected. If I start Xgl using the HOWTO from Mattisking, my system reliably hardlocks at anywhere between 2 seconds and 2 minutes after the login screen appears. If I create a new "Xsession" file as outlined by Guyhersh, I have the same results. That HOWTO is here: http://www.ubuntuforums.org/showthread.php?t=131253&page=28


I just tried your suggestion, but it locked up as I was testing the menu items in firefox after about 5-10 seconds :( (X800 card)

Mr Frosti
March 15th, 2006, 02:17 AM
This forum is getting difficult to read, so I have moved the information to a wiki page located here:

http://wiki.ubuntu.com/xglati

Feel free to append to this guide - my goal is to provide an easier location to troubleshoot issues

janko
March 15th, 2006, 09:01 AM
Awesome, I followed the first-post how to, and now I have a Linux box that makes the difference!!!
So far I've tried software like "The GIMP", Gaim, Firefox, and everything seems to work perfectly. My hardware is a Pentium M 1,6 Centrino mounting a Mobility Radeon 9700 64Mb Video Ram dedicated and 512 RAM.
My only problem right now is that annoing lagging pseudo animation that has nothing to do with Xgl. It's that slow rectangle that comes up when I start an application clicking on an icon on the top panel or bottom panel. Is there a way to even eliminate that bad animation?

Don_DiZzLe
March 15th, 2006, 03:15 PM
Ensure that the newly installed compiz package has placed the correct entries in the gconf-editor. To check, type in a terminal "gconf-editor". A window will pop-up with a tree view in the left pane. Double-click "apps". If you see "compiz" under "apps", then the needed entries appear to exist. If you do not see a "compiz" folder, then please download and extract the package below into the "~/.gconf" directory.

* [WWW] http://ubuntuforums.org/attachment.php?attachmentid=7039&d=1142311054

Where can I find this "~/.gconf" directory?

loftx
March 15th, 2006, 03:32 PM
Where can I find this "~/.gconf" directory?
It's a hidden directory in your home directory. If you're using nautilus go to your home directory and press CTRL+H (or View-> Hidden files from the menu) and you'll be able to see it

mcduck
March 15th, 2006, 03:53 PM
My only problem right now is that annoing lagging pseudo animation that has nothing to do with Xgl. It's that slow rectangle that comes up when I start an application clicking on an icon on the top panel or bottom panel. Is there a way to even eliminate that bad animation?
Open Configuration Editor (run gconf-editor if you haven't got it in menu), browse to apps/panel/global and unmark 'enable_animations'. That should do it :)

janko
March 15th, 2006, 06:51 PM
Thanks a lot mcduck, does anyone know if there's any possibility to make work again applications that use opengl while i'm using a desktop running XGL? For example i'd like to play again with America's army... or maybe is there a way to tell the program I'm executing that has to run on screen 1 or something like that?

faethon
March 15th, 2006, 11:40 PM
Just registered after I decided to share my story on installing the Xgl/compiz eyecandy:

I did a fresh install of ubuntu dapper drake, using flight 5 CD. After following the ATI howto in the start post (I have a 9700 Pro) I had some small problems:

At first, there were no compiz entries in the gconf editor. I decided to reboot. After that the entries were present (since compiz was started at the reboot) so I could continue with the setup of the entries in gconf. After a subsequent reboot (not needed but I did it anyways) I did not see any window decorations at all. Turned out that in my session, the gnome-window-decoration was not at the top of the list. Adding this to the top of the session startup programs solved the problem.

Rebooted the machine and lo and behold! All eye candy working! I noticed some slugishness with the wobbly effect though and also the 'startup' animations seemed to be extremely slow. I switched the enable-animation off using gconf-editor (apps->panel->global) and the slow animation was gone and also the wobbly effect was much smoother!!

After that I decided to install the opacity with the nice mousescroll keybinding. I used the information in this thread: http://ubuntuforums.org/showthread.php?t=132063&highlight=opacity+compiz and had the opacity running in no time and bound to my mousewheel

I needed to change my keyboard layout to 105 keys setup to get the zooming function to work (using 'superkey - right_mouse' combo).

I did not have any lockups (so far).

Slugishness of wobbly is solved by unticking detect_refreshrate and setting refreshrate to 60 in gconf-editor apps->compiz->general->screen0->options

Fudgie
March 16th, 2006, 09:26 AM
Something else I've just noticed - gconf won't let me add "menu" to the active_plugins string list - after I can add it to the values list in the dialog box - but when I press ok it doesn't add it to the string. Anyone know why this is and what problems it might cause?

There is no menu plugin, so maybe that's the reason? ;)

loftx
March 16th, 2006, 11:02 AM
Yeah, I did eventually find this out :) Though it's still in the walkthrough at the top of the thread.

kotzkroete
March 16th, 2006, 03:05 PM
It worked fine for me before, but since I reinstalled dapper it doesn't work. When I start

compiz decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher --replace gconf
ubuntu says:

compiz.real: Couldn't load plugin 'libmenu.so'
compiz.real: Couldn't load plugin 'libgconf.so'

With all effects, exept tilebars. And when I try to start

gnome-window-decorator
I get this:

bash: gnome-window-decorator: command not found

Fudgie
March 16th, 2006, 04:06 PM
gnome-window-decorator is in the compiz-gnome package. Make sure you install that one as well.

kotzkroete
March 16th, 2006, 04:57 PM
thx...it works...But Why do I get

compiz.real: Couldn't load plugin 'libmenu.so' ?

Fudgie
March 16th, 2006, 05:03 PM
There is no menu plugin, so remove it from the active_plugins setting in gconf (apps/compiz/allscreens/options or something like that)

kotzkroete
March 16th, 2006, 05:51 PM
But what is the menu plugin? What does it?
BTW: Is there a tutorial how to give the top and bottom of the cube a texture? Would be cool.

badcow
March 16th, 2006, 07:18 PM
Yeah ~~~~ I make it!\\:D/

My card is Mobility Radeon 9200 (32M) on a Compaq x1000 laptop, using "radeon" driver.

But there is a problem that Xgl cannot run under 1280x800 which is best fit for my LCD monitor, it will fail with "no screens found". Someone said this problem can be solved by using driconf to enable large texture support. But I cannot make it even I use driconf, maybe my setting is wrong, I hope someone can help me or post the right drirc file.

http://gentoo-wiki.com/HOWTO_XGL#no_screens_found

cbudden
March 16th, 2006, 07:48 PM
Hello. I followed the ATI howto on the wiki and get this output:



cbudden@ubuntu:~$ compiz --replace gconf
cbudden@ubuntu:~$ compiz.real: GLX_EXT_texture_from_pixmap is missing
compiz.real: Failed to manage screen: 0
compiz.real: No managable screens found on display :1.0


Fglrxinfo reports ATI (latest driver from ati.com)

I have tried the XGL live CD and that works fine.
Any idea on how i could fix this problem?

Thanks

badcow
March 16th, 2006, 08:08 PM
Hello. I followed the ATI howto on the wiki and get this output:

[code]
cbudden@ubuntu:~$ compiz --replace gconf
cbudden@ubuntu:~$ compiz.real: GLX_EXT_texture_from_pixmap is missing
compiz.real: Failed to manage screen: 0
compiz.real: No managable screens found on display :1.0
[code]

Fglrxinfo reports ATI (latest driver from ati.com)

I have tried the XGL live CD and that works fine.
Any idea on how i could fix this problem?

Thanks

Are you sure the Xgl is already running ? Just run " ps ax|grep Xgl " to confirm it.

When I first met this problem after I follow the first post method, it is because I run X server by "startx", not by gdm, so the Xgl command line in gdm.conf-custom will not start at all.

cbudden
March 16th, 2006, 08:25 PM
This what we are looking for?


cbudden@ubuntu:$ ps ax|grep Xgl
6616 pts/0 SL 0:00 Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo
6650 pts/1 S+ 0:00 grep Xgl

Fudgie
March 16th, 2006, 08:44 PM
Hello. I followed the ATI howto on the wiki and get this output:



cbudden@ubuntu:~$ compiz --replace gconf
cbudden@ubuntu:~$ compiz.real: GLX_EXT_texture_from_pixmap is missing
compiz.real: Failed to manage screen: 0
compiz.real: No managable screens found on display :1.0


Fglrxinfo reports ATI (latest driver from ati.com)

I have tried the XGL live CD and that works fine.
Any idea on how i could fix this problem?

Thanks

ATI diverts the Mesa libGL to an ATI one, so you need to do a
LD_PRELOAD=/path/to/old/mesa/libGL.so compiz --replace gconf

I don't remember where it ends up of the top of my head, but a locate libGL.so and looking for the one that's ~400kb instead of ~600kb should do the trick.

badcow
March 16th, 2006, 09:12 PM
This what we are looking for?


cbudden@ubuntu:$ ps ax|grep Xgl
6616 pts/0 SL 0:00 Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo
6650 pts/1 S+ 0:00 grep Xgl


Sorry for my mistake, if Xgl isn't running, compiz wil complain of "composite extension", not "GLX_EXT_texture_from_pixmap is missing"

And this HOWTO file is very useful for troubleshooting :
http://gentoo-wiki.com/HOWTO_XGL#GLX_EXT_texture_from_pixmap_is_missing

cbudden
March 16th, 2006, 10:00 PM
ATI diverts the Mesa libGL to an ATI one, so you need to do a
LD_PRELOAD=/path/to/old/mesa/libGL.so compiz --replace gconf

I don't remember where it ends up of the top of my head, but a locate libGL.so and looking for the one that's ~400kb instead of ~600kb should do the trick.




Thanks, it was in /usr/share/fglrx/diversions

cbudden
March 16th, 2006, 10:21 PM
Has anyone got a problem using gdesklets and XGL?

edit

Ok, after a reboot, when I do ld_preload..... compiz --replace gconf it just removes the window decorations and doesn't start compiz. I try typing in gnome-window-decorations but nothing happens to the windows. What am I missing?

Edit

My fault, I was doing --replace gconf and then following on with plugins. Now with just compiz plugins... it works. Thanks guys

krea
March 17th, 2006, 02:30 AM
I'm stuck at step 7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order

I dont have the compiz option under apps/
and I have it installed I believe:

$sudo apt-get install xserver-xgl compiz libgl1-mesa libgl1-mesa-dri libglitz1 libglitz-glx1
Reading package lists... Done
Building dependency tree... Done
xserver-xgl is already the newest version.
compiz is already the newest version.
libgl1-mesa is already the newest version.
libgl1-mesa-dri is already the newest version.
libglitz1 is already the newest version.
libglitz-glx1 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

any help? thx

badcow
March 17th, 2006, 04:31 AM
I'm stuck at step 7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order

I dont have the compiz option under apps/
and I have it installed I believe:

any help? thx

Have a try on the newest compiz:
http://www.ubuntuforums.org/showthread.php?t=139265

cbudden
March 17th, 2006, 10:20 AM
I also found that if I am in XGL, and run the following, I get the compiz section in gconf:


compiz --replace decoration wobbly fade minimize cube rotate zoom scale move resize place switcher

rahab
March 17th, 2006, 11:41 AM
Hi there,

Now my problem is not related to getting Xgl/compiz stuff to work, but
to get rid of it :)
I played around with it a few days and now all those little annoying things which do not work properly yet make me wanna go back to good old plane xorg/metacity.
And that┤s the point!
I commented out the changes in gdm.conf/gdm.conf-custom and removed compiz and gnome-window-decoration from gnome-session autostart.
But now I┤m left without any windowmanger. Metacity is not running when i log on, so i got no window-decoration, no workplace-switcher, no keyboard-shortcuts, etc.
Of course i can start metacity manually or add it to gnome-session for autostarting, but i don┤t know if that is the right way to do it.
I cannot remember metacity showing up in gnome-session autostart before switching to xgl/compiz.
Anyone got a clue here ???

And by the way,
does anyone know how to get the new composition abilities of the latest 2.14 metacity to work? on the gnome.org website it says, that metacity know can manage opacity, fading, etc itself. But how to activate?

RaptorRaider
March 17th, 2006, 07:27 PM
I'm stuck at step 7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order

I dont have the compiz option under apps/
and I have it installed I believe:

$sudo apt-get install xserver-xgl compiz libgl1-mesa libgl1-mesa-dri libglitz1 libglitz-glx1
Reading package lists... Done
Building dependency tree... Done
xserver-xgl is already the newest version.
compiz is already the newest version.
libgl1-mesa is already the newest version.
libgl1-mesa-dri is already the newest version.
libglitz1 is already the newest version.
libglitz-glx1 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

any help? thx
Same problem here.
Neither the oldest ("battlehorse v1") nor the newest compiz package seem to make a difference; doesn't the problem lie at gconf-editor?

Running it manually doesn't work either (since it's not in "gconf"?):

jonathan@doe:~$ gnome-window-decorator & compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
[1] 8083
[2] 8084
jonathan@doe:~$ gnome-window-decorator, Failed to load shadow images
compiz.real: No composite extension

badcow
March 17th, 2006, 08:02 PM
Running it manually doesn't work either (since it's not in "gconf"?):

jonathan@doe:~$ gnome-window-decorator & compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
[1] 8083
[2] 8084
jonathan@doe:~$ gnome-window-decorator, Failed to load shadow images
compiz.real: No composite extension

It seems that Xgl has not run yet. Did you run "startx" or "gdm" to start X server ?

RaptorRaider
March 17th, 2006, 08:59 PM
For some reason it is working now.

Lots of stuff seems broken though.
GDM is acting strange. Firefox is acting strange. Evolution suffers from the problem described below.

Many, many applications (those from the "System" menu + Evolution?) have a titleless title bar which cannot be moved (so the window can't be moved, though the bar is transparant). Neither do these apps appear in the bottom bar (which lists active apps). This bottom bar is also acting strange with apps which do appear.

Also Opacity isn't working. Edit: Nevermind, it is working; shortcuts are different than listed.

Anyone else having similar problems?

Overall though, this stuff is quite amazing.

vendetta red
March 18th, 2006, 03:41 AM
Running it manually doesn't work either (since it's not in "gconf"?):

jonathan@doe:~$ gnome-window-decorator & compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
[1] 8083
[2] 8084
jonathan@doe:~$ gnome-window-decorator, Failed to load shadow images
compiz.real: No composite extension

I have XGL/Compiz working fine on my PC with an Nvidia card, but I am trying to help a friend with an ATI 9800 Pro get it working and after following the guide and tinkering a bit, it is still giving this error everytime. Although for him, compiz is showing up in gconf.

Is there a way to make sure XGL is running for him? Or are there any other ideas as to why this is happening?

badcow
March 18th, 2006, 04:57 AM
I have XGL/Compiz working fine on my PC with an Nvidia card, but I am trying to help a friend with an ATI 9800 Pro get it working and after following the guide and tinkering a bit, it is still giving this error everytime. Although for him, compiz is showing up in gconf.

Is there a way to make sure XGL is running for him? Or are there any other ideas as to why this is happening?

You can try "ps ax | grep Xgl " in a terminal to see whether Xgl is running or not. Another way, while no X server is running, you could run just " /usr/bin/Xgl :1 " in a console to see whether the Xgl can run up.

unf
March 18th, 2006, 05:46 PM
I have problem with my mouse its too fast. Videos are not working I tried xv xv:fbo xv:pbuffer?

ICEM4N
March 18th, 2006, 08:42 PM
Hi, i get the
"compiz.real : Couldn't find the display" error ...
And it do nothing
i try all i imagine about it... i don't know what is wrong

ATI Mobility Radeon 9200 (over Compaq PresarioR3245EA)
fglrx driver installed (and working fine)

I put the "1" in gdm.conf and -custom ...

Thanks

spiritz
March 18th, 2006, 09:45 PM
I've been stuggling to get my video ouput working but with no luck so far.
Is anyone actually able to make work XGL+COMPIZ video playing with an ATI hardware?

I'm using recent compiz with XGL from dapper's repos.

Both mplayer & vlc are unable to ouput using GL or GL2, it just makes the freeze. XV ouput is fine as long as it's not full screen; Fullscreen rises cpu use to its maximum.

btw I'm using
sudo Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer&

blankSWFC
March 19th, 2006, 01:22 AM
I got Xgl working on my System. But something seems wrong. I have an ATI radeon 9550 256mb on an Athlon XP 3200+/nForce 2 Ultra 400.


It runs and most of it works well, but some of the effects are very shuddery/jerky. Particularly the windows wobble when you let go of the windows from dragging it around the desktop. It is also noticable on the menu fade-ins.

However, some effects work perfectly with not jerkyness... such as the cude effect when switching desktops and pressing F12 to display on the opened windows next to each other on screen, which also workes perfectly at full speed.



Heres what i did to get it working from a fresh install... maybe i missed something or did something wrong?

I installed the fglrx driver first, since the one from the ATI site wouldn't let me install (moaning about the Xserver being above v6.9), i used apt-get.

sudo apt-get install fglrx-driver

I replaced the "ati" bit in the xorg.conf file with fglrx, and rebooted.

I run fglrxinfo, and it returns all the correct info about ATI. no mention of Mesa.


Then i get Xgl installed...

sudo apt-get install xserver-xgl compiz compiz-gnome libgl1-mesa libgl1-mesa-dri libglitz1 libglitz-glx1

I added...

[servers]
# Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX).
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
flexible=true
to the /etc/gdm/gdm.conf-custom file.

And, changed my /etc/gdm/gdm.conf file to show...

#0=Standard
1=Standard


I rebooted the machine, and it loaded up Gnome, then from a terminal I run...

gnome-window-decorator

...and from another terminal i run...

compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher


As i put at the top of this post, it works, but *some* effects are very shuddery where as other more complex ones are perfectly smooth. I can't put my finger on it, so maybe i did something wrong during the install?

Any help would be aprechiated. As all effects work perfectly on the Kororaa Live CD.

neoflight
March 19th, 2006, 07:34 AM
6. Modify your session ("Menu System" -> "Preferences" -> "Sessions") by adding in the following two items:

gnome-window-decorator (must be on top, start first)
compiz --replace gconf




I have a problem !!!!!

I cannot edit/delete the entry in the sessions window.(its in the wrong order now)... Its not highlighted..!! please have a look at the screenshot.... last time i rebooted and got a white screen and had to do a fresh install of dapper due to the same :confused: issue......help!!!!!!!!!!!!!

charlesalexander
March 19th, 2006, 08:30 AM
I tried to follow the guide:
1) Even after installing Compiz I don't have a compiz entry in gconf-editor
2) My Compiz version is 0.0.2... seems a little low as I saw mention of 0.0.5

Output of my fglrxinfo:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X600 Generic
OpenGL version string: 2.0.5695 (8.23.7)


Have I done everything correctly?

badcow
March 19th, 2006, 06:04 PM
Hi, i get the
"compiz.real : Couldn't find the display" error ...
And it do nothing
i try all i imagine about it... i don't know what is wrong

ATI Mobility Radeon 9200 (over Compaq PresarioR3245EA)
fglrx driver installed (and working fine)

I put the "1" in gdm.conf and -custom ...

Thanks

I recommend use the open source driver ("ati" or "radeon") for ATI Mobility Radeon 9200 to run Xgl+compiz, at least for this time. I have tried to use fglrx driver for my 9200 (compaq Presario x1000), and Xgl can run slowly in fullscreen (1280x800), but compiz will mess up the whole screen, and other people also reported it as that. Now I use the open source driver, Xgl and compiz can run without error, all the effects work fine. But it is a pity that Xgl only can run with this driver in 1024x640 for my 1280x800 screen.:cry:

scpike
March 19th, 2006, 07:08 PM
It seems like x300 card = random lockups all the time...
if anyone has had any luck getting stability on this card please post what you did.

does the radeon driver work for the card? fglrx is completely unstable with XGL

Fudgie
March 19th, 2006, 09:50 PM
I have a problem !!!!!

I cannot edit/delete the entry in the sessions window.(its in the wrong order now)... Its not highlighted..!! please have a look at the screenshot.... last time i rebooted and got a white screen and had to do a fresh install of dapper due to the same :confused: issue......help!!!!!!!!!!!!!

It doesn't matter if you run compiz before gnome-window-decorator.

Fudgie
March 19th, 2006, 09:52 PM
It seems like x300 card = random lockups all the time...
if anyone has had any luck getting stability on this card please post what you did.

does the radeon driver work for the card? fglrx is completely unstable with XGL

I've read that some people have had success with the radeon driver and an X300, but it requires the latest cvs mesa, dri, drm, xorg, etc. Also loading fglrx and then unloading it before loading radeon seems to give some people better luck. I've been meaning to try this myself, but haven't found the time yet.:mad:

blankSWFC
March 20th, 2006, 01:08 AM
If its useful, installing compiz-0.0.5 fixed all my problems with my Radeon 9550 (same chip as 9600).

No lockups or instability after 24 hours of almost contsant use.

I also put on the latest ati drivers from the ati site, and installed using the command...

X_VERSION=x690 sudo ./ati-driver-installer-8.23.7-i386.run


The compiz i'm using is from a cutom DEB that someone on this forum put together, and is attached to one of the posts somewhere in the section.

I used them as the Battlehorse Debs broke the Cube plugin, but these ones worked.

If anyone wants them and can't find the debs i used then let me know.

chokes
March 20th, 2006, 04:30 AM
hum okay i hva istalled all the stuff for compiz and XGL but... im blocked here:

7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:
Code:

gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher

hum i did'nt find compiz ... and i dont know why...

musther
March 20th, 2006, 05:16 AM
Ok, why can't I delete or edit sessions in System -> Preferences -> Sessions

I can see them, but the delete and edit buttons are unavailable.

kwaanens
March 20th, 2006, 12:43 PM
hum okay i hva istalled all the stuff for compiz and XGL but... im blocked here:

7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:
Code:

gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher

hum i did'nt find compiz ... and i dont know why...

I have the exact same problem. In the first post it says that this is probably a bug, but I've tried 4 different compiz-versions and neither gets me "compiz" in gconf-edior.

- Ketil

blankSWFC
March 20th, 2006, 05:36 PM
I have the exact same problem. In the first post it says that this is probably a bug, but I've tried 4 different compiz-versions and neither gets me "compiz" in gconf-edior.

- Ketil
It seems to be a bug with the new Compiz debs.

I had the same problem, but to get the Compiz section to appear in the gconf-editor, remove your current verison of compiz, and install one of the older compiz verisions from here http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl .

I used the compiz from the 7th of Feb, but i think any will work.

Then remove the compiz you just installed with dpkg and then re-install the compiz packages that you were using before. You will find that the Compiz section will have appeared in the gconf-editor.

kwaanens
March 20th, 2006, 07:25 PM
It seems to be a bug with the new Compiz debs.

I had the same problem, but to get the Compiz section to appear in the gconf-editor, remove your current verison of compiz, and install one of the older compiz verisions from here http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl .

I used the compiz from the 7th of Feb, but i think any will work.

Then remove the compiz you just installed with dpkg and then re-install the compiz packages that you were using before. You will find that the Compiz section will have appeared in the gconf-editor.

Nope, no luck. Tried with the Feb. 7th version, and even rebooted to be sure. No such thing in gconf-editor.

- Ketil