View Full Version : [ubuntu] 9.10 - Compiz not working

November 2nd, 2009, 06:34 PM
Hey guys,

I recently upgraded to 9.10 via the update manager and in the main everything worked except Compiz on startup. It works when I run it from terminal but not from startup. I did add it as a startup item but since then compiz.real just eats away at my cpu and i have to kill compiz via shell.

Any ideas?

November 2nd, 2009, 06:44 PM
do you have simple-ccsm installed?

sudo apt-get install simple-ccsm

this usually solves my compiz problems

November 2nd, 2009, 07:09 PM

No I resolved it myself, well its a workaround not really a resolution. Under Startup Applications on the options tab I ticked to remember running applications on logoff. Not fantastic as there is still a problem with Compiz - it would not register emerald as the window manager for example.

The simple-ccsm is nice but didn't fix my issue.

November 2nd, 2009, 07:16 PM
To fix it all,you should reinstall CCSM,open it,go to windowdecoration and insert in "command":

emerald --replace

November 3rd, 2009, 03:05 PM

November 9th, 2009, 08:28 PM
Yeah, Compiz effects not beginning on login. I keep having to open it and then right click the icon, chance Compiz options for loose binding or indirect rendering. Either checking or unchecking either of those options bring back the affects, but I have having to do that every time I turn on the computer.

This was fine when I was on Jaunty, I think I remember having this issue last time but it fixed somehow.

November 19th, 2009, 11:17 PM

This suggestion fixed all my compiz problems