PDA

View Full Version : [ubuntu] No Internet After Karmic Wubi Installation



Luiz Peralba
November 2nd, 2009, 05:46 PM
Hello, Friends,

I used to have 9.04 working very well on my dv4-1120 notebook. I uninstalled it to install new 9.10 using wubi, but I have no wireless internet connection at all.

Before, I tried to update to 9.10 from my 9.04 installation using the update administration manager. It worked very well, but I couldn't turn the computer off or even restart it.

I really appreciate if you can help me.

Thanks.
Luiz

xyzt
November 2nd, 2009, 06:56 PM
Just to cheer you up :twisted:, I just did both an update, then a fresh install from CD (dual boot), and got no internet at all, not even repository access. The console ping command works, and that's all. So, back to 9.04.

navneeth
November 3rd, 2009, 10:03 AM
Just to cheer you up :twisted:, I just did both an update, then a fresh install from CD (dual boot), and got no internet at all, not even repository access. The console ping command works, and that's all. So, back to 9.04.

I'm not sure whether to be happy or sad :confused:, but I'm in the same situation. In fact, my computer is brand new. Dual-booted with XP, 9.10 was installed just about an hour ago. While I can access the Internet from XP without problems, I am unable to do so from Ubuntu. Ping, surprisingly, works!

navneeth
November 4th, 2009, 09:36 AM
Manually specified DNS server address in /etc/resolv.conf. Internet works now.

blockheadface
November 4th, 2009, 12:40 PM
Navneeth, can you give a bit more detail? I seem to be having the same problem after upgrading to 9.10 from 9.04 on my ThinkPad T42. Firefox won't load anything and my RSS reader can't load anything. Similarly, the Update Manager can't read the servers which means that I can't check for updates to fix the issue. However, I can use ping from the terminal. I can even ping Google but not open it in Firefox, which makes no sense to me.

My /etc/resolv.conf reads:

# Generated by NetworkManager
nameserver 192.168.1.1

(192.168.1.1 obviously being the local IP of the router - which I just double-checked.)

Any help would be greatly appreciated! I'm having a few other issues but this is the most pressing, and I'm sure that once I get a working internet connection I will be able to fix most of the minor things.

Thanks :)

navneeth
November 4th, 2009, 02:20 PM
The exact problem, indeed.

Okay, here's what you do, and remember that this is only a temporary fix.

Find DNS server addresses provided by your ISP. I did a Google search to find ones provided by mine that work.

Next


sudo nano /etc/resolv.conf

Comment-out or remove the router address from the file (use # to comment) and enter in two lines


nameserver <DNS server address>

So finally, it should look something like this.



# Generated by NetworkManager
#nameserver 192.168.1.1

nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx


(Of course, those addresses should be in place of those Xs.)


But before doing that myself, I got limited Internet connectivity by setting network.dns.disableIPv6 to true in about:config in Firefox. That at least let me search for a solution. But try the one mentioned earlier first and see if it works. :)

blockheadface
November 4th, 2009, 10:01 PM
Thanks so much for that! I had been trying to do that before, but I didn't comment out the router IP. But it certainly appears to work now, and hopefully I'll be able to download a proper fix from the update manager. Thanks again :)

navneeth
November 5th, 2009, 11:42 AM
You're welcome. :) I found that this was a temporary temporary-fix. After a reboot, the file listed the router address again. So to make this into a permanent temporary fix, I went to graphical network manager (right click on NM applet in panel-> Edit Connections). Choose your connection and click on the Edit... button. Go to the IPv4 Settings tab (Method: Automatic (DHCP) addresses only) and enter you DNS server addresses separated by a comma in the field that says DNS servers. Click Apply...

surveyorsteve
November 6th, 2009, 09:55 AM
Thanks again from me, I thought I'd never be able to solve my upgrade/internet problems. I've disabled IPv6 in grub and changed the IPv4 settings in NM and now I have Evolution email and all other programs I've tried connecting as well. I've got it working and can relax now...

megamania
November 6th, 2009, 09:58 AM
Try installing Wicd, which will replace Network Manager.

It worked for me...

blockheadface
November 6th, 2009, 12:59 PM
You're welcome. :) I found that this was a temporary temporary-fix. After a reboot, the file listed the router address again. So to make this into a permanent temporary fix, I went to graphical network manager (right click on NM applet in panel-> Edit Connections). Choose your connection and click on the Edit... button. Go to the IPv4 Settings tab (Method: Automatic (DHCP) addresses only) and enter you DNS server addresses separated by a comma in the field that says DNS servers. Click Apply...
One step ahead of you there :P Actually, credit should go to my brother for figuring that one out.

kiff
November 6th, 2009, 01:38 PM
The exact problem, indeed.

Okay, here's what you do, and remember that this is only a temporary fix.

Find DNS server addresses provided by your ISP. I did a Google search to find ones provided by mine that work.

Next


sudo nano /etc/resolv.conf

Comment-out or remove the router address from the file (use # to comment) and enter in two lines


nameserver <DNS server address>

So finally, it should look something like this.



# Generated by NetworkManager
#nameserver 192.168.1.1

nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx


(Of course, those addresses should be in place of those Xs.)


But before doing that myself, I got limited Internet connectivity by setting network.dns.disableIPv6 to true in about:config in Firefox. That at least let me search for a solution. But try the one mentioned earlier first and see if it works. :)
Thank you so much navneeth, this has been driving me crazy for about a week.

navneeth
November 6th, 2009, 02:28 PM
One step ahead of you there :P Actually, credit should go to my brother for figuring that one out.

Haha. :D

kiff and surveyorsteve: I guess, since we're in the mood to give credit where it's due, I should probably mention my best friend Google who helped me figure this one out. ;)

DiogoFC
November 8th, 2009, 02:46 AM
Mine is now working, but after trying a lot of solutions I don't which of them is responsible for that.

Probably it was forcing the following jaunty packages: network-manager, network-manager-gnome, libnm-glib0 and pptp-linux.

But only after two restarts [?] it did take effect, so maybe it was something else I did.