View Full Version : [ubuntu] 9.10 sound preference issue.

November 2nd, 2009, 10:09 AM
Ok, I had Ubuntu 9.04, with alsa 1.0.21 on it. I had configued it for my X-fi sound card and everything was working perfectly. After upgrading to 9.10 (which also installs pulseaudio, which I had disabled in 9.04), I disabled the pulseaudio, and reconfigured the alsa for my x-fi sound card. (After upgarde it was using intel audio (the one on the motherboard)). After reconfiguring and restarting alsa, the sound worked fine. The problem appeared after the restart, alsa again went back to intel audio. aplay -l listed card 0 as intel and card 1 as x-fi. Again reconfiguring and reloading alsa worked. But the problem appears after every restart. In 9.04, I had to configure it just once.

Also System>Preference>Sound has never worked on 9.10 (even when pulseaudio was enabled). Everytime I click it I get waiting for sound system to respond message box with a cancel button and it stays put there.

What do I need to do to stop reconfiguring alsa after every restart ? Also what of sound prefrence?

November 3rd, 2009, 01:22 PM
I reinstalled Alsa but the problem still remains

November 6th, 2009, 06:40 AM
I don't know, the problem of reconfiguring alsa after every restart has stopped. After I configured alsa after one of the restarts. The only thing I did differently was to stop Alsa and all related utilites.

The other problem still remains...any pointers on that will be highly appreciated.

Thanks in advance