View Full Version : [ubuntu] 9.10 upgrade has killed keyboard, sound, touchpad...

November 1st, 2009, 03:29 PM

I'm sorry if any of these problems have already been answered in other threads, I have tried to read through some of them but after half an hour with little joy, here I am.

After my upgrade to Karmic, the following has occured:

I am only able to get into 2.6.31 intermittently (once every 5 attempts). It usually hangs before it gets to the white ubuntu logo (the text saying booting from... ). When I do get in, my keyboard fails.

When I try booting from 2.6.28 (has worked every time so far), my touchpad and sound fail. Also, running alsamixer from the command line tells me:

alsamixer: function snd_ctl_open failed for default: No such file or directoryRunning touchpad from System > Preferences > Touchpad tells me:

GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynapticsI am using a 2 year old Advent 7201 laptop, and since it *may* be something to do with this (also since I remember I might have needed to change this after an epic graphics failure on an upgrade to Jaunty), I have posted my xorg.conf file here:


Thanks for any help you can give,


November 1st, 2009, 03:41 PM
I'm not sure SHMConfig even *exists* anymore. GSynaptics is...well I think I was one of the last people to submit patches to it...2 years ago.

That sound doesn't work on 2.6.28 is unsurprising. If it is necessary to use 2.6.28, I think you can workaround this by changing /etc/pulse/default.pa around lines 53-59. Comment out the conditionals and the module-udev-detect line, leaving only the module-detect line.

#.ifexists module-udev-detect.so
#load-module module-udev-detect
### Alternatively use the static hardware detection module (for systems that
### lack udev support)
load-module module-detect

November 1st, 2009, 10:16 PM

Thanks for the advice, but it hasn't really worked.

It does, however, make the laptop speakers crackle when logging on.

After some help from forums, I was told to try:

sudo apt-get --reinstall install linux-image-2.6.31-14-generic

On reboot, I got in to a fully working (as far as i could tell) Karmic. Which crashed after 2 minutes, and now I'm in the same position as before.

Running it from recovery mode shows it hangs after 2s, and the last line printed says nothing about an error, just something with scsi3:0:0:0 and OptiARC CD/DVD. I can try and find the exact text, but I don't know how helpful it would be and don't particularly want to waste time.

Doing a memtest from GRUB showed no errors with my RAM, too.

Thanks to ArcticPenguin from #ubuntu on irc.freenode.net for your help

November 10th, 2009, 09:00 PM

As advised on the IRC channel, I created a LiveUSB for karmic, with the intention of re-installing it. (Running the MD5SUM command in cygwin confirmed that it downloaded correctly)

Initially, I managed to boot from USB (took a while, but this was expected), but it crashed after 2 minutes. (It crashed as I tried to install pidgin from the ubuntu software centre so that I could use IRC)

Second time around, everything worked fine for about 5 minutes, and then the sound failed, followed 5 minutes later by the touchpad, and 2 minutes after this, the keyboard.

This leads me to believe the problem isn't to do with installation, and doesn't need a re-install. Can anyone advise me on what to do next, please? (afaik, the USB is in perfect working order)

Again, thanks to all on IRC for their advice.