View Full Version : [ubuntu] 9.10 grub error 2, fdisk -l fails, sudo grub fails

November 1st, 2009, 01:11 PM
I'm having serious issues trying to upgrade to 9.10.

First attempt - upgrade from 9.04 via update manager:

All seemed well until reboot, where I got dumped into a command prompt. This probably is a issue with nvidia drivers ... I've had problems on the last two upgrades which required editing xorg,conf (which doesn't seem to be available now). I'll post the solution link in a reply, but I'm not really wanting to try this route again.

Second attempt - clean install from live CD:

Downloaded and run install from disk. Hard drive recognized as raid setup (first time ever). Strange naming tho - /dev/mapper/nvidia_blahblah. Grub error 2 upon boot, no idea what's wrong. Redid install loading grub to root partition gives grub error 17.

Third attempt - Upgrade from clean install of 9.04:

Finally got 9.10 to boot. Definately an issue with grub and the raid setup from before, non-raid partitioning works fine. nvidia restricted drivers will not install, fails trying from "activate restricted driver". World of Warcraft hardly able to run, so back to 9.04.

My system seems to have serious nvidia issues, as usual, because of dual graphics cards. I'd love to be able to just upgrade and have that work, but how? And why the grub errors? and why can't nvidia drivers install from a CLEAN install? Until these issues are answered, I cannot upgrade, and if the problems persist too long, I may be forced back to Windows (pls, pls noooooooo)

November 2nd, 2009, 09:14 AM
This is the solution I use to get nvidia graphics working with my 2 card system - I'm wondering if it would work with 9.10 (updating for newer drivers, kernel, etc)?

First, open Synaptic and make sure the following pkgs are installed:

linux-headers-2.6.xx-x (assumes you use the current kernel)

Next, make sure the following are NOT installed, and use the "Mark for complete removal option" if any need to be removed:

ALL nvidia pkgs (search for nvidia)
Any old kernel pkgs, ie linux-headers-2.6.xx-x and earlier, etc
(This might not be necessary, but I did it anyway)

Now, perform the following command in a terminal:

sudo lspci | grep VGA

The output will look something like this:

02:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GTX (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GTX (rev a2)

Write down the number begining each line.

Go to System-Administration-Hardware Drivers and choose 180.44 and activate the driver - DO NOT REBOOT yet!!!

<If you have nothing to activate in hardware drivers, then go to Synaptic and install:>

nvidia-180-kernel source

Open terminal and type:

sudo gedit /etc/X11/xorg.conf

Replace the graphics "Device" section with the following:

Section "Device"
Identifier "Configured Video Device"
BusID "PCI:1:0:0"
Driver "nvidia"

Edit the BusID line to reflect the number you wrote down earlier (for me, that would be "PCI:2:0:0". ***MAKE SURE*** you use all colons as shown, and add the PCI part as shown.

If you have sli, add the following:

Option "sli" "auto"

Save the file, reboot and you should have 3d graphics working.

Note - for dual graphics PCs, you may boot to a black screen but you'll hear the normal boot sounds. If that happens, you used the wrong number in BusID. Change it to the other number OR plug your monitor into the other card.