View Full Version : [SOLVED] Change default OS in Grub2 and 9.10

November 1st, 2009, 01:30 AM
My girlfriend is killing me, Ubuntu is the default OS and I need it to be Windows 7 for her.

I've looked in the forum and people are talking about it but I've yet to find an answer.

Thanks for any help.


November 1st, 2009, 01:36 AM

You can install Startup-Manager in the Software Center. Open it at System -> Admin -> Startup-Manager and change the setting under "Default operating system".

That should do the trick. Good luck!

//Edit: you might want to run "sudo update-grub" in a Terminal. I don't know if this is required, but just to be on the safe side.

November 1st, 2009, 03:40 AM
Cool, thanks man. I'm going to check that out.

God I wish she would just get over it and use Ubuntu more.

Ubuntu, the chick unfriendly OS! :D

November 1st, 2009, 03:45 AM
Click on the SUM link in my signature line for a guide on using StartUp-Manager. It is an excellent tool in Grub, and is able to do some of it's tweaks in the new Grub 2.

If you prefer to change it via file editing, open /etc/default/grub and look for the "DEFAULT=0" line.
Open a terminal and type:

grep menuentry /boot/grub/grub.cfg
Count the "menuentry" listings, starting with 0. Note the Windows line. If it's the fourth line, it would be "DEFAULT=3".
Save /etc/default/grub and then run:

sudo update-grub

November 1st, 2009, 04:15 PM
Thank guys, I tried both ways and they both work.

I also changed it from 10 to 5 seconds for startup.

Very happy and now no more complaints from the girlfriend.

Rock on with your bad grub self! :guitar::guitar::guitar:

September 11th, 2010, 06:59 PM
Thank you very much!

November 2nd, 2010, 07:21 AM
I found a different way of doing this in 10.10 Maverick:

If you look in /etc/grub.d/ you'll see the files which create the grub OS ordering.


You'll see that other OSes are probed AFTER linux. A quick file rename changes that:

sudo mv /etc/grub.d/30_os-prober /etc/grub.d/05_os-prober
sudo update-grub

You'll see this:

Generating grub.cfg ...
Found Microsoft Windows XP Professional on /dev/sda1
Found linux image: /boot/vmlinuz-2.6.35-22-generic
Found initrd image: /boot/initrd.img-2.6.35-22-generic
Found memtest86+ image: /boot/memtest86+.bin

Note that windows is now first.