PDA

View Full Version : [SOLVED] 9.10 install, partition manager gray screen.



Cobracommand0
October 31st, 2009, 01:51 PM
I'm attempting to do a clean install from the previous distro to 9.10, I have a USB and DVD that I can attempt to install from. Both of these have an iso that passed the MD5 check, and show no errors from the initial "check disc for errors" screen.

My issue is such: When I choose to install Ubunu from the live cd, I can get all the way to step 4, the partition creator. However, at this step I get a gray screen with no options to create partitions. I can click continue, but it errors because there are no partitions created. I have formatted the drive while in the live CD boot, hoping that this would enable the partitioner to see the drive, but to no avail. I'm pretty sure that the problem is that the partitioner can't see that drive for some reason, and as a result can't offer partition options...

Any help would be much appreciated!

Cheers

Cobracommand0
November 1st, 2009, 01:37 AM
Bump!

gdburton
November 1st, 2009, 02:08 AM
Yup, seeing much the same situation here.
I have 1 300GB SATA disk with 4 partitions. All were NTFS, 1 was empty and was my intended target for a clean install.
Got to step 4 of 7 of install and there are no partitions listed and all buttons other than cancel, back & next are greyed out.
Tried deleting my target partition to leave a space, same result.
tried formatting as ext4, still same result.
CD image checks out okay.
Tried an update, all no change.

Interestingly a USB disk is detected happily.

Any assistance appreciated.

Lenry
November 1st, 2009, 05:12 AM
Same problem. Can't install Ubuntu, although it seems to run from a memory install from the live cd.

The disk partitioner doesn't work. Mostly grayed out window, nothing works.
I have a compaq presairo with an AMD 2 ghz processor and an 80 gig hd.
I have the previous version of Ubuntu and had no problem installing it that I remember. It has worked fine.

Also, I had a copy running on my I-mac using sun virtual box, and I can't get the new version to run on that either. It looks like 4 bit graphics and everything is so big I can't see any windows, only part of one. The last thing I read was "who are you".

fredymendez
November 1st, 2009, 05:26 AM
i have the same problem...can some one plz help us!! thank you

Cobracommand0
November 1st, 2009, 03:43 PM
Found this post, concerning things that sound close to my problem. I'm going to mess with these F6 boots to see if I can get my drive recognized...

http://ubuntuforums.org/showthread.php?t=1309128

Cobracommand0
November 1st, 2009, 08:30 PM
Still no luck with this issue, tried disabling the acpi and dmraid through the F6 options but to no avail. I'm pretty much stumped at what is going on here. I can format the drive in gparted while in a live cd boot, no problems interacting with the drive in fdisk either. The only time ubuntu is unable to see the drive is when the installation tries to format and install on step 4....

Drowning a little here, anyone have a resolution for this??

Cobracommand0
November 1st, 2009, 09:10 PM
Interestingly enough, my live disc for 8.10 has no problem whatsoever on step four. It can see the drive and manipulate the partition..

Rugger1
November 1st, 2009, 10:47 PM
This is due to a bug with dmraid. Boot into the live desktop using the install LiveCD. Then uninstall dmraid and libdmraid using Synaptic Package Manager (System -> Administration -> Synaptics Package Manager). Once you have removed that software click on the "Install Ubuntu 9.10" icon on your desktop and all will work fine.

Cheers!

Plecebo
November 2nd, 2009, 12:12 AM
Rugger1:

I was having this same issue and after doing a complete removal of the dmraid components you mentioned the drives were detected and I was able to install.

Thanks for the info.

barrycom
November 2nd, 2009, 01:06 AM
THANK YOU Rugger1 !!

The buggy packages have wasted an entire weekend. You have saved the day! Cheers

Cobracommand0
November 2nd, 2009, 02:51 AM
That did the trick Rugger1, many thanks for your post!

Cheers!