PDA

View Full Version : [ubuntu] 9.10 Clean Install - Command Prompt after boot. No Desktop.



jackharvest
October 30th, 2009, 04:36 PM
That's it. All I've got is a nice little command prompt staring at me. No Karmic. -__-

Is there a way to install the needed video drivers from here?

Typing "startx" gives me this:

(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

---

Any help would be super... I'm excited for Karmic, but I have to see it first! Haha

coolgenes
October 30th, 2009, 04:40 PM
try going into recovery mode and choose xfix at the bottom. if that doesn't do it then you can choose netroot in recovery mode and apt-get the correct drivers

jeffus_il
October 30th, 2009, 04:46 PM
This should do it:
first install the nvidia driver package

sudo apt-get install nvidia-glx-185
and then set it up as your xserver driver

sudo jockey-text -e nvidia-185

rimmy2000
December 5th, 2009, 04:21 PM
Hi,

I also get this problem. Have been scouring the forums for some time now. Can someone with a bit of patience help me through this problem please?

I am OK at Linux, but not really an expert. Be great if you can assist me. My problems are exactly as those detailed above.

I also have Nvidia card, but am not sure if the suggested command 'sudo apt-get install nvidia-glx-185' is generic for all Nvidia cards or for this particular user.

Thank you,
Richard

darkod
December 5th, 2009, 04:25 PM
There is very nice video driver handling package called EnvyNG. At the command prompt do:
sudo apt-get install envyng-core envyng-qt

After it's done installing run it in text mode with:
envyng -t

Select to install the Nvidia driver, it will know which one and from where to download (have no idea how). There is option to remove current driver but no need to do that. Afer it finishes downloading and reboot, it should be fine. See if it works.

PS. The above is possible only if your internet is working at that stage.

rimmy2000
December 5th, 2009, 04:56 PM
DARKROD,

Thanks for your response. I will try your suggestion and report back.

I tried the above, and now when I boot in normal mode I get a black screen with nothing else!

It reports xorg.conf may not be configured properly, I looked and it is very basic (eg just reads 'default monitor' etc)

Let me try your suggestion and get back to you - internet works fine btw..

Richard. (Thanks for your help mate)

rimmy2000
December 5th, 2009, 05:24 PM
I did follow your advice darkrod and all went successfully on the install of the EnvyNG.

Picked to install Nvidia driver and then selected the 185 driver, which was recommended.

Restarted and I just get a blank screen, I get the initial Ubuntu logo in the centre, then that disappears and it just goes dark. Nothing else happens, so I have to restart.

I should be able to follow any suggestions with regard to looking at config files and logs, but can't copy out the file content (as I don't know how) Currently corresponding with a windows machine, you see.

Any tips to resolve this?

Thanks, Richard

darkod
December 5th, 2009, 05:27 PM
I'm not sure what you need to do about the driver, EnvyNG worked fine for me. But if your question is how to access some files, you can always boot with the ubuntu cd and select Try Ubuntu option. That will run it from the cd. It gives you internet access to post on forums and check on the internet etc. You can look at your hdd files in Places. You might need to mount the partition first, it might say something like 25GB Filesystem, just click on it and it should mount (don't remember if the LiveCD asks for password during mounting because you wouldn't be in your standard user account).
This is the way you can see any files from your ubuntu, even from your windows, if sometimes it crashes and you need some important data.

Amilo1718
December 5th, 2009, 07:45 PM
Just made a clean install of 9.10 to my Toshiba laptop...
Everything went smoothly :)

Then the same CD inserted for a clean install on my Fujitsu laptop...
Guess what... ;)
Only a flickering command prompt after I selected a language (English) & made a choice for 'install Ubuntu' or 'Try Ubuntu whithout any change to your computer'

I chose a fresh install after the upgrade from 9.04 to 9.10 on this Fujitsu laptop got me the flickering command prompt after the reboot...

Does somebody have any ideas about the cause & the remedy ?

margazhang
December 6th, 2009, 08:47 AM
Same thing with me trying to do a clean installation of Ubuntu Studio 9.10. The installation went OK but when I tried to boot up, I got a blank/black screen after the Ubuntu Studio logo showed up and disappeared. It was clearly a video driver issue as typical with HP computer/monitor. As instructed above, I downloaded the EnvyNG package and installed the needed driver - Viola! It worked. Now I am using Ubuntu Studio without the display problem! Thanks a million!

rimmy2000
December 6th, 2009, 12:08 PM
Hasn't worked for me :-(

Does anyone else just get a black screen, and what appears to be hanging or crashing?