View Full Version : [SOLVED] 9.10 boots to tty1 CLI only

October 30th, 2009, 01:29 PM
I have done a clean install after checking everything worked off the live CD. I have had several versions of Ubuntu on my laptop (Toshiba). No problems before. Install seemed to go smoothly.

On boot up I get the little white Ubuntu logo and then I just get a command prompt, requesting a login. I can login but I had rather hoped for something more than a CLI. :(

Previous installs had suppported my graphics driver.

Any advice?


October 30th, 2009, 03:03 PM
Must have had an install glitch after all!

I just did *another* clean install -- looked exactly the same as the previous one but this time I get a proper login screen, not just a CLI prompt. Yay! :D

October 30th, 2009, 03:50 PM
Don't install the restricted graphics driver: "ATI/AMD proprietary FGLRX graphics driver" ("Tested" by Ubuntu Developers!). It totally screws up graphics -- no login screen -- on my Toshiba laptop (sat pro). It was fine under 9.04 and before.

Now doing my THIRD clean install! ](*,)

Totally the worst upgrade experience yet. May yet go back to 9.04

October 30th, 2009, 09:46 PM
I have the exact same problem with a HP mini 110 (1020la) under the intel-video-driver. And the rarest is the system works OK under the live session in every variation (tested in Ubuntu / Xubuntu / NR) but nothing bad happen before with the betas nor the RC.

October 31st, 2009, 03:23 PM
Upgrading from 9.04 to 9.10:
If you have a nvidia graphics card,
1. download the latest driver which has an extension of .run (NVIDIAxxx.run) and copy to a flash drive.
2. After upgrading, If the gnome desktop boots up then all went well for you and you don't have to follow the following steps.
3. If you see a tty1 flickering commandline then proceed. You will see a logon, where you should enter your username and then password

Note: (if your password is very long like mine, I suggest you change it to a character by pressing ESC on bootup and select the latest recovery kernel then log to
root type(passwd username, then enter new password and reboot(shutdown -r now)) else you would always get password error)

which takes you to the bash shell with a welcome message to ubuntu 9.10.
4. Insert the flash drive and press enter to see the commandline not minding the i/o error on display.
5. Detect the usb port your flash is connected by typing (ls /dev/sd*) that listed the number of usb ports. Remove the flash and type the same command to notice the
port that is now not available. For me it was sdc1.
6. Next connect the flash again then create a directory where you would mount your usb (mkdir myusb) then (sudo mount /dev/sdc1 myusb) to mount the content of your
flash to the directory. Note sdc1 is where my flash is connected and might be different for you.
7. Enter the directory (cd myusb) In the directory type (ls) and you should see the NVIDIA driver you downloaded.
8. Make it executable by typing (sudo chmod +x NVIDIAxxx.run) then run (./NVIDIAxxxx.run) This will bring up NVIDIA configuration wizard.
9. Answer YES to every question and once done, the GNOME desktop will bootup:-)

Enjoy!!!! Thanks to opensource coders!!!