PDA

View Full Version : [ubuntu] 9'04 - 9.10 error



SilentSentinel
October 30th, 2009, 12:37 AM
I have upgraded my 9.04 to 9.10 using the update function, but when I boot up, I now get the following errors -----
one or more of the mounts listed in /etc/fstab cannot yet be mounted:
(esc for recovery shell)
/: waiting for /dev/disk/by-uuid/2becea6bf-4576-451c-b778-bc0ffcb60212d /tmp: waiting for (null)
swap:waiting for UUID=949e92f7-a360-4de0-aa53-ee3fbe82cb49

how do I recover from this?

Fitzsimmons
October 30th, 2009, 01:53 AM
I have the exact same problem, although with a different UUID.

rvachtl
October 31st, 2009, 09:40 AM
Hello I have exactly the same problem after upgrading from 9.04 to 9.10 on my Aspire ONE netbook with SSD drive. As a result of the upgrade my system is unusable now. Any ideas how to fix it?

End3r
October 31st, 2009, 02:49 PM
I had this problem on my Dell M1330. I found a solution in this thread: http://ubuntuforums.org/showthread.php?p=8151569

Boot the computer, select the most up-to-date kernel in grub, then press ESC repeatedly until some sort of recovery screen appears (where it tells you to press ctrl+D then login). Login.

After that point, follow this:

Your installs have failed.

remount your filesystem like this:



mount -o remount,rw /

then do a


sudo dpkg --configure -a

And the installation will continue.

Apologies for the vagueness of those instructions; I'm doing it from memory.

rvachtl
November 2nd, 2009, 09:54 AM
The previous post might help you in case your installation failed before the end. This is thread show different problem though, I managed to fix it by following instructions in this post:
http://ubuntuforums.org/showthread.php?t=1308451&highlight=gave+waiting+root

i.e. by changing the grub to reference my hdd as "/dev/sda1" instead of by UID!