View Full Version : [SOLVED] metacity doesn't start automatically

October 29th, 2009, 09:49 PM
I just upgraded to ubuntu 9.10. I installed a bunch of different programs, setup my video card driver then restarted. When it can back up metacity wasn't running. I was able to add metacity to the "startup applications" to fix it. Is there someway I can fix the gnome config files to start metacity that way?

October 29th, 2009, 09:51 PM
my video card is an nvidia 8600 something and I'm using the propriety drivers

October 29th, 2009, 10:19 PM
my video card is an nvidia 8600 something and I'm using the propriety drivers

Did you happen to install Emerald? And do you have compiz running :)

October 29th, 2009, 10:21 PM
No, I didn't install emerald and I'm not using compiz

October 29th, 2009, 10:54 PM
Before you added metacity to autostart list... what would happen when you log in?

October 29th, 2009, 11:54 PM
Same here - funnily enough it worked a few times and out of a sudden metacity wasn`t started anymore. Switching to desktop effects enabled ( compiz ) and back didnt reenable metacity. No messages are given up to the gnome desktop - windows are just not decorated anymore.

October 30th, 2009, 12:21 AM
That's my issue - there is no window decoration. Thus the windows can't be manipulated at all.

I created a new user on my box, it didn't have the problem. It seems like there is some kind of issue with the upgrade of gnome. However, I would like my original user to work.

October 30th, 2009, 12:39 AM
Try with:
sudo dpkg-reconfigure metacity

Let me know how it goes!

October 30th, 2009, 12:59 AM
unfortunately, that didn't fix it

October 30th, 2009, 03:53 PM
Can you manually start metacity from console and give post output here? This is like fishing in the dark...

October 30th, 2009, 05:58 PM
when I start it from the console, I don't get any errors - it just starts

November 3rd, 2009, 02:05 AM
I have exactly the same problem. After upgrading to 9.10 the window manager just does not start on login. If I run metacity from the command line it works fine. X and gnome desktop seem to work fine. Where is metacity normally started from?

November 3rd, 2009, 02:08 AM
unfortunately, I don't know where metacity normally starts from. It used to be configured in the file ~/.gnome2/session. I'm not sure where they moved it to.

November 5th, 2009, 03:51 PM
unfortunately, I don't know where metacity normally starts from. It used to be configured in the file ~/.gnome2/session. I'm not sure where they moved it to.

Well Metacity is just window decorator, not a window manager... most likely you won't be able to find it in session files. Are you completly sure you are not running Compiz...

What is the result of:

ps -A | grep compiz

Just a note: If you have desktop effects enabled you are running Compiz...

November 11th, 2009, 09:17 PM
Hi! I'm new around here, but I have been Ubuntu / Linux user for a while. I recently upgraded from 8.04 to 9.10.

Looks like I'm having this same problem, when I log in there's no metacity or compiz running. I can open the terminal (panels are visible and working) and run either of them and things are working - until the next login of course. I have Ati Radeon 4870 and use the automatically offered closed drivers if that matters.

Now, to actually contribute at least something: I think I know where the window manager / decorator is specified in settings. Just start gconf-editor (via terminal, you probably won't find it in menus) and browse to /desktop/gnome/session. There is a configuration key required_components_list, which contains a list of values. For me they are [windowmanager,panel,filemanager].

Those values seem to refer to the required_components, which is another "folder" under the session "folder". There are some values, and the important one is windowmanager. Its value is metacity if you have no desktop effects on, and compiz if they are enabled. In my case it doesn't seem to do anything, but checking that value might help figure things out.

Edit: Okay, I took a little chance and added some extra values to those places and the program (firefox to be specific) did run, so I am pretty sure that that place really is the one that is supposed to run metacity or compiz.

November 12th, 2009, 09:29 AM
for /desktop/gnome/session/required_components/windowmanager I have metacity

November 14th, 2009, 12:08 PM
Yesterday, I tried deleting the entire .gconf directory, and the .gnome2 directory too. (Actually, I just renamed them.) Did not help. I think it can be ruled out that the problem lies in those places. The file .xsession-errors contains several error messages, but nothing seems to be related to metacity - or compiz if I try to enable desktop effects.

Now I just created a new user, and for it metacity...sorry, compiz started up fine. So even if the reason for metacity (or compiz) not starting is not in those two obvious-looking directories it still seems to be something in the home directory.

November 14th, 2009, 01:32 PM
I think I found out the files that caused this. Took some time to narrow the problem to a specific directory but it's nice to have a desktop that works again!

Go to directory .local/share/applications - .local resides in your home directory. (Ctrl-H shows dot-files and directories in file manager.) I moved these files from there to a backup folder:

gnome-wm.desktop (gnome-wm apparently is a script that runs the actual window manager and seems to be the default value for the windowmanager gconf key)

I have no idea why those files would cause problems - maybe it is a bad thing to have launchers with some specific names, or maybe the files are in a old format and some update broke compatibility or maybe they are somehow corrupted.

November 14th, 2009, 07:35 PM
Renaming the files gnome-wm.desktop metacity.desktop in the .local/share/applications directory fixed it! Good job figuring this out!

Ludwig Weinzierl
December 22nd, 2009, 04:05 PM
Moving the files gnome-wm.desktop metacity.desktop in the .local/share/applications directory fixed it for me as well!
Thanks a lot!

January 8th, 2010, 11:38 PM
Unfortunately rm-ing the files didn't work for me. I use compiz and suddenly it doesn't start automatically anymore. Another user has no problems, so with me too it's in my home dir.

I suspect the 'Automatically remember running apps' function: turned it on, didn't like how it worked, turned it off again. Unfortunately, removing everything in
./config/gnome-session/saved-session/ doesn't work either.

Any idea's?

October 17th, 2010, 08:28 PM
I was slow to upgrade, but removing the .desktop files from .local/share/applications worked for me.