View Full Version : [ubuntu] Can't install X-Fi drivers in 9.10

October 29th, 2009, 05:37 PM
make -C /lib/modules/2.6.31-14-generic-pae/build M=/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00
make[1]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic-pae'
CC [M] /home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.o
/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.c:14:26: error: sound/driver.h: No such file or directory
/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.c: In function ‘ct_card_probe’:
/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.c:55: error: implicit declaration of function ‘snd_card_new’
/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.c:55: warning: assignment makes pointer from integer without a cast
make[2]: *** [/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00/xfi.o] Error 1
make[1]: *** [_module_/home/mark/Desktop/XFiDrv_Linux_Public_US_1.00] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.31-14-generic-pae'
make: *** [all] Error 2

build-essential is installed as well as kernel headers for:

linux-headers-2.6.31-14-generic-pae is already the newest version.

Any ideas?


It actually is already installed, I just needed to un-mute it because the ATI HDMI driver took precedence.

October 31st, 2009, 05:09 AM
I have the same problem. No sound :(

October 31st, 2009, 07:37 AM
I have sound for some reason, but line-in doesn't work. Glad everyone else is having fun with their new OS while we sit here struggling to get our sound working.

October 31st, 2009, 04:32 PM
Yeah mine is working fine, it was just muted by default because i have 2 audio devices, I un-muted it and it works fine, didn't test line in yet.

November 13th, 2009, 03:37 AM
My solution may not work for all. But I ended up giving up on my X-Fi working under any version of Linux. I'm multi booted. I installed my old Sound Blaster Live. Now I have two sounds cards running on my system. The Linux uses the SB Live, while Vista runs the X-Fi. Works perfectly because Vista doesn't see the SB Live and Linux doesn't see the X-Fi. Also, I run 64 bit versions of both.

November 13th, 2009, 03:44 AM
Your X-Fi should/may work on 9.10 after installing the

and rebooting.

February 1st, 2010, 02:35 AM
I installed oss drivers (oopensound.com), then had to delete /dev/mixer and /dev/dsp and make new links to point to the right devices.
Now I have some sound, for example I have sound when I use firefox, but not in applications that use gstreamer (everything else).

February 1st, 2010, 06:08 AM
OK, nevermind the OSS, I got it working with alsa.
Remove the OSS and follow these steps:

February 16th, 2010, 05:02 PM
I know that it's not the best solution.. but after a bunch of tries it worked for me =)
I simply removed the include directives of sound/driver.h present in xfi.c and ctac.h
After I comment the following statement in xfi.h
//card = snd_card_new(index[dev], id[dev], THIS_MODULE, 0);
(the function snd_card_new probably is called from sound/driver.h)
After that I successfully compiled and installed and after a reboot the sound was working fine good.