View Full Version : [SOLVED] 9.10 RC Grub problems: Win partition missing, no menu.lst

October 23rd, 2009, 09:16 AM
Problem solved, thanks for reply :) .

I just installed the 9.10 RC from the alternate installation disk for 64-bit architectures.

I had two NTFS partitions, one of which was a Win7 partition (my college got Win7 for the students through a partnership program with MS).

Now, after booting my PC, Grub only displays the Ubuntu partition (although during installation it detected Win7 as Vista).

I can no longer find a menu.lst file in /boot/grub so I don't know what to edit.

I did NOT overwrite the NTFS partitions during installation, I chose the manual partitioning and automatically partitioned the free space I had.

This hasn't happened with previous versions of Ubuntu, perhaps it's all because this is still the RC?

Anyway, here's the contens of my /boot/grub:

915resolution.mod efiemu64.o lspci.mod reiserfs.mod
acpi.mod efiemu.mod lvm.mod scsi.mod
affs.mod elf.mod mdraid.mod search.mod
afs_be.mod ext2.mod memdisk.mod serial.mod
afs.mod extcmd.mod memrw.mod setjmp.mod
aout.mod fat.mod minicmd.mod sfs.mod
ata.mod font.mod minix.mod sh.mod
ata_pthru.mod fs_file.mod mmap.mod sleep.mod
at_keyboard.mod fshelp.mod moddep.lst tar.mod
befs_be.mod fs.lst msdospart.mod terminfo.mod
befs.mod fs_uuid.mod multiboot.mod test.mod
biosdisk.mod gfxterm.mod normal.mod tga.mod
bitmap.mod gptsync.mod ntfscomp.mod true.mod
blocklist.mod grub.cfg ntfs.mod udf.mod
boot.img grubenv ohci.mod ufs1.mod
boot.mod gzio.mod part_acorn.mod ufs2.mod
bsd.mod halt.mod part_amiga.mod uhci.mod
bufio.mod handler.lst part_apple.mod usb_keyboard.mod
cat.mod handler.mod part_gpt.mod usb.mod
cdboot.img hdparm.mod partmap.lst usbms.mod
chain.mod hello.mod part_msdos.mod usbtest.mod
cmp.mod help.mod part_sun.mod vbeinfo.mod
command.lst hexdump.mod parttool.lst vbe.mod
configfile.mod hfs.mod parttool.mod vbetest.mod
core.img hfsplus.mod password.mod vga.mod
cpio.mod iso9660.mod pci.mod vga_text.mod
cpuid.mod jfs.mod play.mod video_fb.mod
crc.mod jpeg.mod png.mod video.mod
datehook.mod kernel.img probe.mod videotest.mod
date.mod keystatus.mod pxeboot.img xfs.mod
datetime.mod linux16.mod pxecmd.mod xnu.mod
device.map linux.mod pxe.mod xnu_uuid.mod
diskboot.img lnxboot.img raid5rec.mod zfsinfo.mod
dm_nv.mod loadenv.mod raid6rec.mod zfs.mod
drivemap.mod loopback.mod raid.mod
echo.mod lsmmap.mod read.mod
efiemu32.o ls.mod reboot.mod

Any ideas on how to get my Win partition back (short of waiting for the final version of Ubuntu 9.10 and reinstalling) ?

October 23rd, 2009, 09:52 AM
Not sure what has gone wrong with the installation, but you won't find a /boot/grub/menu.lst in 9.10 as it uses grub2, not the old grub-legacy. Look here (http://members.iinet.net/~herman546/p20/GRUB2%20Configuration%20File%20Commands.html) for more information on grub2 and here (https://wiki.edubuntu.org/Grub2). Did you do a md5checksum on the downloaded .iso before burning it to disk and then check the disk for errors prior to installation?

October 24th, 2009, 10:06 AM
Thank you very much for the reply. I was able to correct the grub installation and got my win partition back by running update-grub.

Also, I ran apt-get upgrade a few minutes ago and noticed grub was patched to 1.97 beta 4; this patch configured itself and found the win partition (so I guess the final version of 9.10 won't have this bug).

karma coma
October 30th, 2009, 03:43 PM
hi, yesterday i installed 9.10 - (the first time handling linux for me)

grub2 runs and shows me the new linux os and my old winxp.

9.10 starts without problems but when i select windows to boot, the procedure stops at a blinking cursor. i read through many threads getting to know the booting of linux.

My major problem right now (i think) is, that i can't find menu.lst in my /grub/boot directory, also update-grub is missing. I tried to reinstall grub2 via terminal, but nothing changed. You have any ideas? I hope someone can help me to run both os.

I also tried to post the output of: $ fdisk - l , but nothing happens.