View Full Version : Why do my keyboard keys change on the fly

October 21st, 2009, 06:37 AM
I typed a simple C program to try and get the hang of a linux prompt, so I typed the hello world program. after a successful compile and run, I went to add more code but my quotation marks have turned into tiny pairs of dots. this has affected everything that I type in. I am using US keyboard and it worked fine until I compiled and ran hello world. """""""""""""" these are from my windows computer.I'll try and login with the notebook with linux and display the wierd qoutes I'm getting there.

October 21st, 2009, 06:42 AM
This what Iดve got now จจจจจจจจจจจจจจจจจจจจจจจจจจจจจon Kubuntu.
Anyone have any Ideas? Thanks.

October 21st, 2009, 07:19 AM
I have to hold shift down then press qout to get it to print to screen then if I press the space bar down it prints a standard qoute, but only once - it then continues to work as space.

Tony Flury
October 21st, 2009, 08:21 AM
Have you checked that you have the correct Keyboard set up - System -> Preferences -> Keyboard.

There should be no reason why a Hello world program should impact your keys or keyboard - can you post the code of your program, it might be that your code has a side-effect. Use the CODE tags when you include your source code.

October 21st, 2009, 08:56 AM
Yes keyboard is correct.
this is the code:

#include <stdio.h>
int main () {

printf ("hello world");

return 0;

October 21st, 2009, 09:04 AM
Then in command line:
gcc -Wall -o hello hello.c

I was in the appropriate directory.
When I removed the offending quotes in the new code the compiler and shell were happy.
But now it does something weird, it requires you to hit the key twice to get one output and if you hit it once and then hit the space bar it will make a qoute that is code compatable.
it's almost as if I somehow toggled some sort of letter highlighter or punctuator or ???

Tony Flury
October 21st, 2009, 11:38 AM
I can't see that the code that you have given would cause any changes to your keyboard or key mappings.

Does it still do the keyboard funny over a reboot ?

It might be (long shot) that your keyboard is mis configure, you might need to reset the config (delete the layout definition and start again).

ANother suggestion is to post your question in General help, as I am fairly sure the problem is not connected with your little "Hello World" app.

October 21st, 2009, 05:31 PM
I set keyboard to us generic but no change. I have run DSL Linux as a live CD and did not have any issues.
Looks like I'm gonna have to remove this OS!

October 21st, 2009, 05:42 PM
Yes I'm going to post this thread in general help.
I will keep this one open for 24 hours to see if I get any responses.

October 21st, 2009, 11:31 PM
Wow, I'm really surprised that nobody has been able to help..
I guess there is no fix and the best option is to search for linux distros that don't support dead keys or accented letters.
I mean, I've got an excuse, I used windows vista prior to this and XP before that it's perfectly excusable that I don't know how to turn this off but whats your excuse (the ubuntu kubuntu community).

October 21st, 2009, 11:36 PM
Could you describe the exact steps? Maybe someone will be able to reproduce it.

October 22nd, 2009, 02:34 AM
I guess there is no fix and the best option is to search for linux distros that don't support dead keys or accented letters.No such thing.

I mean, I've got an excuse, I used windows vista prior to this and XP before that it's perfectly excusable that I don't know how to turn this off but whats your excuse (the ubuntu kubuntu community).That we've never needed to. Either we actually want the behavior, or we've never run into it.

IIRC, the behavior you describe is what I saw with a U.S. International layout. I don't get it with a regular U.S. layout. I've never gotten it as the default setup; I had to explicitly select it, when I wanted to test support for dead keys etc. in a library I was maintaining (PDCurses).

Looking at the Gnome keyboard option widget now, it seems to have changed a lot since I last used it. I find to my surprise that my current layout is shown as "(Intl)", though I don't have dead keys. I know there's a way to switch, but I can't say offhand what it is.

Try Googling on "Ubuntu dead keys", etc.

October 23rd, 2009, 12:02 AM
Kubuntu seems to be like some sort of b@st@rd stepchild to ubuntu.the documentation is sparce for Kubuntu and different than the GNOME environment on Ubuntu. I don't even know why I chose Kubuntu over Ubuntu really? I'm pretty disgusted with it.I read a little here https://help.ubuntu.com/community/ComposeKeybut I don't have Ubuntu, I have Kubuntu.They always mention Ubuntu and Xubuntu but rarely is Kubuntu mentioned. The closest thing thing you ever hear about Kubuntu is that the documentation should work on other versions.If Kubuntu is being described as "other versions" in the documentation I think that that should have sent red flags off in my head. There are a lot of bugs reported on the net about international characters and the associated patches in Kubuntu, why Kubuntu & not others, I guess we'll never know.I guess when I have some time I'll check that box they write about at the documentation page for Ubuntu, just to see if that fixed it but I should probably be using Ubuntu over Kubuntu if I want to be able to sort this kind of stuff out. I can only imagine how many people reading these forums ignore certain posts because it has an Kubuntu prefix instead of Ubuntu.

October 23rd, 2009, 02:06 AM
Yeah I googled dead keys Kubuntu and found info about Ubuntu only.I have been through every keyboasrd setting. You have to look under languages and regional or something like that.And it seems that Ubuntu an Xubuntu both have relatively easy fixes but Kubuntu is completely different.If they won't wright documentation for one of the versions they should just end it.Thats the solution to this problem, get rid of Kubuntu!Stick with the mainstream and download Ubuntu.