PDA

View Full Version : [SOLVED] System Monitor and CPU widgets no longer work



kvarley
October 17th, 2009, 09:27 PM
I ran some updates and while configuring samba-common the update-manager froze. I came back a while later and killed the update-manager window.

Now when I go to add a system monitor or a CPU scaling widget to the panel it gives me this:



The panel encountered a problem while loading "OAFIID:GNOME_MultiLoadApplet".

Do you want to delete the applet from your configuration?

Any ideas? Thanks

ajgreeny
October 17th, 2009, 10:09 PM
In a terminal use the command
sudo dpkg --configure -a and it might put right the non configuration that occurred when your system froze.

louieb
October 18th, 2009, 12:50 AM
Don't have fix. But a workaround. When I get that message I just log out then login again and everything starts up normally. I Guess its some sort of timing issue.

kvarley
October 18th, 2009, 11:59 AM
Solved. It was a much bigger problem.

Somehow when the update broke it left me with an error with the desktop environment.

So in terminal I re-installed the environment. Then installed "ubuntu-desktop", that fixed it, for now...

Thanks for the help anyway!