View Full Version : [ubuntu] 9.10 Hangs after inactivity

October 14th, 2009, 09:58 PM
After 30 minutes or so of inactivity, my new installation of 9.10 hangs and becomes unresponsive. The mouse can still move but I cannot click on anything. Also, when I try to run the update manager, it claims I need a partial upgrade, then fails to download the necessary files. I am working on an e-machines desktop. The only post install changes I have made is replacing the mail client with Thunderbird, installing flash, and setting up my wireless card with ndiswrapper (running a US Robotics card). I am at work at the moment so if anyone needs more info about my computer or me to post log files, I would be glad to do so. I have disabled my screensaver and any power saving settings. If anyone has any ideas, I would love to hear them. Thanks for any help!

November 2nd, 2009, 02:48 PM
My custom built desktop has the same problem. My Comapq Presario 2100 laptop doesn't have this problem though.

November 2nd, 2009, 03:01 PM
Mine hangs and the mouse wont move at all (complete lockup), anyone heard of a resolution yet?

November 2nd, 2009, 03:43 PM
I'm having this problem too. Hangs after random amounts of inactivity and is entirely unresponsive.

November 3rd, 2009, 02:54 PM
I somehow got it fixed but I have no idea how and why. It hangs with and without activity. What I did was when I got fed up and logged in using gnome fail safe, it hung; I tried KDE, it hung; I then tried xterm and run firefox, it hung too; Reinstall firefox; Got back to Gnome. For some reason everything works. When I tried to start SCIM before I did all these it errored on "creating X11 front end.." but now it works too.

November 4th, 2009, 08:17 PM
I fixed mine. I had a pre-release version of 9.10 and it was freezing up periodically. The mouse would move but I could not click on anything. Key combos didn't work and I would end up having to restart. I couldn't upgrade because the update manager would report that it couldn't download the proper files. I burnt the official 9.10 release to disk and tried to install it. That installer would hang. I tried to install Linux Mint 7. That installer would hang. I tried to install 9.04 - another hang. Each time my caps lock and num lock lights on the keyboard would flash. From reading forums, I discovered that flashing lights = kernel panic. This probably means a hardware failure somewhere. I reseated my RAM, removed my pci cards, and unplugged any usb devices. No more hangs on install. I installed Linux Mint 7 and it has been running smooth ever since. Turns out the problem was a U.S. robotics wireless pci card. Replaced it with a different brand from newegg, and have not looked back since. I assume that since linux mint is running fine now, 9.10 would as well. Hope this helps.

tl;dr - It was being caused by a faulty pci network adapter. Run an update, then check your hardware.

November 14th, 2009, 08:11 PM

Had the same issue. Hangs after some minutes. The mouse was movable, keyboard useless. Remote vogin via ssh was possible.

Fixed changing the graphics driver from intel to i915.

February 10th, 2010, 04:05 AM
I have the same problem.

Discovered it happens only when I run firefox. Try to upgrade to FF3.6 also does not help. So currently live with it using opera & chrome as my browser.