View Full Version : [all variants] No BIOS access on Toshiba Satellite L555 ?

October 9th, 2009, 05:43 AM
The only documented way to alter the BIOS settings on the Toshiba Satellite L5xxx series laptops on the Toshiba website is to use a configuration program that runs from the Windows Control Panel. I bought a L555D-S7909 from NewEgg and I would like to install Ubuntu on it.

Has Toshiba made it impossible to install Ubuntu or any other Linux on these machines? For example, I don't see any way to make the machine boot from the DVD drive, even in the Windows Control Panel.

October 9th, 2009, 06:07 AM
This thread: http://forums.laptopvideo2go.com/topic/640-entering-bios-setup-in-toshiba-laptop/
mentioned turning the machine on and pressing the F12 key. I turned the machine on and tapped the key about once per second. This brought up a boot menu which will let me boot from the DVD drive. As far as I can tell it does not permanently set the DVD drive as the boot device.

But do I dare install Ubuntu without knowing whether I can change other BIOS settings? It would be nice to know if any pioneer has installed Ubuntu on an L5xx series laptop.

October 9th, 2009, 06:10 AM
Usually F2 will access all Bios systems there maybe a few exceptions..

October 9th, 2009, 06:14 AM
On my Toshiba laptop, from the M200 range of models, F2 while the "Toshiba" splash screen is showing will let you access BIOS, and F12 instead will let you choose a boot device.

October 9th, 2009, 06:29 AM
It is true that on many Toshiba laptops, one can access the BIOS setup by pressing some combination of keys. However, this is not true of the L5xx series - at least according to a FAQ on the a Toshiba website, which says:

"The BIOS cannot be accessed via boot up on these systems. To make changes to the BIOS setting on these models please use the Toshiba Hardware Setup utility located within Control Panel. The BIOS settings can be reset to their default valies by booting the system up and holding down the‘Esc’ key, then press F1 to reset to default settings when prompted."

"Satellite 5xxx"

I've tried the method (F2) mentioned in the previous posts on my L555D machine and, in agreement with the FAQ, it doesn't work.