View Full Version : [SOLVED] Problem installing Java6 runtime environment

October 9th, 2009, 03:12 AM
I am trying to install Sun Java runtime envoirenment in my operating system but it is giving me this error,
"E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report."

Can someone help to figure it out???

October 9th, 2009, 03:14 AM
How exactly did you try to install it?

October 9th, 2009, 03:22 AM
I tried it from "Applications>Add Remove Program>internet"

October 9th, 2009, 03:43 AM
Try to install this way:

sudo aptitude install sun-java6-jre

Or if you would rather: Go to "System > Administration > Synaptic Package Manager" and search for "sun-java6-jre". Select it and click apply.

Let me know if it works.

October 9th, 2009, 04:22 AM
Its not working.
Synaptic Package Manager turns off showing the same error message

October 9th, 2009, 04:27 AM
First of all, I made a mistake in the previous command. I don't know what I was thinking, but it should be 'sun-java6-jre' not 'flashplugin-installer'. I fixed my post to reflect this.

However, it doesn't sound like that will help you at the moment. I think that you should open up a terminal (Applications > Accessories > Terminal) and execute:

sudo dpkg --configure -a
It sounds like you have packages that weren't configured all the way.

October 10th, 2009, 03:39 AM
Its still not working, this is shown in the terminal window.
"sudo: dpkg--configure-a: command not found"

October 12th, 2009, 02:58 PM
It is working dear, thanks a lot...

October 13th, 2009, 02:46 PM
I am having a similar problem. running the "configure" command recommended helped and allowed me to run the "aptitude install" command (prior to the "configure" command, I couldn't run an install at all). But now I'm hitting the same roadblock that got me into this mess. It starts installing then I get to the Blue license screen and I can't do anything. I hit enter to signify "ok" but nothing happens.

Any help?

October 13th, 2009, 03:55 PM
I hit enter to signify "ok" but nothing happens.

If you look at the screen, you'll see that the sidebar is red, indicating that it is selected. Hit "tab" until the "OK" button is selected and hit "enter".

October 13th, 2009, 04:01 PM

Thanks, that worked. I'd actually just found the same answer here:


I found this after I tried to install it via kpackagekit & got an error.

Thanks! Love getting solutions w/in minutes of posting the problem! You guys rock!