View Full Version : [ubuntu] Apt-get Error

October 7th, 2009, 01:14 AM
I logged in to my home computer today and saw that I had some updates to Wesnoth, Spring, Nexuiz etc but when I clicked install it wouldn't download the updates. I tried to run apt-get upgrade and got this error:

E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory

Also, when I run `ps -eaf | grep apt` I saw this:
root 3806 3713 0 19:39 ? 00:00:00 apt-get -qq -d dist-upgrade

What's the deal?

October 7th, 2009, 01:27 AM
something, somewhere, seems to have locked APT.

Do you have GDEBI or Synaptic, etc running?

October 7th, 2009, 01:39 AM
No, I just turned my desktop on and logged in. It started dist-upgrade on it's own for some reason, but it's not showing now. I just ran apt-get update and upgrade and it finally worked, but now it's telling me all of the package updates it asked me about a few minutes ago are being held back. Dwah?