PDA

View Full Version : [SOLVED] Sound is muted after reboot



slamhound
September 29th, 2009, 10:58 AM
I'm guessing there's some simple solution to this, but I can't figure it out. I'm setting up a new 9.10 system and am almost there with it. But one weird problem cropped up after making a few changes. Every time I reboot the computer, the sound is muted. I have to go to "mixer" and then unmute and raise the volume for "front".

I think the first time it was muted actually occurred during DVD playback through myth, but since then, it just occurs on reboot. Once I change the settings in mixer, everything works until I reboot.

Any advice?

klc5555
September 29th, 2009, 02:31 PM
You may have done a logout from X and done a "save settings" while the mixer was muted. So it comes up that way on X startup. Try logging out with a "save settings" with the mixer unmuted.

slamhound
September 30th, 2009, 01:00 AM
Okay, I tried that, but still no sound after reboot. Any other suggestions for things to try?

faical117
October 16th, 2009, 05:43 PM
try this:
unmute the sound
and #sudo alsactl store

faical117
October 16th, 2009, 05:48 PM
sudo alsa force-reload

sudo alsactl store 0

igoddard
October 16th, 2009, 11:26 PM
Delete /var/lib/alsa/asound.state, set the controls in the mixer (you might find the actual problem is in the front channel) and then, as root, run alsactl store.

slamhound
October 17th, 2009, 12:58 AM
Thanks. Just changing volume and running "sudo alsactl store" worked for me.