View Full Version : hald is doing SIGSEGV; how do i get desktop without hald?

September 28th, 2009, 01:49 PM
hald is doing SIGSEGV, how can I bypass dbus and hal to get to the desktop?


Get the xorg.conf from this port and replace your xorg.conf

OR the following is ALL that you need in your xorg.conf

Section "ServerLayout"
Identifier "Default Layout"
Option "AutoAddDevices" "off"

Also, run "sudo /etc/init.d/hal restart" once your gnome desktop is up and running.

HAL is a pos that needs to be kept out of serious stuff like X. HAL is NOT stable enough, one hiccup and your ENTIRE desktop is inaccessible without ANY indication of WHAT the HELL is wrong!!!!! I'd love to hear the explanation of how ANY dependency on HAL's flakiness is better in ANY form whatsoever as compared with the registry nonsense that MS keeps getting beat up for

Seriously, I mean, HAL has to have ONE hiccup and my desktop is inaccessible with no warnings/workarounds/explanations/indications???????????? What kind of Engineering is this?

Edit: deleted all kinds of hald logs

System is Dell Inspiron 6400 running Ubuntu 9.04. Basic install.

November 15th, 2009, 10:30 AM
This is not to be considered solved since the hald has started crashing again... on a 9.10 clean install + updates.....