PDA

View Full Version : [ubuntu] Spanish keyboard



gjmata
September 23rd, 2009, 05:37 PM
I'm using Ubuntu Jaunty. Since I do most of my work in english, I am using english as my desktop language.

However, my keyboard has a spanish layout. And ocassionally I need to write spanish documents in Open Office (OO).

The problem is that spanish especific characters (accents, ) are not recognized in OO. Is there a way around this?

Thanks in advance.

Gustavo J. Mata

clonne4crw
September 28th, 2009, 03:24 AM
You can always change the keyboard layout under Keyboard Settings. Or have you done this already?

I guess you could do what I do for Spanish class and use ASCII scan codeshttp://www.lingolex.com/spanishascii.htm

gjmata
October 8th, 2009, 09:08 PM
Changing the keyboard layout does not work, unfortunately.

I must add that the caracter works. So does

But I cannot type accented vowels. The accent character comes out separate from the accented character, like this: a.

gjmata
October 8th, 2009, 09:10 PM
I must add that the umlaut character has the same problem. It comes out as:

u

theZoid
October 9th, 2009, 12:52 AM
My wife is Peruvian, and she had those characters mapped somehow, like an alt-u did the umlaut, but that was in windows...

I guess I'm not much help....

jadu
March 3rd, 2010, 03:40 PM
I would like to reactivate this thread.
I have added spanish to keyboard preferences. and a shortcut that activates it.
The problem is, when it activates spanish, only some of the keys work! the works, and so do other parts of the spanish layout. but the accented keys don't work. what should be an accented a comes out as {a.
anyone know why?
thanks

jmrasor
April 20th, 2010, 05:57 PM
I added the Spanish keyboard (not the Latin American one), and it works fine: , , , etc.

I've got Ubuntu Karmic installed with Spanish GUI (sitting in Guatemala), so I did this:

Sistema - Preferencias - Teclado - Distribuciones - Aadir - Espaa

I'm guessing the English menu choices would go something like:

System - Preferences - Keyboard - Layouts - Add - Spain.

I had an ugly time with this, 'cuz I wanted to stick with Latin American keyboard, and I had the same problem you did, jadu. Bleepin' {a instead of . Now, umlaut works as well.

rnerwein
April 20th, 2010, 09:02 PM
hi
i have a german keyboard and when i must have a special character like or i use:
right-Alt ~a --> ( type Alt and ~ at once and then a )

ciao