View Full Version : [ubuntu] Texts missing after 9.04 upgrade

September 22nd, 2009, 11:19 AM
After my update from 8.10 to 9.04 all text strings in applications (in web sites, dialogs, menus etc.) are missing until I hold the mouse over them. Also tty2 to tty6 are weird looking graphics instead of login prompts to shell. What can be wrong?
Thank you

September 22nd, 2009, 02:39 PM
This is most likely a problem with the kernel module that is running your display. What is your hardware (computer, display adapter)?

September 22nd, 2009, 03:22 PM
Geforce 5700 running the proprietary nvidia driver, on a MSI K8TN FISR motherboard.

September 22nd, 2009, 04:14 PM
What is your display?

September 22nd, 2009, 07:42 PM
TFT, connected with VGA.

September 22nd, 2009, 08:27 PM
Boot in Recovery Mode. Try xfix. If that doesn't help, can you at least get a command-line interface? Or, do you get distorted text even with a Recovery Mode boot?

September 25th, 2009, 05:29 PM
xfix made x look unrecognizeble in black and green as if it where out of sync. I have a working commandline at tty1. I've tried restoring old xorg-confs that I know was working before, but they don't do any longer.

September 29th, 2009, 05:13 PM
I get the same screwed up login splash that hangs when I try to load the 9.04 or 9.10 live-cd. Older live-cd:s (7.04) work fine. Is there a module I need to downgrade or what?

September 29th, 2009, 07:58 PM
You can try to force a VESA driver to start a graphical desktop. I think it is F6 at the Live CD opening menu that lets you edit the command line. Or, there might be a safe-graphics mode that does the same thing.

If you edit the kernel command line, add vesa=force to the end of the line, then try to boot. This might also work on the kernel line in the menu.lst file of an installed system.

September 30th, 2009, 06:54 PM
I "solved" it by downgrading xserver-xorg to 8.10 intrepid version.