PDA

View Full Version : [ubuntu] Asrock ION no (multichannel) SPDIF sound in XBMC (Ubuntu 9.04 Jaunty)



OobieDoob
September 22nd, 2009, 10:30 AM
Hardware: Asrock ION 330 (DVD)
BIOS: 1.60
OS: Ubuntu Jaunty (9.04)
Display drivers: 185.18.36
Alsa drivers: 1.0.21

First things first, I want multichannel audio (AC3/DTS) over SPDIF in XBMC (via HDMI isnít necessary). Before I started with my days of struggle through xbmc and linux threads (yes Iím a linux noob), I had sound over SPDIF in XBMC but as so many unfortunately only 2-channel (http://ubuntuforums.org/showthread.php?t=1212523). Now after my hellish search I lost my SPDIF sound, but only in video files which are played by XBMC.

This was after my last try to disable pulseaudio by this post: http://idyllictux.wordpress.com/2009/04/21/ubuntu-904-jaunty-keeping-the-beast-pulseaudio-at-bay/
All my tries with /etc/asound.conf and ~/.asoundrc didnít work so I removed the files but unfortunately no luck. If Iím getting sound back in video files I still think itís only in 2-channel stereo. Before disabling PulseAudio I had the strange thing that my amp thought it received a 2-channel stream but itís was in fact a 5.1 channel stream but only played over my L and R speaker. I can tell you, it sounds very strange ;-)

Does someone have an idea because Iím clueless at this point. Help much appreciated!

OobieDoob
September 23rd, 2009, 02:13 PM
UPDATE: closing thread after a 3rd clean Ubuntu Jaunty install and replies (or lack off replies) to just clean install Ubuntu Jaunty again (on other forums).

For the people with the same crappy problem, I tested in Windows 7 today and everything works like a charm without even installing extra display and/or sound drivers: full HD display and DD5.1+DTS sound over SPDIF and/or HDMI.

Why is this such a problem within the latest Ubuntu version. Unbelievable!

zorniki
October 29th, 2009, 10:03 AM
Hi OobieDoob!

Iīve had the same problems with my ION330 since 9.04 released. No help in sight it seems. Iīve pretty much abandoned my Ubuntu partition since then... :(