PDA

View Full Version : [ubuntu] CUPS & Windows printing



cowboy_mcd74
September 20th, 2009, 08:19 PM
I have a printer hooked up to my ubuntu 9.04 desktop. I can print, no problem, from the desktop. I've shared it over my network, and can view it from my laptop running Windows, both in an explorer window, and by connecting to the CUPS browser page.

I cannot, however, print to the printer. If I add it through Windows Explorer (by browsing to \\server\printers and clicking on the printer), and try to print to it, nothing happens. If I try to add the printer manually (by going to add printer->network printer->and type in 'http://server:631/printers/printername'), it cannot find it. But, if I type in 'http://server:631/printers/printername' into the browser, it displays the printer's page.

Anyone else have this problem? Or know of any ideas on how to solve it? Thanks.

khelben1979
September 20th, 2009, 08:27 PM
Give us the exact model of the printer. Also, are you trying to print pages through Wine or what do you mean?

cowboy_mcd74
September 20th, 2009, 09:43 PM
sorry, yeah, I should have made it more clear.

It's an HP Officejet 4200. It's connected to a desktop running Ubuntu 9.04. I and my roommates have laptops that we use, each of which run Windows. All of them are connected over a wireless network.

I can connect to the desktop, view the printer, even connect to the printer (using windows explorer), but cannot print to it. If I try to use the 'add printer' wizard, it doesn't even detect the printer. But I can bring up a browser on my laptop and view the printer's CUPS page.

Do you need any other information?

jonallport
September 20th, 2009, 10:37 PM
I seem to remember something like you need the .printer in the URL for Windoze, CUPS to CUPS seems to know that this is implied.

That'd be:
http://server:631/printers/printername/.printer

cowboy_mcd74
September 20th, 2009, 10:58 PM
Thanks for the idea, but I tried that, and it still comes up with the same error that Windows can't find the printer...

cowboy_mcd74
September 21st, 2009, 01:38 AM
Nevermind! I figured it out. It didn't occur to me right away cause XP's firewall sucks, but the newer Windows versions block outgoing connections. Windows wouldn't let me connect to the printer!

Still couldn't find it by manually putting in the address, but now when I navigate to \\server\printers I can connect to it and print to it =D