View Full Version : [ubuntu] error message installing jdk

September 20th, 2009, 08:01 AM
I tried to install jdk 6 on my ubuntu, using sudo apt-get install sun-java6-jdk, but it took forever to do the configure stuff with a stupid screen, and I didn't know how to stop it so I quit the terminal. Now every time I try to reinstall it, I get the error message:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I try to remove all the files sun-java6* in the archives folder and download and install them again, but still get the same message, also try to do the sudo apt-get -f install and sudo dpkg --configure -a, but it doesn't change anything.

What should I do to fix this?
And then, if it'll be fixed and I want to install jdk, am I supposed to wait such a long time for the configuration stuff?

Thank you very much!

September 20th, 2009, 08:36 AM
Open a terminal and run

sudo dpkg --configure -a
You may need to except the license agreement, by pressing 'Tab' till 'ok' is highlighted then 'enter'

September 20th, 2009, 09:45 AM
yes I did it but it didn't work still.

I got the license part, thank you :-)

September 20th, 2009, 09:49 AM
Can you post the output to

sudo dpkg --configure -a