PDA

View Full Version : [ubuntu] Another Nvidia Widescreen Issue



Soscan2062
September 20th, 2009, 01:36 AM
Hello, I think I've read at least 10 different threads on this issue. I've done everything my feeble mind can come up with to do from those threads but to no avail. So here's what I have and what I've done.

Problem
I have a TV (hooked up through VGA) that's capable of 1440x900 resolution connected to an Nvidia 8500 GT graphics card. However my Nvidia X Server Settings does not list that resolution and the only one close is 1366x768. (which I don't think is the same ratio) How do I go about making that happen? (And keeping it there from what I've read from some other threads)

Attempts
Several posts referred to this fix: http://www.krishnamo...idescreen.html (http://www.krishnamoorthy.in/2009/05/ubuntu-904-nvidia-7300-gt-widescreen.html) So I reverted my recently updated proprietary driver from v 180 to v 173 as stated. Found xorg.conf, opened it through the terminal using sudo gedit, entered password, and made the changes as shown. Logged out, restarted, and nothing. I go into the settings and it lists everything as unchanged. If I update like it says to do within xorg.conf it completely resets the entire file after backing it up. (I forget what it says but I really don't want to go through that again. But I will if you need me too.)

I saw another thread say to go into the root terminal, gksu nvidia-settings, and make changes as root in the gui. So I go to Save X Configuration and check out the preview there. It shows that whatever I've been putting into the xorg.conf it's been spitting it out as a comment and replacing it with whatever it wants. (It'll be in further down) So I tried replacing it there. Logged out, restarted, and it spit it out again. End.



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
# generated from default
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8500 GT"
Option "NoLogo" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "1024x768 +0+0; 800x600 +0+0" (the one I replaced)
# Removed Option "metamodes" "1440x900 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
Yeah, I'm new to Ubuntu and linux in general but I don't feel that my problems are any different than what I've seen in the threads. I hope I've been sufficiently thorough. I have a feeling this is going to be a VERY simple oversight on my part. I do appreciate any and all help with this. I'd like to keep learning how to work this thing. Thanks.