PDA

View Full Version : [ubuntu] D-link 140 wireless - stopped working after update



thorezzz
September 19th, 2009, 11:07 PM
I recently bought a D-link 140 for my ubuntu desktop pc, and after some searching around I got it working with a driver from ralink.com after i found out my usb had a rt2870 chipset.

Everything was running smoothly untill I decided to update, this is a computer I have been away from, for over a year,so when I upgraded i got to Ubuntu Hardy Heron..with a kernel 2.6.24-24 now. The driver stopped working,and I tried downloading the latest driver from ralink.com v.2.2 and followed the instructions as good as I could. And the USB is flashing its orange lights which is good, i get my wireless connection deteced in network manager, i can logged my self onto it, and it even gives me a signal. which is 70 % (good) and stays this frozen,no more no less. but the thing is i cannot get any pages loaded in my browser. which looks like Im not connected to the internet at all. I have been using ubuntu for a couple of years, not a savvy guy or anything. Ive tried my best, spent hours reading manuals and searching forums and trying alternate methods but no luck.

This is my last resort, I am going crazy trying to figure this thing out. Please if you have the time, help :)