PDA

View Full Version : [ubuntu] How to fix the Mini 10v Touchpad in Jaunty



Tyrathect
September 19th, 2009, 06:35 PM
This solution comes from the other thread on this and other forums. This turns out to be pretty easy because the code is already written, it's just not on the canonical distro.

The fix is easy, I just wrote it wordy so that everyone could follow it.

So, to fix it in ubuntu 9.04 (jaunty), do the following:

Use the ubuntu desktop menu system to open System/Administration/Synaptic Package Manager

in the package manager menu, select Settings/Repositories this will open a new dialog

First we're going tell the package manager where to find the new update.

select the Third Party Software tab, and click the +Add button in the lower left corner.

copy and paste the following into the APT line box:

deb http://ppa.launchpad.net/albertomilone/ppa/ubuntu jaunty main

Then click +Add Source button to make the change.

Now click the Updates tab, and make sure Pre-Release updates (jaunty-proposed) is checked (I'm not sure if this is necessary, but better safe than sorry).

Click the Close button in the lower right corner of the settings dialog to close it.

Now we need to tell the system that the packages in the new repository are safe to download. We do that by telling the system where it can download a security key.

open a terminal window from the desktop menu by selecting Application/Accessories/Terminal

In the terminal window, cut and paste the following (you can use ctrl-shift-v to paste into the terminal):

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 99C0198F

press return to enter the command, and enter your password. When the command completes, return to the synaptic package manager and press the blue Reload button in the upper left corner of the package manager.

Now the package manager is aware of the new code, we just have to tell it that we want to use the new code.

Cick on the Search button in the package manager, and type in the following:

xorg-input-synaptic

Then click Search.

There should be one result, xserver-xorg-input-synaptics and under latest version it should say something like 0.99.3-2ubuntu4netbook1

right click that line (or left click the green check box on the left side) and choose Mark for upgrade.

A new dialog will come up, click the Mark button.

After the dialog goes away, click the Apply button.

Once the installation completes, there's a few last things we should do.

We want to make sure that you don't accidentally get any other updates from that repository, so we're going to stop package manager from looking there.

Open up the repositories dialog again with Settings/Repositories from the package manager menu.

Choose the Third-Party-Software tab and uncheck the line with ppa.launchpad.net in it.

Now go to the Updates tab, and uncheck pre-released updates

close the settings dialog.

Now click the Reload button again so that your local files are up to date.

close the package manager

Now reboot and (hopefully) your trackpad will be working!

good luck.

thenickster
September 22nd, 2009, 01:28 AM
Spot on walkthrough!

Just tried it on my Mini 10v and, although I use an external mouse most of the time, it's good to have the trackpad working properly.

Cheers.

plopper2
September 23rd, 2009, 08:51 AM
When typing in
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 99C0198F
in the terminal I am getting an error

"gpg keyserver timed out
"gpg: keyserver receive failed: keyserver error"

I am on a a wireless don't know if that would make any difference. Thanks for the help.

plopper2
September 23rd, 2009, 09:13 AM
Tried it again and it connected. Thanks again touchpad works awesome. :)

franklin_m
September 26th, 2009, 12:11 PM
I just did it as well...and it works awesome! Thanks.

Frank

thebleublurr
October 6th, 2009, 05:15 PM
This is an amazing fix. I am wondering whether there is a way to do this for Windows 7, as I am dual-booting and would love this functionality on my other OS! Please reply.

thebleublurr
October 6th, 2009, 05:21 PM
I double posted and can't delete this, sorry.

mechanic
October 26th, 2009, 01:04 PM
So does this add a .fdi file to the /etc/hal/fdi/policy/ directory or what? If so please post it! I take it it doesn't tinker with the xorg.conf file!!

JayUK20
December 3rd, 2010, 05:58 PM
is there a way to make this work because i cannot see an upgrade option for xserver-xorg-input-synaptic

jsiret
December 26th, 2010, 04:01 PM
Hello,

Should this also work on 10.04, trying to keep this clean.

Regards

anilakar
December 2nd, 2011, 10:41 AM
Apologies for bumping an old thread, but this is still the top result in Google if you search for "ubuntu disable touchpad bottom edge". The PPAs mentioned earlier only have packages up to Lucid, and as of writing this, Oneiric is the latest release of Ubuntu. The Mini 10v might not be able to run Unity, but there are dozens of other laptops out there whose mouse buttons have been embedded into the touchpad. The synaptics pad on my Lenovo E325 is rather horrible example of this.

Without installing the patched driver, it is possible to disable the bottom edge by typing the following in the console:


synclient AreaBottomEdge=4500

However, resting one's finger on the edge area disables the touchpad movement altogether, and it's impossible to cover large areas by tap-dragging. Alternatively it is possible to cheat by pressing the button with something non-capacitive such as a plastic ballpoint pen.

Is there a working solution or are people forced to carry external mice with their netbooks?