PDA

View Full Version : [ubuntu] flash 9 stops working intermittently



v1nsai
September 18th, 2009, 06:32 PM
I've had this problem on both Debian and Ubuntu, this seems to be a problem with the flash 9 plugin in the repos. The problem can be fixed by restarting, so it's only an inconvenience but I'd still like to fix it.

I tried the instructions here (http://ubuntuforums.org/showthread.php?t=772490) for installing flash player 10 (I'm using Hardy 64-bit) but it didn't work and the instructions said not to try anything else but to post some info and blah blah I don't even know if flash 10 will have the same problem so I stopped.

Has anyone had this problem and fixed it by upgrading to 10? Or know anything I could try to make 9 work? Thanks :-D

ozzman2
September 26th, 2009, 06:43 AM
I've got the same intermittent problem (using Ubuntu 8.04 64bit).

I just get a white box in leu of video - but the sound still comes through. Sometimes reloading the page a couple times resolves it, other times I have to restart Firefox.

If anybody has an answer to this, I'd love to hear it too.
Thanks

v1nsai
October 13th, 2009, 07:46 AM
Maybe it's a 64-bit issue? Both Debian and Ubuntu that I used were 64 bit. It's annoying, but easily solved. If you force quit firefox it will restore your session, even if you only had one tab open, it only takes a second.

v1nsai
November 6th, 2009, 06:21 PM
I'm also having problems with flash ads growing to huge sizes and taking up the whole screen, and when I right-click or click on something that causes a menu to come up (like in facebook) if it's near a flash window instead of covering the window the flash window will cover my menu -_-

I've been trying to get gnash to work, I don't like having to click to make swfdec work. I've installed mozilla-plugin-gnash but I still don't see anything for gnash. Does gnash work any better than the nonfree plugin and could someone suggest why this might not be working for me?

v1nsai
November 18th, 2009, 05:49 PM
Bumping, have tried using the 32-bit flash 10 plugin also. Firefox saw it under 'Plugins' but it didn't actually run any videos. Still can't get Gnash to work and I'm still having problems with the Flash 9 plugin.

Would really appreciate some help this has been going on for a long time and I haven't been able to get anything to work

v1nsai
December 9th, 2009, 08:26 AM
I'm an idiot. You have to uninstall the 'flashplayer-nonfree' plugin in order to get anything else to work.

Uninstalled the adobe plugin, installed 'mozilla-plugin-gnash' and it's working great. Hoping this will keep working longer than adobe's. I are happy :)