PDA

View Full Version : [ubuntu] "Install Package" button disabled in Package installer for TrueCrypt



vladu
September 17th, 2009, 03:06 PM
Hi,

I was trying to install TrueCrypt the other day, but the Install Package button is disabled in the package installer. You can check it out on http://www.truecrypt.org/downloads where you will download a binary which extracts the deb file.

Does anyone have a workaround this issue?

Soul-Sing
September 17th, 2009, 04:41 PM
Try this: http://ubuntuforums.org/showthread.php?t=1190053&highlight=truecrypt

vladu
September 18th, 2009, 12:47 PM
I had run the script with

sudo sh truecrypt-6.2a-setup-ubuntu-x86
but i forgot to mention. Even so, the package installer behaves the same, it keeps the install button disabled.

Soul-Sing
September 18th, 2009, 03:06 PM
You should not use the "deb" file.

vladu
September 19th, 2009, 03:24 PM
You should not use the "deb" file.

The installer is really weird - it's easier to see why if you try it yourself. Anyway, it gives you two options:

1. You can either extract the .deb file and it then puts it into /temp or
2. You can "install" TrueCrypt which first leads you to a message showing you the license. If you accept, it automatically launches the same .deb file which I presume it also extracts in /temp.

So basically there's no way around the disabled install button.

Soul-Sing
September 19th, 2009, 03:35 PM
I did several truecrypt installs, can't remember this as an issue.
Sorry...Maybe someone else?

vladu
September 20th, 2009, 01:03 PM
Should I report this as a bug in Package installer - gdebi-gtk? After all, the TrueCrypt installer only unpacks a .deb file and launches it.

ChrisWebb
September 24th, 2009, 10:28 PM
I can confirm the same behaviour - Ubuntu Jaunty 64 bit. Guess it's a problem with the deb file.