View Full Version : [ubuntu] Upgraded from 9.04 to 9.10: DNS problems

September 16th, 2009, 03:54 PM
Hi there!

Today I upgraded from 9.04 to 9.10 via "update-manager -d".

The process went smooth and fine, the only problem is that now my PC can connect to my network but can't surf the web...

After some trials and searches I've found a temporary solution by editing the "/etc/resolv.conf" file and adding a line like:

nameserver xxx.xxx.xxx.xxx

with the IP address of my DNS (the file was originally empty, only a commented line saying "Generated by NetworkManager")

The problem is that the system by itself tries to revert back to the empty resolv.conf file (for sure at each reboot, but I suspect even during normal operation) and so I'm back to my problem :-(

Any suggestion is welcome!

Thanks and Ciao


September 16th, 2009, 04:19 PM
Sounds like it isn't getting nameservers from dhcp

November 1st, 2009, 07:21 PM
I am having a similar problem on a freshly installed 9.10 system. My system is a little different in that I am using vlan interfaces (e.g. eth0.16). When I reboot, my /etc/resolv.conf contains only the line:

# Generated by NetworkManager

When I open the Network Manager applet, it shows the vlan interfaces, showing each as "ifupdown (eth0.16)" for example, with last used indicated as "never". I am unable to edit these.

It appears that network manager is re-writing the /etc/resolv.conf file on every boot.

Is there anything unusual about your network configuration? Do you see that line in the file after restarting?

- Bob

November 1st, 2009, 07:35 PM
Hi, I have exactly the same problem as you do.

I've upgraded from 9.04, after the reboot I noticed that the network doesn't work.
I simply can't ping e.g. www.google.com or else.
What I've found is that it's some problem with DNS name resolving, because when I ping some external IP address of mine ISP, the result is positive, but I can't make it through the DNS names.
That DNS resolving simply doesn't work. What else I've found is, that I must restart the network using '/etc/init.d/networking restart' to make it work.
Anyway, after another restart I must make it again and again.
What I've found in that networking script is, that the restart function executes only the 'ifdown -a' and after it the 'ifup -a' commands.
After these steps my connection works fine again, even with using the DNS.

And the "resolv.conf" contains this: "generated by resolvconf"
I even tried to uninstall the "Network Manager", but with no change.

Hemanth S A
November 3rd, 2009, 01:25 PM
Sure this sounds like a DNS resolving problem. I can ping the servers, I can open some of the pages using the IP Address.

November 3rd, 2009, 01:32 PM
I too have this issue. And my current solution was to restore a 9.04 Jaunty image.

Is there a permanent solution to this?

November 3rd, 2009, 06:31 PM

works for me.

November 3rd, 2009, 10:00 PM

works for me.

Does NOT for me. :(

November 3rd, 2009, 10:49 PM
Does NOT for me. :(

after the procedure you still have your resolv.conf rewritten?

November 4th, 2009, 12:22 AM
Removing network manager worked for my particular machine. It would be less of an option if these were happening on my laptop, however. There seems to be a disconnect between how Network Manager and /etc/network/interfaces work together. While there's an Add button in NM, there's no way to tell it what network interface to tie to. Odd that it seems to have broken between 9.10 and the earlier versions.

November 4th, 2009, 05:38 PM
after the procedure you still have your resolv.conf rewritten?

you were right, I forgot to fill up the resolv.conf after the removal.
my apology. problem solved.
thx for the help.

November 4th, 2009, 06:46 PM
I too have this issue. And my current solution was to restore a 9.04 Jaunty image.

Is there a permanent solution to this?

I also had this problem, only resolved by restoring Jaunty. It seems Network Manager in 9.10 is not correctly configuring my wireless router (BT HomeHub). Firefox fails to find any web addresses and I couldn't download WiDC which has been suggested as a solution to this problem.

November 4th, 2009, 11:21 PM
This problem is a DNS lookup issue with certain routers. The network-manager automatically configures your network to ask your router for DNS lookups first. If your router doesn't support ipv6 lookups, it has to timeout.

A solution to this is to put your own or your ISPs DNS servers in resolv.conf. Unfortunately Network-manager will overwrite these.

The best solution I have found is:

Hook your computer directly to modem
sudo apt-get remove network-manager
sudo apt-get install wicd
On wired connection on wicd select DHCP addresses only
Add your DNS entries to /etc/resolv.conf
Restart your PC, and reconnect it to the router.

November 8th, 2009, 11:02 AM
follow this thread. i've done it and succesfull


and you can disable ipv6 in mozilla too to make mozilla respond faster.

about:config in mozilla.